Solved

No password for additional server

Posted on 2002-03-25
13
412 Views
Last Modified: 2013-12-18
Hi,

Is there anywhere one can setup the additional server without a password? l tried setting the password sensitivity level to zero when registering the new server, but it would not allow blank password.

l have my additional server install on a LINUX server, and it's quite cumbersome to always have to key-in the password whenever the linux server reboot. It would be nice if it can start up the domino server just like the first server.

Any suggestion on what can be done to overcome this problem?

Thxs in advance.
0
Comment
Question by:mikeckt
  • 5
  • 3
  • 3
  • +1
13 Comments
 
LVL 10

Accepted Solution

by:
zvonko earned 25 total points
ID: 6896004
Hello,

when you create a server.id for this additional server, then is at Basic options dialog, below the servers name are two fields: Password and PasswordQualityScale
You have to enter a password, but you can let PasswordQualityScale at zero.

After creating server.id with a password and letting PasswordQualityScale at zero, you can open the id file in the IdProperties dialog.
At Basic options dialog page are two buttons: SetPassword and ClearPassword
For this IdProperties dialog you have not even to start the Administrator. You can do it in every clients menue: File->Tools->UserID
Of course you have to change first from your user.id to server.it in client. Better option is to do it directly in Administrator.

The ClearPassword is grayed if at registration time the PasswordQualityScale was set higher then zero.


Good luck,
zvonko

0
 
LVL 1

Assisted Solution

by:McSlacks
McSlacks earned 25 total points
ID: 6896005
Just copy the Id from your server to a workstation where you have a notes client. Then switch user id to that id.

Then file-tools-user id-set password, and clear password. Just make sure you set the password sensitivity to 0.When you add the server.

Cheers,
Toshio
0
 
LVL 10

Expert Comment

by:zvonko
ID: 6896006
hi Toshio :-)
0
 

Author Comment

by:mikeckt
ID: 6898311
first, thxs for the help.

just one extra question.....how does one setup the domino server to run as a service on a Linux O/S just like the way it is done on a NT server? how does one shutdown the domino server should it be able to start as a service?

Any clue to the problem?

thxs.
0
 
LVL 1

Expert Comment

by:McSlacks
ID: 6898589
Easy,

You can set it as a daemon like this

$server > /dev/null  &

You could also redirect input and output of the server. Beware of big logs if you redirect to a file.

$server -q

Will shutdown the server.

Cheers,
Toshio

0
 
LVL 10

Expert Comment

by:zvonko
ID: 6899024
Sorry Toshio, again me :-)

Piping the output to null is a waste of possibilities :-)

The important char on Toshio's proposal is the last char starting the server as a background process (the "&" char)
We do on S/390 (also a POSIX UNIX subsystem) start the server with assigned input and output files (and the background char).
This start method offers the possibility anytime asynchronously to assign and release the console.

Are you interested in this one-liner commands?

(I am not talking about Domino rconsole command)

0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 10

Expert Comment

by:zvonko
ID: 6899145
I fetched the lines from my server :-)

It is a bigger procedure to check running processes, shared memory and semaphores, but finaly is the server started with this line:
nohup /u/prog/lotus/bin/latest/sever /notesdata < /tmp/console.input > /tmp/console.output 2>& 1 &

Because the server is started wht redirection of console output to /tmp/console.output, we can anytime from another telnet session (with apropriate rights :-), do this command (parametrized in a shell script of course :-)
tail -f /tmp/console.output &

This tail command give us every new line of console output for hours and days; until we kill this tail background process.

Also easy is to enter new commands to the server. We add new lines into servers console input file and they are executed. Adding is simple done by a shell script with one line:
echo "$@" >> /tmp/console.input

And one word to amount of console output data. We have a very verbouse setting for our Domino console and can run for weeks. With such megs and gigs of other data is the console text output the least problem :-)





0
 

Author Comment

by:mikeckt
ID: 6901400
To Toshio & zvonko,

l tried both methods suggested, and depending on the circumstances, sometime work and sometime not.

If l up the server after login to 'notes' using either methods, the shutdown process will work i.e. either issuing the command 'server -q' or 'echo "q" >> /home/notes/console.input'.

However, if l up the server as one of the bootup-process in the startup directory (/etc/rc3.d), the shutdown process will work partially only i.e. it will not completely shutdown all the domino processes.

The following is the content of my startup script file in /etc/rc3.d:

#--- Tohsio's version ---

#!/bin/sh
case $1 in
'start')
       su -c "cd /local/notesdata; /opt/lotus/bin/server > /dev/null &" notes
;;
esac
exit 0

#--- zvonko's version ---

#!/bin/sh
case $1 in
'start')
       su -c "cd /local/notesdata; nohup /opt/lotus/bin/server < /home/notes/console.input > /home/notes/console.output 2>&1 &" notes
;;
esac
exit 0

When l tried to shutdown the domino server by logging in as 'notes' user, it gives me the following message:

#--- Using 'server -q' method ---

The "Waiting for processes to exit" message will continue to display on the screen. The "Server shutdown complete" message will never appear.

#--- Using 'echo "q" >> /home/notes/console.input' method ---

03/28/2002 11:03:08 AM  Starting Server shutdown
03/28/2002 11:03:08 AM  Schedule Manager shutdown complete
03/28/2002 11:03:08 AM  Administration Process shutdown
03/28/2002 11:03:08 AM  Database Replicator shutdown
03/28/2002 11:03:08 AM  Index update process shutdown
03/28/2002 11:03:09 AM  Calendar Connector shutdown
03/28/2002 11:03:09 AM  DECS Server shutdown complete
03/28/2002 11:03:09 AM  Router: Shutdown is in progress
03/28/2002 11:03:10 AM  Mail Router shutdown
03/28/2002 11:03:11 AM  Event Monitor shutdown
03/28/2002 11:03:19 AM  Stats agent shutdown
03/28/2002 11:08:08 AM  AMgr: Some Executives are still active, shutdown
continue ...
03/28/2002 11:08:08 AM  Agent Manager shutdown complete



On further check the domino processes that is still running using the "ps -ax" command,

 1137 ?        SWN    0:00 /bin/sh /opt/lotus/bin/server
 1151 tty1     S      0:00 login -- notes
 1181 ?        RN     0:00 /opt/lotus/notes/latest/linux/server
 1182 ?        SN     0:00 /opt/lotus/notes/latest/linux/logasio NOTESLOGGER res
 1183 ?        SN     0:00 /opt/lotus/notes/latest/linux/logasio NOTESLOGGER res
 1184 ?        SN     0:00 /opt/lotus/notes/latest/linux/logasio NOTESLOGGER res
 1185 ?        SN     0:00 /opt/lotus/notes/latest/linux/logasio NOTESLOGGER res
 1186 ?        SN     0:00 /opt/lotus/notes/latest/linux/server
 1187 ?        SN     0:00 /opt/lotus/notes/latest/linux/server
 1195 ?        SN     0:02 /opt/lotus/notes/latest/linux/amgr
 1196 ?        RN     3:00 /opt/lotus/notes/latest/linux/amgr -e 1
 1216 ?        SN     0:00 /opt/lotus/notes/latest/linux/http


In order to completely kill all the domino processes, l would need to run the command "/opt/lotus/bin/nsd -kill"; sometime more than once.

Any idea what's going on? :-)
0
 
LVL 1

Expert Comment

by:McSlacks
ID: 6901916
I have written a BETA startup script for Domino on Solaris. If you are interested, let me know this way you can check the script yourself.

As for `server -q' that *should* work, it works great here. Never redirect your `domino-in-console' it is not safe. Use `cconsole' instead.

T.
0
 

Author Comment

by:mikeckt
ID: 6901969
Hi Toshio

If you don't mind, yes l am interested in your beta startup script. Perhaps, you can email it to me at michael@srikom.com.my. Thanks for help.

By the way, the command 'server -q' does work great as long as the command 'server > /dev/null &' is not started during the machine bootup. l don't quite understand your remark regarding the "redirect your 'domino-in-console'" & the 'cconsole' command. Is there any article in regard to the 'cconsole' command?

Thxs in advance.

0
 
LVL 10

Expert Comment

by:zvonko
ID: 6910686
0
 
LVL 63

Expert Comment

by:Zvonko
ID: 10840468
mikeckt,
No comment has been added to this question in more than 746 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:

RECOMMENDATION: split points between zvonko http:#6896004 and McSlacks http:#6896005

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Zvonko
EE Cleanup Volunteer
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now