Solved

Localhost 8080 (portnumber)

Posted on 2002-03-26
29
3,318 Views
Last Modified: 2009-07-29
How come I cannot access the page without putting the port number 8080 eg: http://ipaddress/foldername only and when i put the path http://ipaddress:8080/foldername then only the data from the MS SQL Server can be able to access/retrieve properly
0
Comment
Question by:ueiki
  • 16
  • 6
  • 3
  • +4
29 Comments
 
LVL 33

Expert Comment

by:knightEknight
ID: 6896364
the web server on that IP address is listening on port 8080 instead of port 80 (which is the default HTTP port).  This is probably configurable on the web server or application server.
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 6896976
knightEknight is absolutely right.. configure your webserver/servlet engine to listen to port 80 and then you won't need the port num

CJ
0
 
LVL 6

Expert Comment

by:kotan
ID: 6898151
Yes! Both of them right.
If you are using tomcat, you can edit the file {tomcat_path}/conf/server.xml

Go to line

<Connector className="org.apache.tomcat.service.PoolTcpConnector">
  <Parameter name="handler"
    value="org.apache.tomcat.service.http.HttpConnectionHandler"/>
  <Parameter name="port"
    value="8080"/>
</Connector>
Then change 8080 to 80.
0
 

Author Comment

by:ueiki
ID: 6898158
I have change the portnumber to 80 (using tomcat 3.3) but now the http://ipaddress cannot go into the first page of the tomcat main but when I am using tomcat 2.1 when I make changes to the portnumber to 80 then it can work. Can anyone tell me what can I do to resolve this problem using tomcat 3.3? What other changes must I make to the server.xml or other files?
0
 

Author Comment

by:ueiki
ID: 6898184
<Http10Connector   port="8080" <---has change to 80
secure="false"
maxThreads="100"
maxSpareThreads="50"
minSpareThreads="10" />
then the page would not be found if change back to 8080 then it can find the path

<Ajp12Connector      port="8007" /> <---Does this connector need to change the port to 80 also???
0
 
LVL 2

Expert Comment

by:coreyit
ID: 6898520
If you do change your tomcat port to 80, remember that you need to make sure that no other process (Apache perhaps) is running on that port. When you stop and restart Tomcat, if something else is runnig on that port, it should give some sort of error message regarding its inability to bind to port 80.


In response to "Does this connector need to change the port to 80 also???,"
no.

-corey
0
 

Author Comment

by:ueiki
ID: 6898615
hmm...there is no error regarding the inability to bind to port 80, and there is no other programs running the apache tomcat if i put the port 8080 then the information will be displayed if not the information would not be able to retrieve from the database without the 8080...is it because of the session beans?
0
 

Author Comment

by:ueiki
ID: 6898635
sorry there is one error when I run the tomcat frontend the error is JVM_Bind, how can I find out which program is running from the localhost port 80?? Previously I have shut down the cold fusion server but it does not affect the binding of the port
0
 

Author Comment

by:ueiki
ID: 6898655
the error is java.lang.reflect.InvocationTargetException:
org.apache.tomcat.core.TomcatException:
Root Cause - Address in use : JVM_Bind
0
 
LVL 2

Expert Comment

by:coreyit
ID: 6898707
To see that something is in fact running on that port, open a DOS command prompt window and type:
    netstat -ao
This should give you a list of ports being listened to (note that port 80 may show as machine:http rather than machine:80). There should also be a column called "PID" which lists the process IDs. If you open your Windows Task Manager, select "View - Select Columns - PID", then click the "Processes" tab, you should be able to match the Process ID to an application (Apache.exe for example).

Most likely, you are running the Apache HTTP server (or some other HTTP server). Port 80 is typically used for that purpose. It may be that your system has the HTTP server starting automatically, as a service; in which case, you may not have known it was running.

In any event, if you want Tomcat to run on port 80 (which simply allows you to remove the :8080 from the uri), you will need to stop whatever it is that is running on that port first. You may be able to see this in your list of running processes, or perhaps in the list of active services.

Another option is to configure Apache to "talk to" Tomcat. In this way, Apache would listen on port 80 still, but whenever it received a request for a servlet (incl. jsp pages) it would forward control to Tomcat.

"Integrating Tomcat with a Web Server" document is available at http://jakarta.apache.org/tomcat/tomcat-3.3-doc/index.html

-corey
0
 

Author Comment

by:ueiki
ID: 6898759
How do you guys upload the files onto the website so that it will show eg : http://www.example.com without the port 8080 (http://www.example.com:8080)? is it due to the binding problem or ??? sorry really need help on that
0
 

Author Comment

by:ueiki
ID: 6898760
How do you guys upload the files onto the website so that it will show eg : http://www.example.com without the port 8080 (http://www.example.com:8080)? is it due to the binding problem or ??? sorry really need help on that
0
 
LVL 2

Expert Comment

by:coreyit
ID: 6898803
The reason that the port number is not generally necessary in the url is because port 80 is listened to by default for http requests. (http://www.google.com == http://www.google.com:80 and the same is true for other sites). So, if you want to be able to browse your site without using a port number, it needs to be available on port 80.

The reason that you are not able to get Tomcat to run on port 80 (which as discussed is possibly one solution to your problem), is that something else is running on port 80. Only one is allowed to do so. This is where the binding problem comes in. When you change your Tomcat configuration to listen on port 80 instead of 8080, it complains that it cannot bind to that port because something else is using it. No way around that without stopping whatever else is using it.

I should take an aside here briefly to note that it's also *possible* that Tomcat is complaining because *it* is already running on that port. This would have happened if you managed to get it running on port 80 and then tried to start it again without stopping first. If so, you should be able to browse to http://localhost/ and see the Tomcat (not Apache or other) success page.

Otherwise, if you find that whatever is running on port 80 needs to continue to do so (or that you want it to), you'll have to configure Tomcat to work with the HTTP server that is listening on that port (see above).

cheers,
corey
0
 

Author Comment

by:ueiki
ID: 6901091
I read already but don't really understand how to configure apache to talk to tomcat? Do you have any other websites that explain simplier on that? Thanksz
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:ueiki
ID: 6901375
I found out that as I had some service running on Port 80.
Services included: World Wide Web Publishing Service, FTP Publishing Service, IIS Admin Service and also Cold Fusion running on port 80 too.. Is there any way that without disabling the above service but yet still managed to allow my Apache to take control of port 80. I already read up the article you had asked me to refer to. The problem is I do not really understand what the article is talking about.
Or can i change the services to enable it to use other port no.?
0
 

Author Comment

by:ueiki
ID: 6902018
I have edited this httpd.conf at the end of this line
Include C:/Tomcat/jakarta-tomcat-3.3/conf/jk/mod_jk.conf

LoadModule    jk_module  libexec/mod_jk.so
AddModule     mod_jk.c
JkWorkersFile C:\Tomcat\jakarta-tomcat-3.3\conf\jk\workers.properties
JkLogFile     /usr/local/apache/logs/mod_jk.log
JkLogLevel    info

So is there other things to edit?
0
 

Author Comment

by:ueiki
ID: 6902035
is it that run tomcat first then run the apache??? the apache port number change to 80 or tomcat httpconnector change to 80 or both also change to 80??
0
 

Author Comment

by:ueiki
ID: 6902079
How do I know that my apache is already talking to the tomcat
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 6902842
if apache is talking to tomcat.. you will be able to access your servlets/jsps on port 80 instead of port 8080.

CJ
0
 

Author Comment

by:ueiki
ID: 6904300
is it both programs must be run together which one run first??? how do you actually configure apache talking to tomcat?? the http://localhost should be apache one or tomcat one???
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 6904985
Usually you should start up Apache and then Tomcat.  Yes both need to be running

for easy instruction go here:
http://www.verysimple.com/scripts/support_tc_apache.html
or the official apache docs:
http://jakarta.apache.org/tomcat/tomcat-3.2-doc/tomcat-apache-howto.html
0
 

Author Comment

by:ueiki
ID: 6906317
I have done the step from step 1 - step 9 but the tomcat-apache.conf did not create when I started my tomcat ?
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 6906394
So Tomcat hasn't run successfully?
0
 

Author Comment

by:ueiki
ID: 6909533
it is running but there isnt any conf file create for the tomcat and apache? so does the port 8080 do with the dns domain ?? i heard from someone else that you will still be able to upload the folder with the port 8080 as the dns will hide the port number? or something like that? Is that so???
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 6910261
I am not sure I follow...
0
 

Author Comment

by:ueiki
ID: 6911926
my supervisor manage to solve the problem herself by adding something to the uri file she also not sure done by her bf so she has manage to upload the folder herself...anyway thanks to you guys for your suggestions
0
 
LVL 49

Expert Comment

by:DanRollins
ID: 7087454
Hi ueiki,
You've requested to delete this question, but its status has remained as 'Pending Delete' because one or more comments have been added.  Normally, the only way to fully delete such a Question is to post a message to Community Support and ask for assistance.

EE is making a one-time database sweep to purge the Pending Delete Questions automatically.  During this sweep:

    ueiki -- To allow the deletion to proceed:  Do nothing.
    EXPERTS -- Please DON'T POST a comment except to contest this deletion.

In the future, please refer to http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp#8 for instruction on deleting questions.

DanRollins -- EE database cleanup volunteer
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 7089129
I don't believe this question should be deleted.  User found their own solution but there is a lot of good info here so I think it is should be PAQd.

CJ
0
 
LVL 1

Accepted Solution

by:
Moondancer earned 0 total points
ID: 7110570
Thank you, 100 points refunded and PAQd vs. deleted.
Moondancer - EE Moderator
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now