• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 452
  • Last Modified:

Printing from dos programs

Am using a Novell networked printer, When printing from a dos based program I have the following error..

Error Term\2014 create error .\lpt1.prn
        (dos error 3)
      quit retry default

If I click on default it prints but it ends the program.
Have used NET USE command to capture the lpt1 port but I still have the same error.
0
robtall
Asked:
robtall
  • 5
  • 3
  • 2
  • +6
1 Solution
 
SteveGTRCommented:
I access a Novell networked printer when printing from DOS programs on Windows 2000 as well. I utilize NET USE. I see that you are and still get this error? Here is how I do it:

net use LPT1: \\my_server\server_printq

Good Luck,
Steve
0
 
robtallAuthor Commented:
HAVE TRIED THIS BUT STILL HAVE THE SAME PROBLEM. I HAVE ALSO TRIED TO CAPTURE THE PORT THROUGH NOVELL AND THIS DOESN'T WORK EITHER
0
 
Gareth GudgerCommented:
Does it print fine outside of DOS to the Novell printer?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
SteveGTRCommented:
You sure you have the net use set up correctly? Try to print from DOS like so:

dir > \\my_server\server_printq

DOS error 3 is "Path not found".

robtall... lower your case when you reply to comments. All uppercase is considered yelling and is rude :)
0
 
robtallAuthor Commented:
Sorry for uppercase

Am printing outside of dos with no problem

The connection is via the tree and not the server.
The dir command comes back with specified path is invaild.
Doing dir > lpt1 works ( which is across the netware ), Lpt1 is showing on the net use command as being attached to the printer.
0
 
geoffrynCommented:
Are you using the MS client or the Novell client?  Did you try the capture command?
0
 
SteveGTRCommented:
Do you have the print queue configured on the control panel printers applet?
0
 
robtallAuthor Commented:
Yes the print queue is configured
0
 
msknightCommented:
In your Novell client, there should have been an extra component to allow bi-directional communication with the printer - at the point of installing the client.  Fire up the Novell client installation routine and see which options are available.

It sounds like the program itself is trying to use it's own checking routine to make sure that the printer is actually there - and you may need that component active (I don't think it's part of the "typical" Novell Client installation.

Michelle.
0
 
alexanderpetrusaCommented:
You should have administrator rights to do this...

1. Install your printer as it would be local, on LPT1 (uncheck the Automatically Detect and Install...), and set it as Default.
2. Close the Add Printer window.
3. Click right on the small red N icon from the task bar, and choose Novell Capture Printer Port.
4. Leave the LPT1 as it is.
5. Browse the network to your printer, and make sure you choose the printer queue, NOT the printer server.
6. Check "To always capture..."
It should do the trick...
0
 
robtallAuthor Commented:
Sorry for delay on install of novell client there is no Bi-directional communication with printer ( the client version we are running is 4.83 )

I have also tried to install a local print and then choose the printer queue but still get the same problem.

(The dos program was created when windows 3.1 was around
0
 
jmiller47Commented:
msknight, welcome to EE! Please be respectful of other experts and please do not propose an answer until you are absolutely sure that this will fix the users problem. I have personally already posted step by step instructions as to the creation of a mirror. Whilst you have proposed an answer you have also locked the question so that no other experts may comment. Please post comments and if the user sees that it will fix their problems then they can accept it as an answer.
0
 
robtallAuthor Commented:
I didnt know the question had been locked.
0
 
jmiller47Commented:
Thanks! now it will show up in the regular list and hopefully it will get answered quicker!
0
 
ewtaylorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
[paq refund]
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
[ewtaylor]
EE Cleanup Volunteer
0
 
MindphaserCommented:
Force accepted

** Mindphaser - Community Support Moderator **
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 3
  • 2
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now