Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Routing problems with Dlink 804

Posted on 2002-03-28
15
Medium Priority
?
658 Views
Last Modified: 2008-02-01
I have got a ADSL connection with a fixed ip address.
I have got 3 pc's on my network which are connected to the internet via my hub/switch/router Dlink 804.
Getting onto the internet itself is no problem. But when I want to have a connection to the server that I installed on one of those 3 pc's it doesn't want to connect. I do not have a problem on the intranet.
I have used the configuration from Dlink. And it looks like it is pointing the right direction but it is just not letting the traffic go through. I have a firewall on the server but have turned that off to test out if it would work without.
The Dlink get the fixed ip address from my ISP and the DLink gives and local ip address to the 2 computers connected. (192.168.0.1xx)
I have tried updating the firmware but no result.
Anyone ran into this problem? Any websites with decent information on how to set it up other than what I already have done? Let me know if you need addition information as routing tables etc etc.
0
Comment
Question by:denharrow
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 3
  • 3
  • +1
15 Comments
 
LVL 17

Expert Comment

by:mikecr
ID: 6904227
When you mean connecting to a server, do you mean one of your other computers is being used as a server? How are you attempting to connect to them, mapping a drive letter to a share or just typing in a unc path?
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 6904317
So you are trying to connect from another location, through the DLink Firewall/NAT device to the server? If so, what services on the server are you trying to connect to on the server? If it is a website have you opened inbound port 80 on your DLink and redirected to the IP addresses of the server?

If you know that all this is correct do you know what IP address your ISP assigns your DLink and (2) if they use NAT and filtering.
0
 

Author Comment

by:denharrow
ID: 6904620
yes mikecr. connecting to a server is one of my own computers running as a server. It is not necessary to map a drive since it will be a standalone server with a webserver (apache) and a ftpserver (warftp)
I have tried both seperatedly and on the local network I do not have problems showing the webpage of an apache installation and the main dir of the ftp server.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:denharrow
ID: 6904629
diggisaur. I am not really trying to connect from another location but I try to connect to that server from another computer on the network but by using the WAN ip address from my ISP.
The services I am running are HTTP and FTP at this moment.
And yes I have opened ports to that machine and redirected them.

In the configuration of DLink I have used specific application support and ticked out. http and ftp server.

This is what it instructs:
---------------------------------------------------------
Basic Setup - Specific Application Support

Some applications require that ports are opened in the firewall of the DI-804. At the right is a list of common applications that require ports to be opened to function properly. Please note that these ports will be redirected only to the machine you are using to configure the unit right now. Please also note that most of these applications will only work on a single machine behind a firewall at one time. The common port(s) for the application will be opened.

Go to Open Ports if you wish to allow other applications not listed here to be accessed from the Internet or if you wish to redirect ports to other computers on your network.

Open ports are a security risk. Only open ports for applications that you use regularly. Do not open unnecessary ports.
----------------------------------------------------------

And i have done as instructed.

The way I got things set up is like this.


Internet
   |
Dlink 804--------------------------------
   |                |                    |
PC 1              PC 2                  PC 3

Where PC 1 is the one with the server applications installed.

DLink has ip 192.168.0.1
PC1 has 192.168.0.100
PC2 has 192.168.0.101
PC3 hsa 192.168.0.102

This is what it says when I telnet to the Dlink instead of using the webconfigurator

NAT Port Redirection Configuration Table:

Index  Service Name      Protocol  Public Port   Private IP        Private Port
 1     WebServer                6           80   192.168.0.100               80
 2     FTPServer                6           21   192.168.0.100               21
 3                              0            0                                0
 4                              0            0                                0
 5                              0            0                                0
 6                              0            0                                0
 7                              0            0                                0
 8                              0            0                                0
 9                              0            0                                0
10                              0            0                                0

Protocol: 0 = Disable, 6 = TCP, 17 = UDP

So it looks OK i would say. But fact is it doesn't work. I have reset the router several times. Only running the 'server' PC1 and configurated it from that pc only. Used the telnet configuration.

I would say that they use NAT and filtering. They have closed port 25. But I don't have problems with Yahoo Messenger sending files. And If i check on IRC I have got the WAN ip that I am also trying to connect through with the web and ftp server.

Hope this is helpfull


0
 
LVL 4

Accepted Solution

by:
Shep earned 600 total points
ID: 6906146
is the dlink providing ip's to the clients (dhcp)
if so, shut off dhcp and use static
enable dns, put in dns server ip's from isp
gateway is the dlink (192.168.0.1)
most cable / dsl router port forwarding does NOT work if dhcp is enabled on the router

Shep
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 6906502
Worked fine when I did it on a Linksys shep. But then I configured my server static as that is common sense and left everything else DHCP.
0
 

Author Comment

by:denharrow
ID: 6906851
Shep:

I now turned off the DHCP on my router and put ip address on all 3 computers but alas to no avail.

I don't think matters but could it perhaps be my subnet?

My ISP is on subnet 255.255.255.240 and my own network is on the usual 255.255.255.0
0
 

Author Comment

by:denharrow
ID: 6906867
Changed the subnetmask to 255.255.255.240
Didn't help.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 6907468
My ISP used 10.x.x.x with 255.255.255.248 subnets and my Linksys provided 192.168.x.x with a 255.255.255.0 subnet and I had no problems.

So you said you can connect to it directly but not with the ISPs IP address from within your personal network? If this is the case your DLink may see an access coming from a 192.168.x.x as a spoof and be blocking it. I would try from a remote location (friends house) and see if you can connect with your external IP.
0
 

Author Comment

by:denharrow
ID: 6907495
diggisaur:

I have asked 2 friends who are not with the same ISP. Actually not even in the same country to check. And they both got Server not found. Page cannot be displayed. And they checked both my web and ftp server.

I changed ISP about 2 months ago and they sold this router with their deal on broadband. I had the same type of connection with the other ISP and had a borrow CISCO router from them and that wasn't a problem. And I doubt it is the installation as I did a new installation. First I tried with a Red Hat Linux 7.2 but I am a newbie there so I thought that might have been the problem. Now I did a NT4 Server install which I do have knowledge off.
0
 
LVL 4

Expert Comment

by:Shep
ID: 6908056
post first 2 parts of isp ip
post.post.dontpost.dontpost
dont post full ip for your security
0
 

Author Comment

by:denharrow
ID: 6908508
Shep: WAN ip (ISP ip) is 80.197.xxx.xxx
0
 

Author Comment

by:denharrow
ID: 6908810
Good news and some more problems.

Both webserver and ftp server are accessible from the outside world.
I guess the dhcp configuration did the trick.
But I do have another problem. I want to run an eggdrop bot and that again in itself is not a problem but the dcc chat/send is. As you might be aware DCC send and chat don't pick just a prefined port. That is taken randomly and that needs to be answered back to the initiator.
I can telnet to it. But not dcc send and chat.

I will try and find some volunteer to help me out.
I will close this question and open a new one if need be.

Thank you all for helping.
0
 
LVL 4

Expert Comment

by:Shep
ID: 6908881
dcc chat/send use random udp ports.
the linksys cbl/dsl routers alow 1 computer to be in what it calls DMZ (demilitarized zone), which forwards all non other wise routed traffic to the one comp. example, port 80 will go to web server, port 21 to ftp server, anything other will be routed to that one dmz comp. you will need a firewall on that comp as it will not be protected by advantages of nat. not sure if dlink routers offer this feature

Shep
0
 

Author Comment

by:denharrow
ID: 6908897
there is a DMZ feature on dlink but I do not know if it works at this moment since I haven't found a volunteer yet. I think it is a bit bothersome that I always have to ask someone else with this router.

Didn't have the problem with the CISCO router I had with the other ISP. Maybe I should have bought it from them. Too bad I already got this one :/
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question