• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5310
  • Last Modified:

ntbackup error: "There is no unused media availbale with the selected type"

im trying to backup to my Travan tape backup. it was working about a week ago now i get this error msg with a brand new tape in the drive. i have tried other tapes with and with out existing media on them and it doesn't work either. when i go into computer manager and select my tape drive then physical then media i can't see anything there. i do see somthing under drives tho that says Empty. the dox i have read said i should see my tape listed under the media tree but i don't. im using Windows 2000 Sp1.
0
Jambyte
Asked:
Jambyte
  • 6
  • 4
  • 2
  • +5
1 Solution
 
Gareth GudgerCommented:
Have you allocated your tape? Each new tape needs to be allocated to a particular backup job in ntbackup.
0
 
JambyteAuthor Commented:
this is what i did:
ran NTbackup.exe
selected the backup tab
checked my c:\
selected Travan for my tape device
selected New Media
clicked Backup now
i got that error message
0
 
Gareth GudgerCommented:
I would go into Remote Storage Media in Computer Management and find the tape and try to 'Prepare' it. Then go back into ntbackup and do what you did in the last comment again.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
JambyteAuthor Commented:
i don't see Remote Storage Media.
0
 
Gareth GudgerCommented:
It should be right in Computer Management under Administrative Tools.
0
 
JambyteAuthor Commented:
this is the closet thing i can find:
Computer Management > Storage > Removable Storage > Media Pools > Remote Storage
theres nothing in that when i click on it. and theres 'Prepare' function that i can see.
0
 
AvonWyssCommented:
My default, ntbackup only uses already initialized media from the pool of empty media. To have it search all relevant pools (uninitialized etc.), specify the /UM parameter. See the help file of NTBACKUP (Index, Backup, ntbackup-Command, Command line arguments) for a detailed description of this option.
0
 
Gareth GudgerCommented:
Sorry it is the Remote Storage I meant. It may be already allocated somewhere else. See if you can find your tape in any location unallocate it and prepare it.

AvonWyss solutions works great in a single tape drive scenario and if your backup does not span more than one tape.
0
 
JambyteAuthor Commented:
i wrote my last comment wrong. i ment to say 'theres NO prepare fucntion that i can see'
0
 
AugCHCommented:
There is a /um switch which can help you. Read Q300439 from the microsoft knowledge base. (It helped me anyway!)

CHA
0
 
AvonWyssCommented:
AugCH, if you had read the other comments, you would have seen that I posted this suggestion already two days ago :-)
0
 
JambyteAuthor Commented:
/um just opend ntbackup for about 10 seconds then closed it. i still get that error when trying to backup my data.
0
 
JambyteAuthor Commented:
the strange thing is, is that this program, ntbackup.exe, was working fine last week. i've tried the same tape and a brand new tape out of the package...
0
 
aalliceCommented:
Hi Jambyte,

I have no solutions for you, but I'm having EXACTLY the same problem.  Wondering if you've solved it yet.  Please let me know how if you did.

Thanks,

Alisa
0
 
ewtaylorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
[paq refund]
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
[ewtaylor]
EE Cleanup Volunteer
0
 
MindphaserCommented:
Force accepted

** Mindphaser - Community Support Moderator **
0
 
Dcs-itCommented:
To who it may concern this is a possible solution to problem above:

No garantees
MD

Try rebuilding the RSM database:

1. Stop the RSM Service.
2. Backup the RSM databases located at %SystemRoot%\System32\NtmsData and
then delete the data in the ntmsdata folder.  
3. Restart the RSM Service, and reboot the server. This will recreate new,
empty RSM Databases.  
4. Put a new tape in, or a tape that may be deleted.
5. Go to the "properties" of the disk inside the physical locations. Uncheck
'Enable Drive'
   Hit apply & then check the 'Enable Drive' again
(This was done to reset the Flag since we had renamed the database for RSM)
6. Right click, and prepare.

- This will delete it, write a media label to it, add it to the Free Media
Pool.

- Try again, it should work now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 2
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now