web directory permission drwxr-xr-x

Hi...

Im trying to set up IKONBOARD and Im confused about setting my file permissions.  Im using ws_ftp to upload the files and it says to chmod to change the files permissions.  Isnt this a unix thing?  How do I change them through WS_FTP?  There is a button called 'DirInfo' that opens a text file with this displayed...

-rw-r--r--   1 320882712 4464  board_rules.dat
-rw-r--r--   1 320882712 4464  cgi_path.html
-rw-r--r--   1 320882712 4464  cgi_url.html
-rw-r--r--   1 320882712 4464  email_template.dat
-rw-r--r--   1 320882712 4464  global_template.html
-rw-r--r--   1 320882712 4464  help.txt
-rw-r--r--   1 320882712 4464  index.html
-rw-r--r--   1 320882712 4464  mem_groups.dat
-rw-r--r--   1 320882712 4464  mysql_schema.txt
-rw-r--r--   1 320882712 4464  news.html
-rw-r--r--   1 320882712 4464  non-cgi_path.html
-rw-r--r--   1 320882712 4464  non-cgi_url.html
-rw-r--r--   1 320882712 4464  postgres_schema.txt
-rw-r--r--   1 320882712 4464  register.html
-rw-r--r--   1 320882712 4464  ssi_templates.dat



Im supposed to chmod the directory to either '0755' or '0777'  

0755 is read write execute for the owner and read and execute for the group and everyone.  

0777 is read write execute for all users.

How do I set these?


I tried modifying the text file and saving it...but when I disconnect and reconnect...the permissions are back to where they were?
By the way....I am uploading this to a free site provided by my ISP....


puff
puffapaloozaAsked:
Who is Participating?
 
maneshrCommented:
puffapalooza,

Did you get the solution you were looking for?

Let me know.
0
 
maneshrCommented:
puffapalooza,

"..the files permissions.  Isnt this a unix thing?..."

if you mean file permissions, then the answer, is Yes, file permissions (rwx....) is a UNIX thing.

"..How do I set these?.."

Let say your local machine appears on the left hand side window of WS_FTP. The right hand side window is taken by the remote (UNIX) server.

Now, after you have uploaded the file, select the file in the right hand side window & right-click on it. You will see a floating menu bar with chmod (UNIX) in it.

Select that proper permissions that you want to give.

That it!!!

Let me know how it works for you.
0
 
puffapaloozaAuthor Commented:
Yup...sure did.  I must be on a windows server because it doesnt require me to change the file permissions and there isnt a chmod option when I right click.


thanks



puff
0
 
maneshrCommented:
puffapalooza,

"..Yup...sure did...."

Excellent!!! Glad to know you got the solution you were looking for.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.