• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 353
  • Last Modified:

macros in mde file

I have a mdb file, I made a mde file from it to prevent showing the code.
but the mde file contains some macros. how can I prevent users to show the design of these macros in the mde file.
1 Solution
In general it is a VERY bad idea to use Macros FOR ANY PURPOSE in a real Access application.  This is so for several reasons (in fact, Microsoft has indicated that they are only supporting the macro capability in Access 2000+ for backward compatability, and MS STRONGLT advises against the conscious use of macros in applications developed with Access2000 and later versions)

1) Macros cannot be debugged - there is no way to interupt the steps of a macro to evaluate what is happeing at each step.

2) as you have discovered, since macros ARE NOT code, they are not affected by the process of generating an MDE, so the macros are fully exposed in the resulting MDE file.

3)Almost without exception, a macro can be replaced by the equivalent VBA code, with generally much more flexibility and control.
For each macro name in the list of macros, right click on the macro name and choose properties. Then set the Hidden property.

On the tools menu, choose Startup. Uncheck display database window and anything else you want to change.

This will hise the macros from the average user. However, anyone proficient in Access will be able to easily get around this.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now