Set up a path for Java Compiler in Red Hat Linux 7.2

Hi all,
Recently, I have just install J2sdk1.4.0 into Red Hat Linux 7.2. I am tired of typing the long path name and I have just included the path into .bash_profile file. I dont know is this the correct way but It seems not as the path is not working. So can anyone tell me what's my mistake.

Just in case I have inserted a path into the correct file (.bash_profile), The contents of the file is as below:

#.bash_profile

PATH=$PATH: $HOME/BIN; /usr/java/j2sdk1.4.0/bin

Can anyone explain to me my mistake. and in a layman term because I am new to linux.

Thanks.

antioch_75Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
ahoffmannConnect With a Mentor Commented:
you have wrong syntax in your (listed) .bash_profile:
replace the ; (semicolon) by : (colon) in the PATH assignment (then follow jlevie's suggestions)
0
 
jlevieCommented:
Your PATH setting in .bash_profile looks okay, but that file is only read on initial login. So for the PATH to be modified you have to log out and log back in.

Making a similar change in .bashrc will take affect each time a new shell is started and is probably a better place.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.