very Slow FTP rate on Solaris 8

Hello everyone, i am facing a strange problem, you see i have a Sun 420R running Solaris 8, my problem is that when i try to ftp a 20 MB file from this machine to another it takes a very long time same if its other way around, the transfer rate is about 3k imposible to work with i even tried using NFS and that too takes an extreamly long time, i have my hme0 set to 100xFull
and my switch is set to 100xfull as well, any one have any ideas or suggestions? thanks in advance.
LVL 1
jpfrancaiAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
That behaviour is typically a result of a link speed/mode mismatch. How did you set hme0 to 100FDX? Via /etc/system? Could I see whay you used?

What switch are you connecting to and are you certain that your port is operating in 100FDX?

The other possibility is that you have a bad cable, or switch port. Have you tried other ports/cables?
0
 
Nisus091197Commented:
Hi,

Make sure the IP address of both machines are in the /etc/hosts file on each machine.

Are they on the same subnet?

Use netstat -i 5 to monitor network traffic while you are in the ftp session.

You could also use 'snoop' to keep an eye on the network traffic.

Regards, Nisus
http://www.omnimodo.com
0
 
jpfrancaiAuthor Commented:
Yes i have tried other ports, and cables, my etc system file looks like this
----
set hme:hme_adv_autoneg_cap=0
set hme:hme_adv_100T4_cap=0
set hme:hme_adv_100fdx_cap=1
set hme:hme_adv_100hdx_cap=0
set hme:hme_adv_10fdx_cap=0
set hme:hme_adv_10hdx_cap=0
* Other tuning parameters
set hme:hme_ipg1=0
set hme:hme_ipg2=0
set hme:hme_lance_mode=0
set tcp:tcp_conn_hash_size=32768
set priority_paging=1
set maxpgio=25468
set slowscan=500
set ncsize=5000
set ufs_ninode=10000

thanks for the help
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
elfieCommented:
Ar eyou're two systems in the same subnet? What is the route between the two systems (netstat -rnv).

You can always check the network setting of your system:
e.g.

#ndd /dev/hme link_status
1 ( link is UP )
# ndd /dev/hme link_speed
1 ( link speed is 100Mb )
# ndd /dev/hme link_mode
0 ( link is in half duplex mode )


0
 
jlevieCommented:
Probably a silly question, but you have rebooted since changing /etc/system, right? Changes to that file only take affect at boot.
0
 
beskyCommented:
It could be an invisible problem like late collisions on the wire.
Does the switch have any snmp support ?

There you should be able to see the statistics

On the sun box, use an undocumented oprion to netstat
netstat -k  it will dump every networking structure from the kernel

netstat -s gives you tcp statistics
0
 
jpfrancaiAuthor Commented:
Thanks for your help guys the problem was on my Cisco 4000 Switch the port was set to 100-Half duplex after set port (poort) duplex full and set port (port) speed 100
also i noticed crc's on my port afetr setting those every thing came back up OK.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.