Solved

WSH - New ActiveXObject & Persmission denied

Posted on 2002-04-05
10
358 Views
Last Modified: 2008-02-01
Im trying to create a COM object using the
myobject = New ActiveXObject([object], [remote host])

this results in a "permission denied" alert.
i get no alerts when i try to create the object locally.

the object is my own and i was wondering if i need to
change some security settings through dcomcnfg?

the code is written using jscript in a .wsf file.


best regards
akorn
0
Comment
Question by:akorn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 22

Expert Comment

by:CJ_S
ID: 6920787
A couple of things to do what you want.

On the remote host the component should have been added to Component Services (win2000 / xp) or MTS (win NT). After that you should also set permission for this object for who may access them and under which user it should be ran. (easily accomplished, check the properties of the component within MTS or Component Services).

Then the next (easy) step is to export the component. This will eventually give you an application which you will need to send to your clients. Run the program from there and the component should be created with the above code (note: only if that user has permission to).

You may need to create a new package (within MTS or Component Services) which suits your needs though...

CJ

0
 

Author Comment

by:akorn
ID: 6927848
sorry but i think i havent made myself clear.

ive already got the COM Service installed on several machines. and ive also installed the object on the clients. there is no problem running vbs or .wsf files as long as im running them locally ie.:

  Var myobject = New ActiveXObject([Object])

but for some reason the call:

  Var myobject = New ActiveXObject([Object], [Remote Host])

gives a "persmission denied" alert! ive discovered that this alert does not show if the client station is a windows 2000 server, only when im using windows 2000 pro.

also the remote server is NOT on the same domain as the client. when the server is on the same domain as the client theres no problem.

ive tried to change the "Default Authentication Level" in dcomcnfg aswell as added the users in "Default Access Permission" and "Default Launch Permissions". to no avail.

im at loss here...
0
 
LVL 22

Expert Comment

by:CJ_S
ID: 6927892
Have you tried giving Everyone (or at least the IUSR_MACHINENAME and IWAP_MACHINENAME users) launch and access permissions within component services (on the remote host)?

CJ
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:akorn
ID: 6927901
yes i have. both on the remote host and on the local one.
0
 
LVL 22

Expert Comment

by:CJ_S
ID: 6927915
Should only be done on the server.

Anyway, another thoguht. You say that when it is within the same domain then everything works correctly. This remoten server is not on the same domain. So, are you accessing it using the http port (80)?

If so you might want to give RDS a try

var mobj = New ActiveXObject("RDS.DataSpace")
var myobject = mobj.CreateObject("[Object]", "[remotehost]")

CJ
0
 

Expert Comment

by:quirkyquirky
ID: 7299413
0
 

Expert Comment

by:ComTech
ID: 7300661
This person has been suspended for multiple violations of the Member Agreement, and will reject the proposed answer, and return your question to the Active Questions List.  The Moderator Group is deleting all 388 locked questions.

These were posted by three persons:

quirkyquirky
EliteKiller
liloXwin
 
Thank you,
ComTech
CS Admin @ EE
0
 
LVL 54

Expert Comment

by:nico5038
ID: 7508169

No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
 - PAQ'd and pts removed
Please leave any comments here within the
next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER !

Nic;o)
0
 

Accepted Solution

by:
Jgould earned 0 total points
ID: 7548088
Question has been closed as per recommendation

JGould-EE Moderator
0

Featured Post

Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Batch Files - Error Handling 4 47
Help Required 3 118
Bat File Script - HELP 2 35
powershell script 9 75
Entering a date in Microsoft Access can be tricky. A typo can cause month and day to be shuffled, entering the day only causes an error, as does entering, say, day 31 in June. This article shows how an inputmask supported by code can help the user a…
In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
An introduction to basic programming syntax in Java by creating a simple program. Viewers can follow the tutorial as they create their first class in Java. Definitions and explanations about each element are given to help prepare viewers for future …
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question