Windows 2K Shutdown

My computer will not shut down in Win2K SP2.  

I don't get the "It is safe to shutdown your computer" screen and I never did so lets not go down that road.  

My computer use to shut down when I clicked "Shut down". Once it shut down Win2k the computer power would be turned off on its own as it should. This is a Gateway 1.2 GHz.

Now it just reboots! It is like I told it to reboot, when in fact, I told it to SHUT DOWN.

My system is a dual-boot system.
Windows 2000 (this one misbehaves and refuses to shut down)
Windows 98 (it shuts down when told to)

I have cable modem with an SMC Barricade router along with a Linksys wireless Access Point of which this machine controles all administrative functions.

I have updated my IE to version 6

My Win2K is on SP2

I have really maintained the system well because this is my hobby, and I have 4 computers all networked together and all working as expected, except for this one computer.

I have another machine that is dual boot but does not have the problem on this one machine has.

I suspect the Linksys Access Point USB because I really didn't notice the problem until after the wireless system was configured, but I can't really be sure.

Most of the time, since it use to work, I would simply click the "Shut Down" and walk away.  But I noticed that my computer was on the next day.  Anyway, I can't really pinpoint when it started.

If I boot the computer into Win2k Safe Mode, it will shut down as requested.  

Please help if you can.

Who is Participating?
SysExpertConnect With a Mentor Commented:
Some Hardware ( especially NIC's) cause problems when doing a shutdown.

I would get the newest drivers for your LAN NIC and see if this helps.

Also try updating all the rest of your drivers.

One more thing.

Cleanup the startup stuff. In win98/Win ME/Win XP -  Do a Start - Run - msconfig, startup Tab , or for win95 , NT or win2k,
Download the Startup COP a free pcmag utility from,,77594,.html
 Run it and it will show you everything that is listed in all the possible startup
                        places, and allow you to disable things one at a time until the problem is eliminated.
 A lot of probelms are caused by excess old baggage - programs that have not been properly  un-installed. Startup Cop will eliminate leftovers and un-wanted programs that you no longer want.
Older Antivirus programs and Norton Utilities have been known to cause problems
try disabling them also !

I hope this helps !
First two things to check -

go to Control Panel
Make sure APM is checked

Sometimes when you install a Service Patch Microsoft resets many settings back to default.

Reboot and see if that fixes the problem.  If not -

Before going to the BIOS to check your power configuration, I'd strongly encourage you to make sure your virus definitions are updated.  Your virus software is configured to scan all files.  You boot in safe mode and do a full system scan to make sure you don't have a virus that is present.  If not virus, then go into the BIOS and under the Power or Advanced tab, make sure that Power Management is turned on.
Open Regedit, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon and change the PowerdownAfterShutdown key to 1.
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

argmysterAuthor Commented:
Hi tituba2 and AvonWyss

I tried everything you both suggested and my computer still reboots instead of shutting down.

When I did a system virus scan, the only thing I got was the Iloveyou virus that was already quarantined in th Windows98 Norton quarantine.  That is one of the reasons I dual boot, its the kids partition.  My NTFS is (i hope) healthy.

Windows2K is clean I double checked the registry for any virus's and she is clean.  I do feel we getting closer to the problem.

argmysterAuthor Commented:
Let me clarify some things.

When I go to "Start", "Setting", "Control Panel" I don't see a "Power" I see "Power Options"

And when I'm in the "Power Options" there is no APM anywhere to check.  I have an "Advanced" tab, and in that tab I can do the following:

Always show icon on the taskbar
Prompt for password when computer goes off standby

Power buttons

When I press my power button on my computer:
"Power off"

When I press my sleep button on my computer:

In my BIOS, Power Management is always on, I can't shut it off or turn it on.

Hope this helps.
Try adding the Windows NT Legacy APM node. (Control Panel, Hardware, Add device, Add new device, Select from list, Legacy APM, Add the device, and complete the installation. Now you will most likely have the APM tab in the Power options.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
the PowerdownAfterShutdown key SHOULD be 0.

Right-click My Computer, and then click Properties .
On the Advanced tab, click Settings under Startup and Recovery .
Click to clear the Automatically restart check box under System failure , and then click OK .

for other problems please check this:
argmysterAuthor Commented:
AvonWyss, yuur Lagacy APM node didn't change anything, but thanks for the tip.

Omk, Ok, I changed HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
the PowerdownAfterShutdown key back to it's original setting of Zero (0) and that still didn't help.

SysExpert, I will try your download and get back with you.

Thanks everyone.
argmysterAuthor Commented:
Your advise and the nice little Startup Cop did the trick.  I updated the WAP11 Linksys Access Point driver to the most current version and that solved my problem.

I suspected it was the problem, because it seemed like this all started after I configured that hardware for this machine to manage.  

The Startup Cop is nice to use because I don't have to use the 'regedit' to stop things running at startup.  I did disable all components that started and that didn't fix it, so I knew your advise on the driver was the key.  The wireless Access Point is not a NIC, but you where on the right track.  

You see, this computer manages the wireless Access Point hardware that is connected to my router so that wireless NICs can access the Internet and network servers.  This computer is hardwired Ethernet to router, and the NIC is current.

Thanks for your help leading me in the direction I should have gone in the first place.

Great help!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.