Configuring ISA Firewall to allow RealPlayer Streaming.

I'd like to know how to configure my ISA firewall to allow internal (LAN) users to view streaming RealMedia. An ACCESS POLICY allowing PNM and RTSP has been created and allowed to ALL INTERNAL USERS. I'm still not able to stream. Help.
elvinsohAsked:
Who is Participating?
 
trathCommented:
You have to find out which port it is using and then create a new protocol definition, this must be an INBOUND protocol, because you must then create a protocol allowing its use. Ie.. When you set up the Protocol Rule you must choose the new definition you created.
0
 
SunBowCommented:
Hmmmph. Restraining temptation to slam ISA. Hmmm. OK, here is your answer:

If you have configured ISA to disallow the streaming, then you have the 'proper', the best configuration. Otherwise, what good is firewall if not helping users to get the bandwidth they need to be productive?
0
 
elvinsohAuthor Commented:
Thanks guys, but I found the solution on the ISA newsgrps

trath : the protocol def was already there I allowed PNM and SMTP but it still wasn't letting it in.

SunBow : Thanks, but this time, it IS for productivity. The guys in Transport/Distribution are using it to log onto the Transportation authority's online RoadCams to see the traffic state of major roads -> avoid congested areas.

SOLUTION
It seems there's a setting that routes all tcp requests through the proxy. This has to be disabled. Use the Send request to server option. Then set RealPlayer to use the NO HTTP PROXY option.

0
 
ALALLY1Commented:
Hi, I found the simple solution, contributed by Trath,worked  for me.This was to simply was to create a protocol rule allowing rtps and rtps server Inbound & set the Http redirector filter under "Extensions" to "send to requested web server".You may also have to set realplayer to use http ...maybe not!

Thanks again!
Anthony
 
0
 
ALALLY1Commented:
Update.
the only reliable way I found of getting the above to work (with realplayer 10) working with ISA in firewall mode was to do the following.
1)Install the firewall client.
2)Set the protocol rules for rtsp client & pnm client (&mms for good measure) to allow.
3)Under extensions set the hhtp redirector to forward to web server.
4)Manually set the hhtp proxy in realplayer preferences to the isa server.
5)This final step requires you to switch off the "ask authenticated users for identification" .(right click your server name under "server & arrays" -->properties-->"Outgoing web requests".

Streaming is 100% reliable..although you may have issues banning users using isa after that!
Thanks
Anthony
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.