Solved

HTTP 403.9 - Access Forbidden: Too many users are connected

Posted on 2002-04-08
11
49,838 Views
Last Modified: 2011-08-18
I've got IIS 5.1 running on Windows XP Professional.  The computer is on a network and does serve multiple users and people are getting the "too many users connected" error message fairly often.

The help file says to to increase the "limited to" option (or check the "unlimited" option) under "Connections" in the property sheet for the site, but all I see is the "Connection Timeout" and "HTTP Keep-Alives Enabled" options.

Is this option not actually available for XP Pro?  Or has it been moved to some other location?  (Either way, the help file is clearly out-of-synch with what's actually there... should I really be surprised?)

Please, if anyone's been through this, let me know what, if anything, I can do to adjust the number of connections supported!

Thanks!
0
Comment
Question by:hopperp
11 Comments
 
LVL 2

Accepted Solution

by:
pssiew earned 50 total points
ID: 6927041
IIS on W2K Pro or XP has a limit on the number of concurrent access.

You are only limited to 10 concurrent user access to the website hosted on W2KPro/XP Pro machines.

See article below for confirmation

http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q262632&LN=EN-US&rnk=4&SD=tech&FR=0&qry=windows%20XP&src=DHCS_MSPSS_tech_SRCH&SPR=IIS50&
0
 

Author Comment

by:hopperp
ID: 6927055
Ah... bastards!  That's what I figured, but I wasn't able to find anything to tell me for sure and didn't really have the time to spend doing too much looking.  Thanks.
0
 
LVL 2

Expert Comment

by:pssiew
ID: 6927066
No problem. I guess you will have to pay for a server OS :)
Thats MS for you
0
 

Expert Comment

by:nbfriend
ID: 7297594
Actually, a limit of ten simultaneous connections is quite generous: since each connection only lasts a split second, you should be able to serve up hundreds of files a minute with that setting.

So the reason that you get this error is probably that you allow each connection to stay alive longer than that. To turn this off (and get your web server performing much better), just do the following (in WinXP):

1. Right click on My Computer, click Manage

2. In the Computer Management Console, go under Computer Management > Services and Applications > Internet Information Service > Web Sites

3. Right click on your web site, click Properties

4. On the Web Site tab, uncheck "HTTP Keep-Alives Enabled"

Now unless you get a million hits a day, I'll bet you never see that error again. So the real problem is that this fix isn't documented anywhere, and the error message doesn't help. Enjoy!
0
 

Expert Comment

by:tysonbrown
ID: 8294134
Quite generous??!!
Can't even serve up one web page if that page has dependencies on web services running on the same server. For example. You request a page, it is served. Yay! How generous to be allowed to send a file across the wire. Now you enter login information and hit submit. The real fun starts. First, the new login verification page gets the security token for you from the Login Web Service, then sends this token to the Utilities service to determine if this user has any administrative right. The utility service then queries the resource permissions service, then for each entry queries the resource instance service, then the resource service, and finally the resource type service since this is where the determination of whether a particular resource instance is a administrative resource or not. OF course it never gets that far because the magic number of 10 connections are made (not really, but there is lag between when the connection returns from a call and when the connection handle is released by IIS), and your wonderful work for the last month returns back to 403 Access Denied. So you pull out some hairs tryin to make sure all the permissions and such are kewl. Not that I am bitter ;) But with Web Services bein pushed down developers throats, one would think that the forcers would take into account the possibility of multiple dependent web services exceeding the max on a developer workstation. Of course it all comes down to licensing, as any developmental headache with MS does. But I wouldn't say that 10 is any where near sufficient. Maybe 100. At least I could get one page to load. Heaven help me if I throw some images that download asynchronously on the page. I will prolly have to upgrade to the next $2000 web platform of a product that I can download for free under a different name (apache???)
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Expert Comment

by:icysamur
ID: 9935046
ha ha ha
Dunno what people want out of free services ... I mean come on guys you are getting a free unlimited (limited only by your hard disk size) webspace. Once the "HTTP Keep-Alives Enabled" is unchecked the problem gets more or less solved and it even reduces the burden on the connection ...... so chill out and be happy with what you have. :)

Btw the solution given by "nbfriend" is more acceptable than the one which is labelled as "Accepted answer" .... Are the solutions termed by first-come-first-served or by their usefulness? I'm new here so was just wondering :S
0
 

Expert Comment

by:shodbmx
ID: 10206796
yeah, also if you have antivirus software with script blocking running you will get this error
0
 

Expert Comment

by:mmayer2000
ID: 10761265

  I have this same problems and NOTHING WORKS except rebooting the machine that the IIS is running on!
0
 
LVL 3

Expert Comment

by:Saber37886661
ID: 11838196
I find I can fill the 10 connections in 1 click.

We are in the process of building a web application that uses iframes, lots of them. It had to be done this way unfortunetly, since we have many calls happening at the same time, 1 simple click may change 10 things, then add the fileupload factor, the fact that alot of the graphics are done in aspx, 10 connections are used in 1 click :(
0
 
LVL 6

Expert Comment

by:Jaymol
ID: 14534922
Hi - I know it's a bit irrelevant now, but I thought I'd just point out that the last comment was incorrect, in a way.

net config srv will show you network information, not w3svc information.  Use the following vbs to check the max connection settings...

Dim IIsObject
Set IIsObject = GetObject ("IIS://localhost/w3svc")
WScript.Echo ("MaxConnections = " & IIsObject.Get("MaxConnections"))
Set IIsObject = Nothing


Just stick it in a vbs file and run it using c:\windows\system32\wscript.exe (usually)

Hope this helps,

John.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Here are the symptoms: You start receiving calls from users that one of your legacy web apps isn't coming up, so you log into your IIS 5 server to check it out.  When you pull up the services, you notice that the WWW Publishing service isn't runn…
Lync server 2013 Backup Service Error ID 4049 – After File Share Migration
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now