Solved

Used Winipcfg and now can't get online

Posted on 2002-04-08
22
360 Views
Last Modified: 2013-12-28
okay, i can tell this is already going to be fun (sarcasm).  i have a cable modem and i set up a network in my house w/ a linksys router.  from time to time i lose my connection, so i switch whatever port my pc is plugged in the router to another.  sometimes it works and i get my connection back.. other times i have to reset both my router and cable modem.

okay.. so this time that i lost connection i ran winipcfg.  i did a release all and renew all when my router wasn't plugged in.  now my ip address is different than what is set for my home network (ie 168.182.32.103 instead of 192.168.1.*)

when i try release again it won't release and i get an error when i renew.  i've removed my network card from the device manager, i've physically removed the NIC from the pc... restarted.. then reinstalled the card.  nothing has worked.  i've trying to specify and ip address instead of having it dynamically select one and that didn't work either.   i'm tempted to reformat but i'd like to see if there are any other options that i don't know about before i go through with it.

thanks.
0
Comment
Question by:fatfe
  • 6
  • 4
  • 3
  • +7
22 Comments
 

Author Comment

by:fatfe
Comment Utility
basically it's "stuck" to this IP address.  is there any file or registry entry where i can go and change it?  my pc is set to dynamically obtain an address on my network.  
0
 
LVL 1

Expert Comment

by:danny_ng
Comment Utility
dear fatfe,
would you try to reinstall your windows98.and that is the fastest way you can get if you are in a hurry need of getting online.

Please let me know then

Thanks
regrds,
Danny
0
 
LVL 7

Expert Comment

by:WiZaRd
Comment Utility
can't hurt to try although may not work with all the changes you've made. restart in dos mode & type scanreg/restore at the prompt then press enter. choose a date prior to the problems occurring.
0
 
LVL 6

Expert Comment

by:bartsmit
Comment Utility
When you had the cable modem plugged directly into the PC and did a release/renew of your DHCP, the PC requested a DHCP lease from your ISP DHCP server.

Normally your PC would get a DHCP lease from your Linksys router. The PC is now patiently waiting to renew its lease with the ISP.

There are a few easy things you could try before wiping Windows and starting fresh:

- In Winipcfg do a release and then reboot. In theory this should kick off a new DHCP conversation with the Linksys.

- Set your IP stack to a static address; start, settings, control panel, network, TCP/IP for your network card, set your IP to 192.168.1.111, netmask to 255.255.255.0, default gateway to the internal IP of the Linksys (usually either 1 or 254) DNS to your ISP DNS server.

- Make sure that the DHCP server on your Linksys is working properly. You may need a static IP to be able to use the Linksys management tools.
0
 
LVL 18

Expert Comment

by:centerv
Comment Utility
The router is pretty reliable. Unless you have a bad one,
it should be pretty straight forward. Recheck your steps,
starting with being sure that the cable modem is plugged into the WAN port of the router, and assign one number to one
pc plugged in.  When you have one working well, proceed
with the next and so on.
you could start with letting the router assign the numbers,
and give yourself a chance to test the system.
Good luck.
0
 
LVL 6

Accepted Solution

by:
joe_massimino earned 100 total points
Comment Utility
Linksys is not my favorite cable modem router. I use a lot of them and I just sent three back to Linksys.

You might wantto go to Linksys.com and get to the support page where you can download the newest firware upgrade for your model.

This may fix any number of problems with your Linksys.  Before you do much else, get the firware upgraded.  If you could get through to Linksys, this is the first or second thing they are going to say to you.
0
 
LVL 41

Expert Comment

by:stevenlewis
Comment Utility
try resetting the linksys (not just a poweroff, but a reset to reset it's values to default
then go to a dos prompt and type
ipconfig /release all
reboot
0
 
LVL 6

Expert Comment

by:joe_massimino
Comment Utility
You can also bypass the DHCP and use a fixed IP on your PC's.  Thsi is useful if you want to take full advantage of the many features of your Linksys.  

Also, depending on the age of your current firmware, you may be adding new features to your Linksys after you upgrade the firmware.  So, to deal with this, you will need to download the manual that goes with the firmware you get.

                   Good luck
0
 
LVL 18

Expert Comment

by:Crash2100
Comment Utility
How often does it stop working?

When your connection stops working, can you ping websites or anything?  Try going to the dos prompt, type this and tell us what it says after each:

ping www.toast.net
ping 206.244.186.245


If restarting the router and updating the firmware doesn't help.  And if you have no problems accessing the internet when you're directly connected to the cable modem, you should contact linksys and see what they have to say.

http://www.linksys.com/contact/contact.asp
http://www.linksys.com/download/
0
 
LVL 6

Expert Comment

by:st_steve
Comment Utility
No one so far has suggested reinstalling TCP/IP??
0
 
LVL 6

Expert Comment

by:bartsmit
Comment Utility
Steve, Joe, thanks for agreeing with me on releasing the DHCP and trying static addressing :P

Does the linksys have any way of configuring other than through the LAN? My WAP11 also has a USB connector. This may be an easy way to run its diagnostics.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:fatfe
Comment Utility
hey all, sorry it took me a little while to get back.  i actually did reformat my pc.  it took me a little longer cause i switched how i use my 2 harddrives.  originally, HD1 had windows and HD2 was for storage.  HD2 was running out of space and HD1 was 10gigs larger so that's why i did the switch.  

before i get to all your posts does anyone know of a DOS command that can copy files/folders from one HD to another?  i ended hooking up an old 3rd HD of mine up that i ran windows off of and proceeded to copy my 30gigs of storage from HD2 to HD1.   i'm not looking for a huge program, something if DOS can not do it i could run it off a floppy disk.  ultimately i would like to eliminate the use of the 3rd HD.
---------------------------------------------------

bartsmit,
before when i hit "release" in winipcfg nothing happened.  i know the values should have changed all to 0.0.0.0 but they stayed the same.  tho i tried your suggestion and after rebooting i was in the same situation.  i agree with your logic tho.  setting a static ip didn't work either for me.  but i think that's something i might do now to my network at home (assigning permanent addresses for each pc).

centerv, joe_massimino, stevenlewis:
i actually had this router for a few months now.  i did try a complete power off and reseting to factory settings but to no avail.


crash2100,
i have actually posted a question before about losing my connection perodically.  the weird thing is, is that the other computer on my network never loses it's connection.  so i think it's something with my pc, but since i just reformattedd i'll have to wait and see if it happens now.  hopefully it won't.


thanks all again.  i'll keep you posted if i continue to lose my connection periodically.
0
 

Author Comment

by:fatfe
Comment Utility
well i just upgraded the firmware version of my router.  i'm noticing that i lose my connection (by AIM signing off and unable to connect to websites) and about 30 seconds to a minute or so later i get my connection back.  i'm not sure if it's a result of the upgrade, tho it is happening alot... about every 5-10 minutes i lose my connection.  i'm betting it's comcast :)

3 things:

1) does losing my connect have anything to do with leases?  i really don't understand what they are and what they do.

2) i have both DHCP enabled for getting my outside WAN connection and for assigning IPs to my PCs.  should i statically assign addresses to my PCs?  will this maybe make a difference?

3) to a previous question, no i can not ping.
0
 
LVL 6

Expert Comment

by:bartsmit
Comment Utility
Given the likely size of your network, DHCP is a bit overkill. You're better off with static IP's.

Have you swapped patch cables with a station that is connected longer?
0
 

Author Comment

by:fatfe
Comment Utility
this network is setup at my house.  i just have 2 PCs connected.  tho i will try static IPs.

i'm going to call up comcast to see if there is a problem with them... tho i said before i just upgraded the firmware to my router, not sure if that did anything "funny" to it.
0
 
LVL 41

Expert Comment

by:stevenlewis
Comment Utility
does losing my connect have anything to do with leases?  i really don't understand what they are
and what they do
no, it shouldn't
when you get an ip address from a dhcp server you "lease" it for a specified period of time, after 50% of this time has elapsed, your machine will request a renewal of the lease, and the dhcp server will renew the lease. this is done so if a machine goes off line for a while, and there are a limited number of ip addresses available, the server will be able to give out the ip address to another machine (if the original one hasn't renewed it
0
 
LVL 6

Expert Comment

by:joe_massimino
Comment Utility
After you did the firware upgrade, you need to do a full factory reset. Not that this will fix your problem, but it is part of the procedure.  The factory reset should be in you owners manual, but it should be something like holding the reset in for 10 seconds, and a power off. Check the book, I don't know if they all reset the same way.

If your cable company is anything like Adelphia, you will lose your internet connection every few days. Mine goes down for an evening at a time, but no more than once a week lately. The quick way to see if they go down is to reboot your cable modem and see if it gets a full connection when it comes back on. If it can't get it's DHCP address, it will keep reseting itself until it does. If you don't reboot, everything looks OK, you just can't get on the net, or obtain an IP address. So if you dump the one you have and try to renew, you won't get it until your internet connection is restored.
0
 

Author Comment

by:fatfe
Comment Utility
so i call up comcast and they say they've had a problem in my area for a day or two.  something with a router going bad.  not that they call or send an email out to the affected people.  so there, it's been comcasts fault all along.  i'm going to leave this question open just in case. you never know with them as you can see.  they said, "someone should be intouch with you within 24 hours."  so that most likely means i'm going to call them tomorrow night if things aren't working.   if they say my service is back and i still have problems you all will be the 1st to know.  :)

thanks again and sorry about the run around.
0
 
LVL 7

Expert Comment

by:WiZaRd
Comment Utility
"a DOS command that can copy files/folders from one
HD to another?"
xcopy will do it. at the prompt type xcopy/? for a list of parameters.
0
 
LVL 1

Expert Comment

by:Moondancer
Comment Utility
ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.  Moderators Computer101, Netminder or Mindphaser will return to finalize these if they are still open in 7 days.  Experts, please post closing recommendations before that time.

Below are your open questions as of today.  Questions which have been inactive for 21 days or longer are considered to be abandoned and for those, your options are:
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you, but may help others. You must tell the participants why you wish to do this, and allow for Expert response.  This choice will include a refund to you, and will move this question to our PAQ (Previously Asked Question) database.  If you found information outside this question thread, please add it.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question (if it has no potential value for others).
   --> Post comments for expert of your intention to delete and why
   --> YOU CANNOT DELETE A QUESTION with comments; special handling by a Moderator is required.

For special handling needs, please post a zero point question in the link below and include the URL (question QID/link) that it regards with details.
http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
 
Please click this link for Help Desk, Guidelines/Member Agreement and the Question/Answer process.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Click you Member Profile to view your question history and please keep them updated. If you are a KnowledgePro user, use the Power Search option to find them.  

Questions which are LOCKED with a Proposed Answer but do not help you, should be rejected with comments added.  When you grade the question less than an A, please comment as to why.  This helps all involved, as well as others who may access this item in the future.  PLEASE DO NOT AWARD POINTS TO ME.

To view your open questions, please click the following link(s) and keep them all current with updates.
http://www.experts-exchange.com/questions/Q.20248829.html
http://www.experts-exchange.com/questions/Q.20249237.html
http://www.experts-exchange.com/questions/Q.20253901.html
http://www.experts-exchange.com/questions/Q.20269726.html
http://www.experts-exchange.com/questions/Q.20245020.html
http://www.experts-exchange.com/questions/Q.20286365.html
http://www.experts-exchange.com/questions/Q.20295707.html
http://www.experts-exchange.com/questions/Q.20299309.html



*****  E X P E R T S    P L E A S E  ******  Leave your closing recommendations.
If you are interested in the cleanup effort, please click this link
http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=commspt&qid=20274643
POINTS FOR EXPERTS awaiting comments are listed in the link below
http://www.experts-exchange.com/commspt/Q.20277028.html
 
Moderators will finalize this question if in @7 days Asker has not responded.  This will be moved to the PAQ (Previously Asked Questions) at zero points, deleted or awarded.
 
Thanks everyone.
Moondancer
Moderator @ Experts Exchange
0
 

Author Comment

by:fatfe
Comment Utility
the newest firmware (1.42.7) was the answer.  linksys and comcast aren't getting along too well.  actually in the comcast forum on dslreports.com i found out that i wasn't the only one with this problem and there i found the answer.  "good" since you pointed me in the right direction.  thanks.
0
 
LVL 6

Expert Comment

by:joe_massimino
Comment Utility
Linksys has had problems with many broadband companies. The first time I ran into this was with BellSouth DSL.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Windows Mobile Barcode Scanning These days almost every product has a barcode in some way... amongst there are 1D barcodes en 2D barcodes.. From http://www.barcodeman.com/faq/2d.php I found some handy definitions and insights. 1D barcodes …
Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now