Installing Apache 2.0.35 on Windows 2000 Pro

I just installed Apache 2.0.35 release on my Windows 2000 Pro PC but am unable to Start an Apache service via the Windows Start menu.

I would like to use the PC as the server for testing JSP programs etc, so I need the correct configuration settings.

I have set Servername to 'localhost' and port to 80.

A DOS screen flashes but there is no indication that anything has succeeded or not.

I cannot find it as an 'NT' Service.

How can I get this thing to work?

Who is Participating?
samriConnect With a Mentor Commented:
Which package do you pick, with SSL or no-ssl.

I tried to simulate one.

There is a few pop-ups during install, but after a few minutes, you should see a small "Red Feather" icon with a green arrow in a circle - Apache is running, on the status bar.  Left-click (dependig on how you mouse button is configure) on this icon, you can control the service.

If you are not seeing this, something must have gone wrong during installation.

Have you tried to redo the installation.  Btw, Apache 2.x will refuse to install if there is already an Instance of Apache 1.x (or maybe any version) installed on the machine.  Kinda stupid.

In the Service window, it should be displayed as Apache, (mine had 2), and Apache2.

Do you have any other software listening to port 80.  Any web accelerator software, InterQuick, WinGate, or any other that might have taken port 80 (TCP).  If this is the case, you need to either, change that software to use other port, or, get your apache to listen to a different port

Look for this section.  Mine has "somebody" stuck at 80/TCP, so I'll let Apache use 8000 -- all are working fine, without reboot.

# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (
Listen 8000

Have you tried opening   replace 80 with the port number your apache is configured to use.
You could go to: c:\Program Files\Apache Group\Apache2\bin and try to run Apache.exe from the CMD line.  And use your browser to browse to in case the first test failed.

Give it a shot.  Try freshboot, and reinstall.  Better still try to download a different copy, and test.
Take a look at this page.  Maybe you MSI installer is the problem.  Scroll to the bottom of the Page!
Take a look at this page.  Maybe you MSI installer is the problem.  Scroll to the bottom of the Page!
ozphilAuthor Commented:
Hi samri

I disabled (stopped) IIS Admin Service then reinstalled Apache and it works!

I had disabled IIS on the first installation of Apache but I disabled it AFTER 'installing' Apache.

There was no previous Apache version installed.

Thanks for you help.

I'm be installing Tomcat later. Hope there is no major drama there otherwise i'll be back here.
That's cool.

just to share the thought.

I had another weird problem.  Right after posting the solution, I change the port in httpd.conf, restart, and Apache kept crashing.  Run from cmd line, works.

-- i bet this will be the drama for me :)

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.