Solved

aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config f

Posted on 2002-04-10
6
2,254 Views
Last Modified: 2007-11-27
aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid.

I need more here than the links that will come up from doing a search for this on Google.com. I really need more a simple step by step explanation of how to fix the problem.

I have tried the those links but either I don't understand something or I am doing something wrong trying to follow them.

If you can help or show me to somewhere than can I would really appreciate it.

Thank you,
Chris Craft
0
Comment
Question by:CJCraft
6 Comments
 
LVL 20

Accepted Solution

by:
Silvers5 earned 200 total points
ID: 6931175
By default ASP.NET runs the ASP.NET worker process using a
non-adminitrative windows account called "ASPNET".  This restricts what
an ASP.NET application can do on a machine -- and requires
administrators to explicitly grant security permissions. =20

However, on Windows Domain Controller machines (this includes the
Windows Small Business Server product) the ASPNET account cannot be used
-- since non-administrative local accounts cannot be created and used
(the security policy of a Windows Domain Controller machine prevents
this). =20

If you attempt to use the default ASPNET account when running an ASP.NET
page on a Windows Domain Controller, the worker process will fail to
start -- most likely with an error message similar to the one below:=20

  "aspnet_wp.exe could not be launched because the username and/or
password supplied in the processModel section of the config file are
invalid"

To fix this, it is necessary to configure ASP.NET to instead use the
LocalSystem account after setup.  This is done by modifying the
<processModel> tag within the Machine.Config configuration file
installed in the below location:

   c:\Windows\Microsoft.Net\Framework\V1.0.3705\Config\Machine.Config

By default you will find that the <processModel> configuration tag has a
"userName" attribute set to the value: "MACHINE".  Changing this value
to "SYSTEM" will cause ASP.NET to instead use the LocalSystem account
when executing.  This account *does* have permission to run on Windows
Domain Controllers.

After making the change to the Machine.Config XML file, save it, and
then restart IIS (iisreset).  ASP.NET will then be using the LocalSystem
account to run its worker process, and ASP.NET will function fine on
domain controllers.


you cann add also any other admin account
0
 
LVL 7

Author Comment

by:CJCraft
ID: 6931372
Is there a way I can get it to work without having to give it high level credititials? We are a little uncomfortable about having it run in that context.

I am trying to implement the following:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q315158

Thanks again,
Chris Craft
0
 
LVL 23

Expert Comment

by:naveenkohli
ID: 6931558
Unfortunately, there is no workaround this problem right now. MS is under lot of heat because of this issue. As the knowledgebase article suggested, the best of the worst is to create an account that has enough previleges to run ASP.Net service.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 7

Author Comment

by:CJCraft
ID: 6932206
You guys are right I just had to suffer through and do what

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q315158
said do, it wasn't that bad after I did it.

Thanks everyone,
Chris Craft
0
 
LVL 23

Expert Comment

by:naveenkohli
ID: 6932237
It seems with this approach, MS is preparing for Windows .NET server family where they are tryig to separate Domain Controllers from Web Servers. Seems like more on the lines of their tightening the secutity policies.
0
 
LVL 2

Expert Comment

by:CUTTHEMUSIC
ID: 6935006
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I have helped a lot of people on EE with their coding sources and have enjoyed near about every minute of it. Sometimes it can get a little tedious but it is always a challenge and the one thing that I always say is:  The Exchange of information …
I would like to start this tip/trick by saying Thank You, to all who said that this could not be done, as it forced me to make sure that it could be accomplished. :) To start, I want to make sure everyone understands the importance of utilizing p…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now