Solved

Username and Password not required - how to get

Posted on 2002-04-11
2
122 Views
Last Modified: 2010-04-13
I have a Windows 2000 machine that functions as a server to an intranet.  It is W2K Pro - not W2K server - but it functins fine.  When I go into Users and Passwords on this machine, I get a little check box at the top "Users must enter a username and password to use this computer."
I don't have it checked, so anyone can use the machine thru HTTP services, and can access the ASP's on the intranet, even though the Access DB's those ASP's use are on another server.

I am trying to upgrade the server, and I have another, better box to replace the old intranet.  I installed IIS 5.0, loaded all the stuff from C:\inetpub\wwwroot, etc. , and tried going to the "new" intranet.  I can get there with HTTP services, but when I go to view the intranet pages that go against Access DB's on other drives, I get the following:

"Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data."

Now, the only differences between the boxes is that on the one that works, I don't need a login, and on the one that doesn't work, I do need a login.  I think this is the rub, but I'm not sure.  One last thing, when I power down the box that works, I don't have to log back in (It knows to reboot as Administrator), but I have to log into the other box.  Is this a W2K issue (which I think it is), and, if it is, how to I effect the change on my new box to let users use it without logging in?


0
Comment
Question by:mbenish
2 Comments
 
LVL 63

Accepted Solution

by:
SysExpert earned 200 total points
ID: 6934746
It could also be a file-permission or related to a SID identifier.

Double check the setups, and especially all the file permissions and IIS settings.

Also check the MS site - advanced search and see if you can find your error messages.

I hope this helps !
0
 

Author Comment

by:mbenish
ID: 6934842
It was the IIS settings.  I set the user that accesses IIS site to a user in my NT domain rather than the IUSR_nodename on domain nodename it automatically assigns when installing.

I solved this before I got this message, but, I will give somethin', you know, for the effort (a la Carl Spackler to the Dalai Lama)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Facing problems with you memory card? Cannot access your memory card? All stored data, images, videos are lost? If these are your questions...than this small article might help you out in retrieving your lost or inaccessible data.
I designed this idea while studying technology in the classroom.  This is a semester long project.  Students are asked to take photographs on a specific topic which they find meaningful, it can be a place or situation such as travel or homelessness.…
This is a video describing the growing solar energy use in Utah. This is a topic that greatly interests me and so I decided to produce a video about it.

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now