Solved

Write permissions to Hard drive and floppy

Posted on 2002-04-12
4
227 Views
Last Modified: 2013-12-15
Hello Everyone:
I have a simple problem. I need non-root users to have full read/write access to all my local hard drives, my ls-120 "super" floppy, and my compactflash reader (sda1). Currently, everyone can read but only root can write.
I tried to change my fstab file options in each line to "users" instead of "defaults" and , you guessed it, I wasn't able to boot up normally any more!!!!
If the problem is in the fstab file, please let me know exactly what each line should say! Thanks!
My fstab file looks like this:
/dev/hda1 / ext 2 defualts 1 1
none /dev/pts devpts mode-0620 0 0
none /dev/sbm tmpfs defaults 0 0
/dev/hda5 /home ext2 defaults 1 2
/mnt/cdrom /mnt cdrom supermount dev=/dev/hdc .....
/mnt/floppy /mnt/floppy supermoutn dev=/dev/hdd,fs=supermount
/dev/hda6 /mnt/win_c vfat defaults 0 0
/dev hdb1 /mnt/win_c2 vfat defaults 0 0
/dev/sda1 /mnt/win_c3 vfat defaults 0 0 (this is the compactflash reader)
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0

0
Comment
Question by:haldrik
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 51

Accepted Solution

by:
ahoffmann earned 100 total points
ID: 6938538
/mnt/floppy /mnt/floppy supermoutn dev=/dev/hdd,fs=supermount,rw,user,exec
# not shure what the other option you specified should do
/dev/sda1 /mnt/win_c3 vfat rw,user,exec 0 0
0
 

Author Comment

by:haldrik
ID: 6940695
Well, I changed my fstab file and I'm still unable as a non-root login to write to floppy, sda1, or any win partition, although the lines you gave me for the fstab file above do allow me now to mount and unmount the drives as a non-root user. Maybe I need to do a chmod command on the drive? (Not sure how to do that either, of course).
0
 

Author Comment

by:haldrik
ID: 6940966
Ooops...I take that last statement back...actually, it worked fine after I rebooted (not sure why that would make a difference, but hey, it works so I'm not complaining!)
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6941309
reboot should not be necessary (this is not M$ ;-)
But oing a unmount (probably with -f), and then mount again might be wise.
0

Featured Post

 Watch the Recording: Learning MySQL 5.7

MySQL 5.7 has a lot of new features. If you've dabbled with an older version of MySQL, it is definitely worth learning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question