Solved

Masquerade problem

Posted on 2002-04-12
13
335 Views
Last Modified: 2010-04-20
I would like to connect my Windows (10.0.0.10) to the  Internet thru Linux (eth1: 10.0.0.1). I use the following commands:

echo 1 > /proc/sys/net/ipv4/ip_forward
/sbin/modprobe ip_tables iptable_nat iptable_nat_ftp
/sbin/modprobe ip_conntrack ip_conntrack_ftp
/sbin/iptables -t nat -A POSTROUTING -o eth0 -s 10.0.0.0/16 -j MASQUERADE

However it won't work.

Note:
I can connect to the Internet in Linux;
I can ping from Windows to Linux;
When I try to browse a site in Windows, the send and recieve lights are blinking but the page cannot be displayed;

Thanks.
0
Comment
Question by:andersy
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6938527
souds like a routing problem on Windows, what does following on windows tell you:

   netstat -rn
   ipconfig -all
0
 

Author Comment

by:andersy
ID: 6938805
Hi ahoffmann,

netsta -rn:

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0         10.0.0.1       10.0.0.10       1
         10.0.0.0      255.255.0.0        10.0.0.10       10.0.0.10       1
        10.0.0.10  255.255.255.255        127.0.0.1       127.0.0.1       1
   10.255.255.255  255.255.255.255        10.0.0.10       10.0.0.10       1
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
        224.0.0.0        224.0.0.0        10.0.0.10       10.0.0.10       1
  255.255.255.255  255.255.255.255        10.0.0.10       10.0.0.10       1
Default Gateway:          10.0.0.1
===========================================================================
Persistent Routes:
  None

Active Connections
  Proto  Local Address          Foreign Address        State


ipconfig -all:

0 Ethernet adapter :

        Description . . . . . . . . : NDIS 5.0 driver
        Physical Address. . . . . . : 00-C1-26-01-B4-73
        DHCP Enabled. . . . . . . . : Yes
        IP Address. . . . . . . . . : 10.0.0.10
        Subnet Mask . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . : 10.0.0.1
        DHCP Server . . . . . . . . : 10.0.0.1
        Primary WINS Server . . . . :
        Secondary WINS Server . . . :
        Lease Obtained. . . . . . . : 04 13 02 PM 10:26:59
        Lease Expires . . . . . . . : 04 14 02 AM 04:26:59
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6939032
looks good, and what does

     iptables -L -n

on Linux report?
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:andersy
ID: 6939759
# /sbin/iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
0
 
LVL 2

Expert Comment

by:hangman
ID: 6940027
Your problem is most likely a windows problem. Have you told windows about the router. Under TCP/IP properties,
click Advanced. Then click on the button under default gateways. Add 10.0.0.1 metric 1.

Give that a go
0
 
LVL 4

Expert Comment

by:kannabis
ID: 6940366
This is not a windows problem.  First off.....you have to define that value in the PREROUTING table, not POST.

2nd - You are mixing IPchains and IPTables commands, you have to stick with one or the other.

oh.....and it's not called masquerading anymore either....it's now referred to NAT (Network Address Translation)  (:

anyhow, d/l this dude's firewall/NAT script.  You have some very minor changes to make to the script, and you'll be up and running with a fairly secure firewall to boot.


http://monmotha.mplug.org/firewall/index.php

0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 100 total points
ID: 6941305
> ... not POST
it must be the POSTROUTING in iptables, the iptables command provided in the question is correct (I'm not shure about the modprobes, 'cause I never use modules for security:)

> 2nd ..
do not see any reference to ipchains here

> .. not called masquerading anymore
RTFM or RTFW or RTFH
It's right that the correct term is NAT, but since the early days of netfilter (ipfw, ipchains) the special n-to-1 NAT is called masquerading. And people tend to use this term, masquerading, if they refere to n-to-1 NAT.


andersy,
think that the interface is specified wrong in your iptables command. Are you shure that your internet traffic is going through eth0? As you specified the iptables command, the interface for the -o option must be that which is connected to your ISP, not that to the LAN.
0
 
LVL 4

Expert Comment

by:kannabis
ID: 6942503
well on my firewall, the command I use to get NAT working is PRE-ROUTING.

I find that most references to masquerading are made using a 2.2 kernel and ipchains.  On the other hand when I see references to 2.4 and IPTables, then NAT is used...no big deal, maybe something I just noticed.....

0
 

Author Comment

by:andersy
ID: 6943632
Hello Ahoffmann,

I've checked many times that eth0 is connect to the Internet, it is not with IP 10.0.0.1. I think the HTTP request can be sent out from Windows, however, the response cannot be routed back to Windows...

Anyway, many thanks to both of you.
0
 

Author Comment

by:andersy
ID: 6943639
Thanks ahoffmann.
0
 
LVL 4

Expert Comment

by:kannabis
ID: 6943880
It doesn't sound like your problem was solved, was it?

0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6943953
> ..that eth0 is connect to the Internet, it is not with IP 10.0.0.1.

Sounds like we're all missunderstanding something.
Either eth0 is connected to internet, then it definitely cannot have 10.0.0.1, and you can no longer ping your other mashines on the same LAN.
Or your internet connections goes through another interface, for example ppp0 or ippp0, which cannot have 10.0.0.1 either. In this case your iptables command is wrong (interface to - o option), as I said in a previous comment.
0
 

Author Comment

by:andersy
ID: 6944162
Maybe I didn't describe my system clearly...

My Linux has 2 NICs: eth0 is connect to Internet thru a cable modem and the IP is got from dhcp of my ISP; eth1 is set to 10.0.0.1 and my Windows (10.0.0.10) is connected to Linux thru this NIC.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Weird Samba Connectivity Issue... 7 40
shell script or linux command to upload a directory to artifactory? 2 131
Can't ping New Linux Servers 40 67
number in printf 13 27
Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question