• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 252
  • Last Modified:

Boot up question easy

At boot up I get this message what can I do and what does it mean

Warning –unable to repair the /var filesystem.  Run fsck manually (fsck –F ufs /dev/vx/rsk/var).  Exit the shell when done to continue the boot process.

Type control-d to proceed with normal startup,(or give root password for system maintenance)
0
UnixKid
Asked:
UnixKid
  • 3
  • 3
  • 2
  • +4
1 Solution
 
chris_calabreseCommented:
It means that something in the filesystem is corrupted and the system can't reboot normally.

What to do about it is actly what the error message says to do  (run fsck -F ufs /dev/vx/rsk/var)
0
 
UnixKidAuthor Commented:
I have actually ran the fsck -F ufs/dev/vx/rsk/var command and the operating system can't load the /var file system.  what are my other opions.
0
 
chris_calabreseCommented:
What kinds of errors did the fsck come up with?  You should keep running it until it's clean.  If that never happens, it's time to break out the backups and reimage the filesystem.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
UnixKidAuthor Commented:
It is saying that it can't find the /var file system.  I also have a question, I believe that all of this happen becuase I had to cold reboot the sun station 3 times.  Could that be the cause of the problem.  And if I don't have a back up what is my option.  I did this at work!,(
0
 
chris_calabreseCommented:
If you don't have a backup you could take a backup of a similar system and restore it on the broken system.
0
 
ecwCommented:
has the volume started?  If not, start it with
  vxvol -g rootdg startall
fsck it (optional), and mount it.

You'll need /usr mounted first, the vx* commands live there.  Failing that, if you have made sub-disk partitions for the rootdg volumes- /, /usr, /var, /opt and swap, mount /usr's  underlying slice READONLY, so you can get to the commands.

If that still doesn't work, the usual cause in invalid vxvm licenses.  Again /usr must be mounted to get to vxlicense, if you can't remember the key, it's kept in plaintext in the vx license directory.
0
 
yuzhCommented:
Have a look at your /etc/vfstab on your system, write down
all you file system and the raw device name.

Boot up your system from CDROM or a boot server (if you have one), run
   fsck -y to all-filesystem(use raw device name)


If this doesn't work, restore your system from backup.
0
 
ahoffmannCommented:
> It is saying that it can't find the /var file system.
That's not the message from fsck, except you executed it in another way than suggested (see your own post here).

please try the fsck again, exactly as posted by the system If it fails again, please post exact message here.


> vxvol -g rootdg startall
will be hard on a a half-booted system, even without /var
0
 
ecwCommented:
starting the volumes in rootdg is not particulary hard if /usr is mounted, and of course to run fsck /usr has to be mounted.

When fsck is barfing because it can't find the filesystem, on a vxvm box it usually means the volume is not active.  If your not happy using vxol startall, use
  vxvol -g rootdg start var
then
  fsck /var

0
 
jonkeCommented:
I agree with ecw on this one. When unixkid said that it couldn't load the /var filesystem, it kind of implied that there was 'no such device or address'.

Post us an output of vxprint -g rootdg -th.

I can think of all sorts of possibilities but first I'd like to see if there is a var volume and what state it is in.
0
 
ahoffmannCommented:
please keep thinking, or read docs.
If the filesystem is corrupted somehow, you cannot mount it, doesn't matter which program you use.
That's what fsck is for, and that's what the message (see question) says: fsck -F ufs <device>
It's a device, not the mount point !!
Running fsck on mounted filesystems is not recommended (for obvious reason), read the docs.
0
 
ecwCommented:
Yeah, but under solaris fsck live in /usr, so obviously the usr volume (if there is one), is active.  If fsck is given a mount point, it will look up the device and filesystem type in vfstab and use them.

Mind you, going back the original question, it mentions
  fsck –F ufs /dev/vx/rsk/var
ie. no d in rdsk, if this was entered exactly as displayed, then vfstab is incorrect, try
  fsck -F ufs /dev/vx/rdsk/var
if it works, mount /vgar adn fix vfstab.
0
 
yuzhCommented:
Sometime, run sfck straight from the HD doesn't fix the problem and you boot it up from CD (or bootserver), then run fsck it fix the problem. Just think about the reasons !
0
 
teisyunCommented:
run this command again with option -Y see what happen.
fsck –F -Y ufs /dev/vx/rsk/var
I had same problems, good luck.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 3
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now