Solved

Win98 computers cant find eachother.

Posted on 2002-04-16
12
233 Views
Last Modified: 2013-12-28
I have 2 computers, AMD700mhz and P4 1.6ghz, both have win98se (dont ask...) with default installation and the share level password fix from windowsupdate.microsoft.com, and 100/10 PCI NIC's. The otherone also has an ISDN and a modem, and the other only an ISDN. The ISDN and the modem works fine, but the problem is within the NIC's.

I'm trying to share a printer in the network, but the machines wont see eachother. I've tried with cross-over tj-45, via HUB, fixed and auto-modes. I've tried with NetBEUI, IPX & TCP/IP, only TCP/IP and IPX with NetBIOS over ipx, only tcp. With and without DHCP, fixed IP addresses, DNS entries (but no name server) and without. I've tried several different cables and combinations - but to no avail. The machines only see themselves. They have their own names and the same workgroup, file and print sharing on (both have a printer and a few folders shared). The NICs' lights blink when I try to ping the other host, but it wont answer (ping wont go through). Network neighborhood only shows the Whole Network -> MYWORKGROUP -> MYMACHINE but not the other machine. I also tried with ethereal (http://www.ethereal.com) to snoop the packets, but it could not find any packages coming to the NIC - _only_ when I used DHCP, it seemed that some broadcast came through when it had 255.255.0.0 netmask. All the other interfaces work fine, the computers connect to internet, but they just wont see eachother. Not via icmp ping, netbios (over ipx), nothing. What am I forgetting?
0
Comment
Question by:acidia
  • 3
  • 2
  • 2
  • +3
12 Comments
 
LVL 10

Accepted Solution

by:
trekie1 earned 100 total points
ID: 6945661
sounds as if you know what your doing but lets just go through the basic's...I suggest this...networking 2 comps    if hooking directly from pc to pc use cross wired cat5 wire   if useing a hub then use stright through cat5   set each comp to use just tcp/ip and assign it a number (192.168.0.1  and 2  with 255.255.255.0 subnet mask  )   dif comp name,,same workgroup and setup file shareing    generaly if the comp see's itself in network neighborhood then all is well  and if useing correct wire it should see other comp
things to check if they dont see one another.....nic  ..the nic can seem to be working but not send and receive   try another (had a new one do this last week)
recheck the wire and check the ends....the crosswired will be diff on each end   and stright through will be the same
if they still dont work and all is correct try uninstalling DUN and reinstall then go to update site and download the DUN 1.4 update
0
 
LVL 18

Expert Comment

by:Crash2100
ID: 6945672
listening...
0
 
LVL 1

Expert Comment

by:HJohnson
ID: 6945985
Make sure that your actually log in to both machines and have the same workgroup name listed on both.  (WIN98se rocks!)
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6946579
0
 
LVL 6

Expert Comment

by:bartsmit
ID: 6947890
what does device manager say about the NIC's?

It sounds like one or both can't get all its required resources.

Try moving them to another PCI slot.
0
 

Author Comment

by:acidia
ID: 6949720
Hi,

Thanks for all the comments!

I'm going to go and check those computers soon (theyre at my moms place) and will try everything you've suggested.

The thing is that I've did _exactly_ as stated in the instructions found on the links SysExpert posted - and still no avail. The cards work fine, they are brand new and installed without a flaw, they send packets forward etc etc, and the other ends NIC flashes when I ping there. But the other end wont 'catch' the packet.

Here's the situation :

Machine 1 has IP 192.168.1.1, machine 2 192.168.1.2, both netmasks are 255.255.255.0 with no gateway, IPX/SPX is installed, with NetBIOS over IPX/SPX (and with/without NetBEUI, no difference on results). They also have the TCP/IP binded with the ISDN adapter, and the modem. The ISDN works fine when dialled to the net. The modem connects fine. Both of the machines have an identical workgroup, and I'm using the same user with the correct password on both. I've tried with DNS-entry and without, but it not make any difference.
I snooped with ethereal and checked what goes out when I try to ping from 1.1 to 1.2. It said that an ICMP-package with the identification 'Who is 192.168.1.2, tell 192.168.1.1?' on the package. The other ends NIC flashed but it did not respond. The speeds have been tried with fixed and auto-mode. Via HUB and cross-over cable. Nothing changes, the machines wont see eachother.
They see themselves, both see Whole Network->MYWORKGROUP->ME\myshares but not the other machine.

I've also tried without TCP/IP, and only with TCP/IP, but it still didnt make any difference.

I downloaded from windowsupdate.microsoft.com the fixes for share-level passwords, igmp and ip-fragmentation but that didnt make any difference either.
I'll try this DUN-thingie next, mind clearing up where to get the updated version :)?

The most peculiar thing is that I have the _same_, completely identical setup at my home with precisely the same NIC's and it works - BUT it also has an samab linux server hosting their hostnames and acting as a gateway... hmmh?

    ~/S

0
Do email signature updates give you a headache?

Are you constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 6

Expert Comment

by:bartsmit
ID: 6949893
Have you tried ARP? See if the machines can resolve each other's MAC address after a ping.

arp -a will give you the current table.

You can also try to fix the MAC address to the IP's explicitly. Note down the addresses from winipcfg and on 1.1 do arp -s 192.168.1.2 <other MAC> and vice versa.
0
 

Author Comment

by:acidia
ID: 6951342
Problem was solved. The reason was that the cards (they were identical Realtek Fast PCI) wouldnt talk with eachother. I changed the other NIC to an old SMC ISA-slot 16bit steam-machine and instaniously the network started to work. The hint that gave me the reason to start looking the reason from the cards was that ethereal informed, when I tried to ping from the other machine, that a packet arrived, but it was malformed (LLC). Netbios echoes seemed to come through fine, but the strangest thing was that wheever i queried the net, the other machine sent out that I'm here, but the other didnt respond anymore. When I changed the other card, it worked immediately. Nice.

Postmortem : The arp-thingie didnt work, naturally it couldnt resolve any addresses. And when I set the ip's manually, it didnt help either.

I'm just wondering how can I accept my own comment as an answer and distribute the points to a better cause :)...

      ~/A
0
 
LVL 10

Expert Comment

by:trekie1
ID: 6951691
taken from my above comment ....however if you feel you answered your own question then so be it..........
.....nic  ..the nic can seem to be working but not send
and receive   try another (had a new one do this last week)
0
 
LVL 1

Expert Comment

by:HJohnson
ID: 6951707
Sounds like you need to give the points to trekie1.   Network problems are always a pain.

0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6952358
I forgot to mention that realtek cards cause 90 % of the network problems i see on EE.

I'm glad you got this working !

0
 

Author Comment

by:acidia
ID: 6952613

Yeah - practically this was the answer - another NIC solved things.

I hereby state, be this the last time I let Realtek's lowlow-prices get to me, and thus next time buyeth better cards. 'nuff said.

I mean, if we look at this from another point of view : if I was a consultant hired to set up that small network - the time it took me to figure out what was the reason, I would have costed them the price of a server computer and a hub. I seem to trust hardware manufacturers too blindly.
Probably because I have those realteks at home and they work fine (btw it said life-time guarantee in the box...) - but there is a 3Com Cyclone and a switch in between :).

Thank you all for the help!

      ~/A

0

Featured Post

Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
file size 9 40
Synaptics ClickPad issue 7 23
Question to the line 4 40
BOSD APC_INDEX_MISMATCH - who's the culprit ? 4 29
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now