• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

Visual C++ 6.0 is being stupid

Hi everyone,

Every time I try to compile an updated .c file, I get an error message telling me that the file is in use by another application.

But it's not...

Any ideas?

1 Solution
I've had the same problem but never got a useful solution here.  Several things were suggested but nothing seemed to help.


If you find out anything, please post it here...
tried rebooting and then compile
1) Something I didn't see in the other thread... If the file includes a line like:

#import "SomeHugeFile.dll"

then that causes some "unexpected" disk activity that can be quite lengthy (for instance, just building the auto-completion table for such a monster will take a long time).  The solution is to put that in your stdafx.h file.

2) Maybe the file IS in use.  What happens if you try to rename or delete it with the Explorer?

3) Are you sure it is the file that you just edited?  What exactly is the message?  If the program is running, then *it* is the file that is in use and the compiler can't delete it in order to build a new one.

-- Dan
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Disable your virus scanner. In our company, this caused on some machines this problem (VC opens file, Scanner recognizes that and scans immediately -> problem sometimes)
Your file may be read only, or you trying to update file without checkout it from VSS.
I get this crap too!! I think it might be the virus scanning program as well. I'm using Norton AV. It doesn't happen all the time but sometimes. I've been trying to see if i can see a pattern but none has appered thus far
Yep, Norton AV was the scanner we were (and still are) using. I disabled the on-line scanning, it is working since now w/o problems.
SuperMarioAuthor Commented:
This appears to work, or at least reduce the problem. Thanks a lot!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now