Solved

User time or hours limit

Posted on 2002-04-18
11
171 Views
Last Modified: 2010-08-05
I recently installed a Win2000 PC on a P2P LAN. A Win98 user on the LAN has a drive mapped to a public folder on the Win2000 PC. Almost everyday at some point, when the Win98 user attempts to open a file (not a specific file) on the mapped drive, the response is as though the network connection has become unavailable. The rest of the time, she can open files on the mapped drive almost as fast as if they resided on her own HD. If she re-starts the Win98 machine, the problem disappears for a while. When the problem occurs, the Win2000 PC is operating fine. I am new to Win2000, and it was a learning process just to setup LAN users in Win2000 so they could logon and get access to files. Is there a time limit somewhere in the user settings that could be preventing the user from accessing the machine after a specific period of time? Or what other possibilities could there be? Thanks, Bill
0
Comment
Question by:boogyman
  • 5
  • 3
  • 2
  • +1
11 Comments
 

Expert Comment

by:rimran
ID: 6951045
Dear Bill
You can prevent the user for some specific period of time,
You can implement this by follow the following steps:

go in the user properties,and then select logon tab from there, here you will see blu boxes in front of week days, from here you can prevent the user in specific time period. i'm sure this will solve ur problem. 'imran'.
0
 
LVL 1

Author Comment

by:boogyman
ID: 6951078
Please DO read the original question, please DON'T lock the question.
0
 
LVL 24

Expert Comment

by:SunBow
ID: 6951325
>  Is there a time limit somewhere

No. Just some NT networking quirk, authentication.

For me it works best if both are standalone, with same ID and password. Once that done, adding both to domain, same ID and password is ok

Make sure you do not have any autodetect or autoconfigure for networking. Be explicit there, or OS will go its own way.

Ensure that you are not experiencing any collisions, for computername or IP address. Maybe it only happens -- when someone else turns their machine on, and you'd need to identify the rogue.
0
 
LVL 24

Expert Comment

by:SunBow
ID: 6951341
btw, there is a timer to refresh the client view of connectivity. (not timer on user) - this a different issue.

example - open explorer window. Over  time, I'll get red 'X' through the mapped drive as if it got lost. There are a couple applications that won't run then. But if I manually click on the letter of those drives, it'll go look and find them ok, the red 'x' goes away, and all programs work again.

quite rare, comparatively, I need reboot. MS OS seems to like us to do that a lot.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 6951497
Try this

HKEY_LOCAL_MACHINE / Software / Microsoft / Windows / CurrentVersion / Explorer / RemoteComputer / NameSpace {D6277990-4C6A-11CF-8D87-00AA0060F5BF}


delete the string value:

{D6277990-4C6A-11CF-8D87-00AA0060F5BF}


also, ask the user to try accessing her files from within My Computer instead of from within the application. So , instead of opening word and browsing for her document on the shared drive have her , open My Computer, double-click on the sahred drive(this will initiate a re-connect it it has lost connection), browse to the document folder and double click it from there.

The namespace fix is well known and it should be performed on both the PC's and the server. It tells windows to automatically search for shared tasks whenever a is accessed...not needed.


I am looking for a hotfix, for WinME I beleive, that address's this issue. Will post when I find it. Do the above in the meantime and let me know if it resolves the situation.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 7

Accepted Solution

by:
jatcan earned 50 total points
ID: 6956885
Here ya go my friend, the answer:

Drive Mapping May Time Out on a Windows 2000-Based Computer (Q297684)

--------------------------------------------------------------------------------
The information in this article applies to:


Microsoft Windows 2000 , Professional
Microsoft Windows 2000 , Server


--------------------------------------------------------------------------------


SYMPTOMS
When you perform drive mapping from a Windows 2000-based client computer to either a Microsoft Windows NT or Windows 2000 network share, the drive mapping may be disconnected after 15 minutes of inactivity and Windows Explorer may display a red "X" on the icon of the mapped drive. However, if you attempt to access or browse the mapped drive, it reconnects quickly.



CAUSE
This behavior can occur because both Windows NT Server version 4.0 and Windows 2000 Server can drop idle connections after a specified time-out period, which by default is 15 minutes, so that server resources are not wasted on unused sessions. The connection can be re-established very quickly at a later time, if required.



RESOLUTION
To resolve this behavior, use a command to change the default time-out period on the Windows NT Server 4.0 or Windows 2000 Server: At a command prompt, type: net config server /autodisconnect:30 .

The valid value range to configure this setting from a command line is from -1 through 65,535 minutes. To disable Autodisconnect, set it to -1 .

NOTE : This step must not be confused with the remote access Autodisconnect parameter that is turned off if you set it to a value of zero (0).

If you set Autodisconnect to zero (0), this setting is not turned off and after a few seconds of idle time very fast disconnections can occur.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 6956889
Oh, and just incase you got a Compaq(s):

Some Compaq Programs Cause Mapped Drives to Be Disconnected (Q305355)

--------------------------------------------------------------------------------
The information in this article applies to:


Microsoft Windows 2000 , Advanced Server
Microsoft Windows 2000 , Server
Microsoft Windows 2000 , Professional


--------------------------------------------------------------------------------


SYMPTOMS
After a few minutes of idle time, your mapped drive or drives may be disconnected, and a red "X" may appear next to the mapped drives in Windows Explorer. After this occurs, and even if you double-click the mapped drive letter, the connection to the server may not be re-established.



CAUSE
This issue can occur if one or more of the following programs are installed on your computer:

Compaq Diagnostics for NT


Compaq Insight Manager LC Remote Management





RESOLUTION
To resolve this issue, contact Compaq to inquire about the availability of a fix for this issue.

To work around this issue, uninstall either or both of the following programs:

Compaq Diagnostics for NT


Compaq Insight Manager LC Remote Management


0
 
LVL 1

Author Comment

by:boogyman
ID: 6958507
Great! Tomorrow (Monday) I will be on the site w/ this problem. We'll know something by Tuseday. Thanks for all the input.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7287954
5 months to realize the right answer? Just curious about this, but why?
0
 
LVL 1

Author Comment

by:boogyman
ID: 7288094
The problem itself actually remains unsolved. The user simply shuts down each night and the problem is mostly avoided.Not completely, just much less than when the PC is left on 24X7. I just realized this question has been outstanding for so long and wanted to close it. As you made the best effort to help I felt you deserved the points. I apologize for the delay, it was inadvertent. Thanks again for the effort, Bill
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7288228
No problems about the time delay, I hadn't even noticed and had forgotten all about the question. I usually wait until the "client" follows up to make any more posts. So when the client doesn't post for a long time(for whatever reasons) I forget all about it, which was the case with your question.

So, just to be clear the command:

net config servername /autodisconnect:30  

must be run from the server and the client autodisconnect can also be set on the server in the same way, simply by including the client host name in the above command like so:


net config servername hostname /autodisconnect:30

AND the 30 (measurement=minutes) can be increased as high as 65,000, try that if you are the NetAdmin, and if not send this to the NetAdmin.

Cheers.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
In  today’s increasingly digital world, managed service providers (MSPs) fight for their customers’ attention, looking for ways to make them stay and purchase more services. One way to encourage that behavior is to develop a dependable brand of prod…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video discusses moving either the default database or any database to a new volume.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now