DNS Server fails to start =>The Handle is invalid?

I can't start my DNS Server and I get the following errors in my event viewer:

=> Starting Microsoft DNS Server (v4.0). => Event ID: 1

=> DNS Server could not create the main datagram socket. The data is the error. => Event ID: 406

=> DNS Server could not open socket for address => Event ID: 408

=> The Microsoft DNS Server service terminated with the following error: The handle is invalid. => Event ID: 7023

=> The DNS Server has shutdown. => Event ID: 3

I have checked the IP address and it's valid.  I can ping it ok - not a problem (from same machine and other local machines).  I use this IP for other things as well.

Any suggestions would be great!
Who is Participating?
emorrieConnect With a Mentor Commented:
Microsoft has several cases where this error is generated.  The most specific to your situation is that there is a mismatch between the IP addresses configured in the Advanced IP Addressing dialog box and those listed in the Server Properties dialog box for the DNS server. This problem can also occur if the TCP/IP protocol is not bound to the network adapter.

I have provided two links that talk about this error and instructions to fix it.


Do you have a proxy client or third party DNS server running on the box?
cjclaytonAuthor Commented:
I have never used DNS server before, so this is my first time to set it up.  I only just installed it.

I am running a ADSL connection to Internet using NTS EnterNet 300 Software.  I have two LAN cards one for ADSL connection and one for my local LAN.  I'm not aware of any proxy client or third party DNS server that may be running.  I am also using Sygate for my firewall software.
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

The "handle is invalid" error usually is caused by some other service binding port 53.  DNS requires this port to operate.  You should try disabling Sygate and the other software.  They may be Binding the port.

Just a thought...if you have just installed DNS for the first time...did you re-apply the latest NT service pack after installing DNS from the original NT CD???

This question is current, but others below are not.  ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.  Moderators Computer101 or Netminder will return to finalize these if they are still open in 14 days.  Experts, please post closing recommendations before that time.

Below are your open questions as of today.  Questions which have been inactive for 21 days or longer are considered to be abandoned and for those, your options are:
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you, but may help others. You must tell the participants why you wish to do this, and allow for Expert response.  This choice will include a refund to you, and will move this question to our PAQ (Previously Asked Question) database.  If you found information outside this question thread, please add it.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question (if it has no potential value for others).
   --> Post comments for expert of your intention to delete and why
   --> YOU CANNOT DELETE A QUESTION with comments; special handling by a Moderator is required.

For special handling needs, please post a zero point question in the link below and include the URL (question QID/link) that it regards with details.
Please click this link for Help Desk, Guidelines/Member Agreement and the Question/Answer process.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Click you Member Profile to view your question history and please keep them updated. If you are a KnowledgePro user, use the Power Search option to find them.  

Questions which are LOCKED with a Proposed Answer but do not help you, should be rejected with comments added.  When you grade the question less than an A, please comment as to why.  This helps all involved, as well as others who may access this item in the future.  PLEASE DO NOT AWARD POINTS TO ME.

To view your open questions, please click the following link(s) and keep them all current with updates.

To view your locked questions, please click the following link(s) and evaluate the proposed answer.

*****  E X P E R T S    P L E A S E  ******  Leave your closing recommendations.
If you are interested in the cleanup effort, please click this link
POINTS FOR EXPERTS awaiting comments are listed in the link below
Moderators will finalize this question if in @14 days Asker has not responded.  This will be moved to the PAQ (Previously Asked Questions) at zero points, deleted or awarded.
Thanks everyone.
Moderator @ Experts Exchange
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.