80004005 Unspecified error or Run Time error -2147467259


I am working on a ASP application where it is using Integrated Authentication.  I am trying to use the SoapClient3.0 object (www.soapclient.com) and when i execute the soap call i get

Error Type
(0x80004005)
Unspecified Error..

If I throw the on error resume next i get a -2147467259 error.

Here is the code (right from thier web site sample code)

<%

on error resume next

set myAgent = Server.CreateObject("SQLDataSoap.SoapAgent")

myAgent.AddParameter "zipcode", "08540", ""

myAgent.SetProxy "mlamrs-proxy.us.ml.com", 8080, "", ""

Response.write "Proxy<br>"
Response.write err.number & "<br>" & err.description & "<br>" & err.source
'Response.write "<br>" & err.HelpContext & "<br>" & err.HelpFile & "<br>" & err.NativeError
'err.Clear

myAgent.ExecuteMethod "http://www.xmethods.net/sd/TemperatureService.wsdl", "getTemp"

Response.write "Execute<br>"
Response.write err.number & "<br>" & err.description & "<br>" & err.source
Response.write "<br>" & err.HelpContext & "<br>" & err.HelpFile & "<br>" & err.NativeError
err.Clear

LocalTemp = MyAgent.GetResponse("return")

Response.write "Get<br>"
Response.write err.number & "<br>" & err.description & "<br>" & err.source
Response.write "<br>" & err.HelpContext & "<br>" & err.HelpFile & "<br>" & err.NativeError
err.Clear

response.write(LocalTemp) & " : ok"

%>

The support there says it is a "rights" issue.

SoapClient is installed in the c:\soapclient3.0 dir
There is a path to that directory
And I set everyone for full access

Anyone know any issues

Windows 2k / iis 5
larzgoldAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Michel SakrConnect With a Mentor Commented:
internal name is : SQLDataSoap.SoapAgent

this should fix your issue
0
 
jitgangulyCommented:
Not sure, but may be its failng at the proxy lavel. Check the permission on that (proxy)
0
 
fritz_the_blankCommented:
Did you give the IUSR and IWAM accounts sufficient access? I am not sure that they are included under the everybody umbrella.

Fritz the Blank
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sk33v3Commented:
First you didn't declare myAgent or local temp. i would suggest you do that. that may fix your problem but i don't know.
0
 
larzgoldAuthor Commented:
Not failing at the proxy level - no need for authorization through the proxy, and can the an XMLHTTPRequest through it. I dont need to declare (dim) variables.. this is vbscript - i could, but it doesnt matter -

The sufficient access is a good thought - but where would I start - what rights should they have?
0
 
fritz_the_blankCommented:
You could start by giving full control to the IUSR and IWAM accounts. However, once you finished testing, I would back things off right away.

Fritz the Blank
0
 
Michel SakrCommented:
include the soap dll in COM+ (SQLDataSoap.SoapAgent) and assign an admin acount to run the package..

Start the Component services..in the tree select computers.. mycomputer..com+ applications...right click on it--> new -> application.. now in the wizard click next and select an empty application -> name your package  leave it in server process and click next -> Select the user and enter an account with enough rights to fufill your com jobs (admin account for ex) -> Finish..

now in the tree expand the new package untill you see the component directory-> right click it -> select new component-> in the wizard click next.. you can either install a new component if it's not registred or install a registred one if you already registred your dll (you select the 2nd choice) -> Select your component from the list (internal name displayed) -> Finish..
0
 
larzgoldAuthor Commented:
I really thought that would work silvers..

I actually reinstalled win2k -
installed the soapclient to its directory..
Gave everyone full access including iwam/iusr ids
Then I created the application / com component as directed
but still getting the error.

It seems you tested this out silvers - am i missing anything?

Larzgold
0
 
fritz_the_blankCommented:
Larzgold,

One last issue about the IUSR and IWAM accounts--they need to be those from the machine hosting the site, not that of the machine with the SOAP software. Are they one and the same server or two different ones?

Fritz the Blank
0
 
larzgoldAuthor Commented:
Fritz... it is one and the same machine...

0
 
fritz_the_blankCommented:
Never mind then!


Silvers5?

0
 
larzgoldAuthor Commented:
It should have been the correct answer - took multiple tries to get it to work, but it is working now.

Thanks Silvers5
0
 
Michel SakrCommented:
rgrds
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.