• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 450
  • Last Modified:

Visual C++ 6.0 on Win XP

Hello All,

I just installed Windows XP and after it I installed VC++ 6.0 from my VStudio 6.0 CD and applied SP5, but it did not run on Win XP giving errors.

I looked at the Microsoft website and couldn't find VC++ 6.0 as a compatible product to XP, but found that VC++ .net is designed for XP.

I was wondering if anyone is running VC++ 6.0 on XP and if not, can someone work with VC++ .net and produce code for Win98 or WinMe.  I have no experience at all with the .net products yet.  I appreciate your helpful information and recommendation with this regard.

Tarik
0
tdaoud
Asked:
tdaoud
  • 5
  • 2
1 Solution
 
jhanceCommented:
>>did not run on Win XP giving errors.

Errors?  Can you be more specific?

I installed and run VC++ 6.0 on XP Pro.  No problems at all.  But perhaps know what specific errors you are seeing would hel out here.
0
 
tdaoudAuthor Commented:
Thanks jhance.

It is good to hear that at least somebody ran VC++ 6.0 on XP Pro.

I will re-install it since I removed it after I thought it did not work.....I will be back with the error I get soon.
0
 
tdaoudAuthor Commented:
Hello jhance,

Here is what I get right after I finish the installation of VC++ 6.0 and try to run it.  A dialog box appears saying:

"Cannot load package 'devbied' because its internal version number, or the internal version number of one of its compnents, does not match the version of the Developer Studio Shell.  Do you want to conitue?"

I press OK and get a last dialog box saying:

"DEVBIED

This required file cannot be loaded
Please re-install Microsoft Visual C++"

It then exists.

Any help is greatly appreciated?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
tdaoudAuthor Commented:
Hello jhance,

Here is what I get right after I finish the installation of VC++ 6.0 and try to run it.  A dialog box appears saying:

"Cannot load package 'devbied' because its internal version number, or the internal version number of one of its compnents, does not match the version of the Developer Studio Shell.  Do you want to conitue?"

I press OK and get a last dialog box saying:

"DEVBIED

This required file cannot be loaded
Please re-install Microsoft Visual C++"

It then exists.

Any help is greatly appreciated?
0
 
jhanceCommented:
I'd suspect a bad VC++ CD.  Is this an original or a copy?

Can you copy the entire contents of the CD to your hard disk and run it from there?
0
 
tdaoudAuthor Commented:

Actually this is what I did, I installed from hard disk with no errors at all.  It is the original.  But it is VStudio 6.0 Enterprise and not just VC++ CD.
0
 
tdaoudAuthor Commented:

Thank you very much jhance for your hint of a possible bad CD.

I installed it again from the original CD rather than the hard disk and it worked fine.  I compared the problematic file on the hard disk and the CD and there was a different version number with the CD being a little newer.  It must have been a previous beta version on my hard disk or something wrong like that.

Thank you again for your hint.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now