• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 225
  • Last Modified:

Apache hangs on Windows NT

I am trying to simulate 100 concurrent using Rational Robo test suite on apache/tomcat.

versions are

apache : 1.3.9
tomcat : 3.2.1

Platform : Windows NT 4 SP6

After making 50 connections, Apache stops responding. I thought these was some problem with requests not going from Rational Robo but I cant even get the page from browser.

Is there any setting that needs to be done ?

Thanks.
0
ashishn
Asked:
ashishn
1 Solution
 
samriCommented:
On 1.3.24 there is a config file; highperformance.conf-dist which you could try.

Straight cut-and-paste from that file:
------------
# Ha, you're reading this config file looking for the easy way out!
# "how do I make my apache server go really really fast??"
# Well you could start by reading the htdocs/manual/misc/perf-tuning.html
# page.  But, we'll give you a head start.
#
# This config file is small, it is probably not what you'd expect on a
# full featured internet webserver with multiple users.  But it's
# probably a good starting point for any folks interested in testing
# performance.
#
# To run this config you'll need to use something like:
#     httpd -f C:/Program Files/Apache Group/Apache/conf/highperformance.conf

Port 80
ServerRoot C:/Program Files/Apache Group/Apache
DocumentRoot C:/Program Files/Apache Group/Apache/htdocs
MaxClients 150
StartServers 5
MinSpareServers 5
MaxSpareServers 10
# Assume no memory leaks at all
MaxRequestsPerChild 0

# this is a True Config File
# see http://www.apache.org/info/three-config-files.html
ResourceConfig /dev/null
AccessConfig /dev/null

# it's always nice to know the server has started
ErrorLog logs/error_log

# Some benchmarks require logging, which is a good requirement.  Uncomment
# this if you need logging.
#TransferLog logs/access_log

# Disable symlink protection and htaccess files, they chew far too much.
<Directory />
    AllowOverride none
    Options FollowSymLinks
    # If this was a real internet server you'd probably want to
    # uncomment these:
    #order deny,allow
    #deny from all
</Directory>

# If this was a real internet server you'd probably want to uncomment this:
#<Directory "C:/Program Files/Apache Group/Apache/htdocs">
#    order allow,deny
#    allow from all
#</Directory>

# OK that's enough hints.  Read the documentation if you want more.
0
 
niggCommented:
Check in the Tomcat configuration files how many open connections are allowed....The number 50 points propably to allowed open connections at one time...

Later...
0
 
periwinkleCommented:
No comment has been added lately, so it's time to clean up this TA.

I will leave a recommendation in the Cleanup topic area with the following recommendation for this question:

Answered by Samri

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

periwinkle
EE Cleanup Volunteer
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now