cFos ADSL connection crash with the MediaPlayer7.01, Help!

My ISP is using cFos connection software to emulate a COM port for the ADSL broadband service.  But after the cFos is installed, the Media Player stop working.  Every times the MPlayer is initiated, error message of "Assert Failed!" pop up.  That problem have made me unable to see any on-line videos.  Other than this, the connection speed is quite OK, often up to 1.5kbps.  
So can u provide any solution ??

Who is Participating?
DragonWolfConnect With a Mentor Commented:
this website (thought in German) has the solution.

Wenn Sie mit dem Windows Media-Player keine Breitband-Videos ansehen können, starten Sie unter "Programme -> Windows Media Player" MPLAYER2.EXE oder WMPLAYER.EXE. Dann deaktivieren Sie unter "Ansicht -> Optionen -> Erweitert -> Windows Media" die Option UDP. Bei WMPLAYER.EXE deaktivieren Sie UDP durch Rechtsklick im Anzeigefenster -> Optionen -> Netzwerk. Dies ist leider ein Problem, welches durch den PPPoE Standard auftreten kann.

Below is translation I can make out.

If you can look at no wide volume-videos with the windows media-Player, you start under "programs -> windows media Player" MPLAYER2.EXE or WMPLAYER. EXE. Then deactivate you under "view -> option -> expands -> windows media" the option UDP. In WMPLAYER. EXE deactivate you UDP through Right-Clicking in the notice window -> option -> network. This is unfortunately a problem which can appear through the PPPoE standard.
uninstall cFos still having this error?
version of cFos, windows, media player ... ?
try "sfc" command if it does any help

Have you already checked your ISP's website for info to see if this is a known problem that they're working on fixing?

Have you already installed the latest Critical and Recommended updates from ""?
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Right, just to translate that broken English above into something making more sense ^^

Go to Start|Programs|Accessories|Entertainment
Right click on the Windows Media Player button and select Properies
In the Target Window is should say ...\WMPLAYER.EXE or MPLAYER2.EXE

If it says MPLAYER2.EXE then,

click cancel
Open Windows Media Player
In the menu bar Click View|Options
Click the Advanced Tab
Select Streaming Media and press change
Deactivate the UDP tickbox
Click Okay

It should work now

(Unfortunately I don't have the WMPLAYER.EXE so could not find out how to fix this one, try following the broken English in the previous Comment)

This is unfortunartely a problem which can appear through the PPPoE standard that your ISP probably uses.

The--CaptainConnect With a Mentor Commented:
DragonWolf - your obnoxious tactic of posting your comments as answers is getting you a visit from CS (if they'll listen to me on this, and they usually do).  Can't say I didn't warn you.  

Please learn how to play nice [AKA RTFM].

kenso - please reject this inappropriate "answer", and let us know how your problem resolution is progressing.


How does it not class as an answer?

It answers his question/problem.
James ElliottManaging DirectorCommented:
<It should work now

(Unfortunately I don't have the WMPLAYER.EXE so could not find out how to fix this one, try following the broken English in the previous Comment)>

That is not an answer!
>How does it not class as an answer?

>It answers his question/problem.

If you had read the AUP like I suggested, you would now realize that your should only post an answer if you are %100 certain that it will solve the problem - since I guarantee that you cannot make such a claim, your post did not qualify as an answer.  In any case, you should realize that in most circumstances, posting an "answer" rather than a "comment" is in rather poor taste - it implies a superior attitude, and removes the question from the list of active questions (which has the effect of moving it much farther down the page), and generally shoves your comment down the throat of the poster, rather than letting her/him choose from all the available comments (a poster may accept any comment as an "answer" at any time, and points are awarded exactly the same - I assume you did not know this, since you didn't read the AUP.)


Would have been here sooner, but all Admin tools were down since the 15th.

DragonWolf, please heed the advice given you from the Experienced Experts, never use the Answer button even though its there, always use the Comment Button, a better way to improve your status here.


Community Support
Administrator @ EE
May I ask that you do one of three things.

1.  If you still have a problem let us know and give us some more details.  

2.  If you feel someone helped you, accept their answer.  If you feel that more than one person helped you, then you can split the answer.

3.  If you feel that you were not helped, then you can post a 0 point question in Community Support and ask that this be deleted.  It also be polite to advise us why its being deleted.

If we don't hear from you in a reasonable period of time, I will request that an EE Moderator

POINTS TO DragonWolf

Please do not accept this comment as an answer.

I also note that you have a number of questions open on EE that have been open for some time.  May I respectfully ask that you close these questions out.  It's simply not fair to EE Experts to ask questions and then not finalize them.
kensoAuthor Commented:
I have to agree to  "The--Captain ".
Previously I kept silent, bcos it seem not help.
Bcos, what I am using is the WMPLAYER.EXE but not MPLAYER2.EXE mentioned by Dragonwolf.  

So up to now, no solutions.

I'm not trying to get involved in DragonWolf's posting of a comment as an answer.  He shouldn't have done that but I think he might have given you the correct answer.

If I can translate his comments into your version of WMP.

Open up Windows Media Player
Select Tools
Select Options
Select Network
Uncheck UDP

Let me know if that worked.

>So up to now, no solutions

So, DragonWolf's comments (and Harry's) did not help?  Please clarify...

Have you tried adjusting your MTU - this can be a problem with encapsulated connections (ie PPPoe).

Unless DragonWolf's comment (posted as an asnwer) can be verified to solve this problem, I strongly object to him being awarded points.  If there is no resolution, I suggest a pt split - Harry seems to like all-or-nothing resolutions (I notice he claimed all pts [rather than a pt split] in one or two dead questions lately - ie Q_20335185), but I think a pt split is almost always more fair if no solution has been achieved.

Harry - what are you doing claiming points in questions where no one agreed with you, but two or three people agreed with me (see above reference)?  

I'm curious to know if kenso hasn't posted a comment, how you can know that my comment didn't help?
Since I closed out the duplicate question, I am posting The--Captain's response that was stranded there.

From: The--Captain  Date: 04/27/2002 01:38AM PST
It sounds like your cFos software is replacing a necessary component/library/dll that is required by media player - what happens if you re-install media player after you get your cFos connectrion working?
If you run one of the many install "trackers" out there, you will probably be able to determine which file your cFos software is replacing that breaks media player...
Have you done the appropriate searches on microsoft and google to see if anyone else has encountered this problem?

This is not yet scheduled for cleanup, but the comment in the dup thread may be valid, so I've placed it here.  Dup Q # was 20294232.

Community Support Moderator @Experts Exchange
Sorry I havn't posted for so long. I've move home and was having trouble with my e-mail provider.

I apologise for my conduct, and it was a case of RTFM on my part.  Also, I apologise for trying to help close the duplicate threads.

Does not bother me if I receive the points or not, just whether kenso's problem is solved.

BTW, Harry, Cheers for the support.
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Split The--Captain and  Dragonwolf

Please leave any comments here within the next seven days.


EE Cleanup Volunteer
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.