Problem regarding sendmail

I have sendmail with default settings... did not make any changes.... i can send from some other account to root@mydomain.com ... but from root neither can i send nor reply to any other user accounts on the system.
harisnshawAsked:
Who is Participating?
 
PashaModConnect With a Mentor Commented:
Questioner did not follow up the question so points are not refunded and question closed

PashaMod
CS Moderator
0
 
jlevieCommented:
What error condition is encountered when root attempts to send mail to some other user on the system? What tool are you attempting to send the mail with?
0
 
harisnshawAuthor Commented:
i am using pine to send the mail. I get the error user unknown...
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
jlevieCommented:
What happens if you do 'mail -s test some-local-user'? If that works and pine doesn't, then it sounds like a problem with root's pine configuration.
0
 
harisnshawAuthor Commented:
I get the same error user unknow. If i try mail -s test root it works. But any other user it does not work
0
 
jlevieCommented:
These are linux accounts on this machine, right? By that I mean that those users can log onto the machine with their username & password.

What happens if you do 'mail -s test some-user', i.e., with out any domain specification. If that works and user@mydom.tld doesn't it could indicate that sendmail is confused about what domain it is responsible for. And that could happen if the system is configured for one domain and gets its IP via DHCP, which could result in a change in the hostname of the system.

You should be able to tell if something like that is happening by comparing the contents of /etc/hosts, what hostname returns and what a reverse lookup of your IP returns. If /etc/hosts doesn't agree with 'hostname' there'll be problems with sendmail.
0
 
harisnshawAuthor Commented:
if i try mail -s test xyz ( xyz is  a local linux user ) then nothing happends..... here is the screen shot

[Haris@sys02 Haris]$ mail -s test Haris


after that i have to press ^C then i get

(Interrupt -- one more to kill letter)

again i have to press ^C then i get back

[Haris@sys02 Haris]$

also i don't use any DHCP server...I have a static ip... my rpm is corrupted ( u only helped me with that in another question and i will reinstall the whole thing soon... )
0
 
arvindCommented:
Cud u post the 1st 10 lines of ur pine config:

pine -> setup-> config
0
 
jlevieCommented:
When you use 'mail -s some-subject some-user' the mail utility expects you to type in a message and then hit ctrl-D to signify the end of the message. mail will then prompt for a Cc: and you can hit ctrl-D again. Only then will the utility actually attempt to contact sendmail to deliver the message. So a transcript of that process looks like:

chimera> mail -s test jim@entrophy-free.net
This is a test message
Now I'll enter ctrl-D to signify end of message...
Cc: chimera>

By entering the ctrl-C's you've told mail to abort and throw the message attempt away.
0
 
CleanupPingCommented:
harisnshaw:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
jlevieCommented:
I'd say to refund the points as the questioner seems to have lost interest in the middle of diagnosing the problem.
0
 
Cyclops3590Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
paq/refund
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Cyclops3590
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.