Solved

ServletExec and IIS: file.java not recognized as servlet!?

Posted on 2002-04-29
3
253 Views
Last Modified: 2006-11-17
I've installed ServletExec on IIS 5.0/Win2k and am having problems getting servlets to run.  First off, this was working; we've had ServletExec, IIS5, and ArcIMS(Map Software) playing nicely, but it appears to be a VERY fragile arrangement.  So today, someone made unknown changes to IIS, trying to affect a misdiagnosed problem with scripting, and now my site which uses ServletExec will not load.  The best description of the problem I can muster, is that when you try to load the TestServlet or Admin servlets, as suggested by New Atlanta, going to http://servername/servlet/admin or TestServlet, instead of executing the file, it prompts to download or open it from it's current location.  Of course if you try to open the file, Win2k doesn't know what the hell it is.  Tried reinstalling ServletExec to no avail.  Permissions are wide open(Everyone Full Access) on New Atlanta\ServletExec ISAPI\ Directory.  Any Ideas?
0
Comment
Question by:benhanson
  • 2
3 Comments
 
LVL 2

Accepted Solution

by:
pssiew earned 250 total points
ID: 6979700
Try to make the folder where the file is executable from the IIS Console.

I am not familiar with the ServletExec software, but your problem looks like the application's executable file is not made executable in IIS hence when browsed, it is prompts for download.

Check for a .exe file location
0
 
LVL 12

Author Comment

by:benhanson
ID: 6981492
This was the case.  Actually, the file in question is a .dll, but the Scripts folder in IIS still needed permission to run "Scripts and Executables", so IIS must consider the Java servlets executables.  The actual steps involved:  Open IIS Managager, open properties on <servername>:Default Web Site:Scripts, go to Virtual Directory tab, and change Execute Permissions setting to "Scripts and Executables"  This got me to the point that the example and admin servlets worked, then I was able to work out the remaining ServletExec wierdness, which involved re-entering Serial number, the info was blown away during reinstall(Its in a file, not the registry), re-adding a Virtual Machine:Class Path to ServletExec through the Admin servlet, then re-copying Connector\Servlet\ Files from ArcIMS install directory.  Each of these steps require a restart of IIS, though if they are done all together they would probably only require one restart.  Thanks for the help pssiew.
0
 
LVL 2

Expert Comment

by:pssiew
ID: 6984941
No problem Ben. Glad that you managed to solve it.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Today I came across an interesting issue that had me pulling my hair out.  I was troubleshooting a new internal web site which uses integrated security instead of anonymous.  When browsing the site from my laptop, I was able to access it with no iss…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now