Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Files disappear after using floppy in Windows

Posted on 2002-04-30
9
Medium Priority
?
483 Views
Last Modified: 2010-04-20
When we are logged in as anyone other than the root, save a file to the floppy, and bring it to a Windows machine, the file is not there.  Then, when we put it back into the Linux machine, the file does not show up there either.  How do we fix this?
0
Comment
Question by:moterk
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 4

Expert Comment

by:MFCRich
ID: 6981581
Do you unmount the floppy before you remove it from the drive?

> umount /mnt/floppy

Assuming it is mounted on /mnt/floppy
0
 

Author Comment

by:moterk
ID: 6981606
We are using the gnome with x-windows it should automatically unmount.  And we do nothing differently as the root user, but for the root user it works perfectly
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6981933
did you get error messages?
Sound like ordinary users have no permission to the floppy device.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:moterk
ID: 6982011
All users are in the user group and have rights to the floppy.  It gives no error when the file is moved or copied onto it.  It just is not there when the floppy is stuck into a Windows machine.  The floppy is formated for windows.  If we save something from the windows machine to the floppy, Linux reads it fine.  We have tried more then one windows machine to see if it was machine dependant.
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 800 total points
ID: 6982068
either unmount, or sync /mnt/floppy (or whatever your floppy is) before removing it (still suggested by MFCRich)
0
 
LVL 1

Expert Comment

by:fauzdar
ID: 6982763
when you a copying the file to the floppy make sure that u dont copy it with the permissions. as windows does dont have permission system. on  the copy tab that appears in gnome, go to advanced options and uncheck "Preserve file Attributes".
0
 

Author Comment

by:moterk
ID: 6983491
fauzdar, I believe the Linux file security attributes can not be stored on a non ext partition.

ahoffmann, I tried using sync in fstab a couple days ago and it did not work so I removed it.  Then yesterday before I submitted this question I found a suggestion on the internet.  The suggestion was to assign the floppy mount rights to a certain group and put all of my users into that group.  I tried that and it did not work.  Then after reading your suggestion about sync, I tried sync in fstab again.  And sync in combination with the group fix I tried earlier fixes the problem.

Should I give the points to you or MFCRich?
0
 
LVL 4

Expert Comment

by:MFCRich
ID: 6984320
I don't mind. But I think the solution you have choosen is closer to ahoffmann's.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6985351
> And sync in combination with the group ..
nice that you got a working solution.
Even I meant /bin/sync rather than the fstab option ;-)

So experts vote for my suggestion --thanks-- I'd give another one:
    use mcopy instead of cp
mcopy does not need a mounted floppy (does mount on the fly), and works with (V)FAT floppies directly. You don't need to take care about syncing.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month14 days, 20 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question