Solved

windows 2000 and samba

Posted on 2002-05-06
12
330 Views
Last Modified: 2013-12-15
 I'm a Windows user learning to administer Linux machines.
  I just installed RedHat Linux 7.2, and I sucesfully setup NIS and some other services. I was using Samba fine with my Win Me clients, but now I installed Windows 2000 Server in a machine and it refuses to work. If I try to join the machine in my domain I got an error message saying something like "this account is a computer account". What's that?
0
Comment
Question by:felipes
  • 3
  • 2
  • 2
  • +4
12 Comments
 
LVL 5

Expert Comment

by:garboua
ID: 6996844
On the samba server, you have to do smbpasswd -a -m <machinename>.  this adds an entry to the smbpasswd file for the machine.
It also have to be added to /etc/passwd as well
0
 

Author Comment

by:felipes
ID: 6998680
 Still doesn`t work.
  I added to my /etc/passwd the following line, it's correct?
  desenv4$:x:1008:1008::/home/desenv4:/bin/bash
  desenv4 is the name of the machine...
  I believe I need a step-by-step guide.
0
 
LVL 5

Expert Comment

by:garboua
ID: 6999414
edit /etc/passwd
desenv$:*:33002:33000:Trust Account:/dev/null:/dev/nullon Now on samba Server (your linux box) run smbpasswd -a -m desenv

33002:33000 are uid,gid you can change them.
you Can NOT run smbpasswd before adding the entries to your /etc/passwd.  If you are using shadow passwd, you have to add it to your shadow passwd file as well.
how is that for step by step? :0)
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Author Comment

by:felipes
ID: 7001588
guess what?
doesn`t work
and now it says it`s an invalid username/password :-)))
0
 

Expert Comment

by:rprakasan
ID: 7031453
Firstly u have to add the machine account with the following command,
'adduser -g 100 -d /dev/null -m -s /bin/false yourmachine$'
and the add this account to samba passwd file by giving the command 'smbpasswd -a -m yourmachine'. The try to change the domain of Windows 2000 to Linux DOMAIN, by giving the username & passwd of ur trust account. Mostly it will be usr 'root'
This will work.

thanx
rajesh
0
 
LVL 6

Expert Comment

by:st_steve
ID: 7036453
Invalid username and password? Also check the encryption settings. Windows 2000 uses encrypted passwords for user authentication, which can be changed:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters

Add a new DWORD value
Value Name: EnablePlainTextPassword
Data: 0x01

Of if you don't want to change Windows 2000, you can change Samba

In the [global] section of /etc/smb.conf, add the following line:

encrypt passwords = yes


And also read the files Win95.txt, Encryption.txt and WinNT.txt in the Samba documentation.




0
 

Author Comment

by:felipes
ID: 7036988
 I've done all that
0
 
LVL 4

Accepted Solution

by:
kannabis earned 50 total points
ID: 7048975
I've been doing this all week long, this works for me

add the machine to the unix passwd list with

adduser -d /dev/null -g machines -c 'Machine Account' -s /bin/false -M SYSTEM_NAME$

then do a smbpasswd -am SYSTEM_NAME  no need to put the dollar sign.  The dollar sign is how samba knows this is a machine account

I did this about 3 minutes ago and it works.
0
 

Expert Comment

by:CleanupPing
ID: 9077016
felipes:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 6

Expert Comment

by:st_steve
ID: 9083655
Waiting for comment from felipes
0
 
LVL 1

Expert Comment

by:drewber
ID: 9220384
This question has been classified abandoned. I will make a recommendation to the moderators on its resolution in a week or two. I appreciate any comments that would help me to make a recommendation.
 

Unless it is clear to me that the question has been answered I will recommend delete. It is possible that a Grade less than A will be given if no expert makes a case for an A grade. It is assumed that any participant not responding to this request is no longer interested in its final disposition.

 
If the user does not know how to close the question, the options are here:
http://www.experts-exchange.com/help/closing.jsp
 
drewber
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question