Two BDE apps won't run together

A customer is using our application on a machine that also has another BDE-based application installed.  He can run either app on its own, but not both together (the other app falls over with error initializing BDE).  Our app is Delphi 5, installed using bundled InstallShield.  I am setting private and net directories in my startup code if that matters - is it not possible to have two sessions running with different net dirs?

It seems that our app always stays running and the other one fails when trying to run both at once.

Any ideas?

Rob
robnorthcottAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
YensidModConnect With a Mentor Commented:
Question is PAQ'd and no points refunded.

YensidMod
Community Support Moderator @Experts Exchange
0
 
kretzschmarCommented:
>is it not possible to have two sessions running with
>different net dirs?

yes, is possible,
but not for the same database-directory,
therefore tell us:
-are the two appy sharing the same database-directory or same tables?

meikl ;-)
0
 
robnorthcottAuthor Commented:
Thanks for the reply Meikl,

No, the two apps are not using the same tables or directory.  The only common factor is that they both use the BDE.  The other app is one that runs on startup (bit like MS Office bar) but doesn't seem to access any BDE until the user selects an option - then it falls over with an error.  My app will run alongside the "toolbar" thing, but must be closed before the other app can open its own files.

Is there anything I could be doing that would "hog" the BDE?  I have run other BDE apps together before with no problems, so there must be something wrong here.

Rob
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
SteveWaiteCommented:
listening :)
0
 
YodaMageCommented:
Did you consider increasing maxfilehandles and maxmemsize, as your issue might be capping out the defaults maximums of the BDE.
0
 
kretzschmarCommented:
good point, yodamage :-)

i myself have no idea yet :-(
0
 
lottolCommented:
I had this problem everytime I reinstall system on my PC. I solve it by changing BDE settings as YodaMage said.
0
 
robnorthcottAuthor Commented:
Thanks,

I'll get them to try that and see if it helps.
Get back to you later!

Rob
0
 
robnorthcottAuthor Commented:
Doubling file handles and memory didn't solve the problem.  Each app runs on its own, so they can't possibly need more than double the defaults together can they?  Still gives the "Error occured while initialising BDE" message.

Bummer :(

The customer isn't making a big fuss about this, but it would be nice to get it working.
Any more cunning plans?  Anything appreciated...

Rob
0
 
YodaMageCommented:
Out of curiosity, have both apps share NET DIR and tell us what happens.
0
 
lottolCommented:
I still think it's a settings problem.
I think you'd lose nothing if you test my settings.

LOCAL SHARE false // optional
LOW MEMORY USAGE LIMIT 32    
MAXFILEHANDLES     48
MEMSIZE     64
MAXBUFSIZE 2048
MINBUFSIZE 128
MTS POOLING false // optional
SHAREDMEMLOCATION 2000 // optional
SHAREDMEMSIZE 32768
0
 
robnorthcottAuthor Commented:
Lottol:
Thanks, but that didn't make any difference.  Still gives an error initialising BDE.

YodaMage:
I'll try that if I get the chance (it's in a busy garage so not much time to fiddle with stuff while they're open).
I might be able to get them to use the same NETDIR if I set the default NETDIR to my app's directory (my app sets NETDIR and private dir in its startup code), assuming that the other app uses the defaults.

In the meantime, any other suggestions welcome!

Rob
0
 
freshman3kCommented:
Hello,

Set LocalShare in the BDE Admin to true. I have 3 BDE applications open at one time, and seems to work just fine.

0
 
robnorthcottAuthor Commented:
Local share is set to True already - my app actually forces this setting when it runs because of problems that can occur if it is not set.

My next approach is to give YodaMage's suggestion a try, but things are a bit hectic at the moment, so it may not get done for a couple of weeks.

Thanks anyway

Rob
0
 
pnh73Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQ with Refund

Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
Paul (pnh73)
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.