Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

WinXP with USB Modem Connection Problem

I am having trouble dialing in to the research centre where I work with my new D Link External USB modem. I am using Windows XP Professional and I've configured the connection the same way as I did when connecting using Windows 98. I don't believe the problem is related to the D Link hardware because I am able to dial in to other sites with no problems.

When I dial in to the modem I receive the following error message:

Opening port...
Error 678: The remote computer did not respond. For further assistance ...

The D Link Modem has the following description in the General tab of the connection properties:
Modem - Conexant HCF V90 Data Fax Voice USB Modem

The modem I am trying to connect to is a:
Banksia iNTRA8 ISA Card 336 - BC5052C

TIA
0
davidrahal
Asked:
davidrahal
1 Solution
 
Snazzy_GraphicsCommented:
Hi. I'm a graphics guy with similar problems.

Got quite an education about this last couple of days.

Try setting up a log file for your modem in the control panel. Then look at the bottom of that and you'll see how the two modems tried to negotiate.

Although 678 says the remote machine is not answering, that may not be the whole story.

I was able to improve my connection by changing some settings using hyperterminal.

Specifically for me: AT&Nxx and AT&Uxx seem to help by changing what frequency of carrier I send; where the values xx are a table of speeds (may be different for your modem or your circumstances). I then write that (AT&W) and use an init string which employs it (AT&F).

However, what I'm talking about may be overkill for you. Before going there, make sure the other modem is answering (turn volume on and/or look at that file). Make sure cancel if not connected is checked and set a timeout of 60 seconds. In Conection > call prefs.

These HCF USB modems are apparently a bear in XP.
0
 
Snazzy_GraphicsCommented:
Some corrections and added info:

I've been messing around some more in Hyoerterm.

Confirmed that you can get a 678 by having &U set too high. &U is the lowest speed you are willing to connect at. Although other requirements may prevent the connection too.

To fix you can do AT&U0&N0 (<--those are zeros). That just means best speed. Then you would AT&W to write that to modem. And use ATZ1 to activate that (not F like I had earlier).

But that may well be how you are set up in the first place.

I suppose the place to start messing about is the modem advanced config tab, init string. Try it with:

First try: ATZ
2nd: AT&F
3rd: AT&F1

Those should send you through factory setting possibilities, skipping whatever XP has decided you want.
0
 
st_steveCommented:
listening and learning...
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
davidrahalAuthor Commented:
Sorry I've taken so long to reply. I've been overseas.

I managed to get a hyperterminal talking to my modem yesterday. I didn't have any luck with my first attempts at using the AT commands. Maybe I'm not using them properly.

Should I continue asking question in the comment section of ee or do I need to contact Snazzy_Graphics directly?

TIA
0
 
Snazzy_GraphicsCommented:
ask away.

--Snazzy
0
 
davidrahalAuthor Commented:
I wasn't able to use the <AT&Nxx> and <AT&Uxx> commands you suggested to control the carrier speed of my modem. Instead I tried a connection using the modem modulation command which has the following syntax:

AT+MS=<carrier>,<automode>,<min_tx_rate>,<max_tx_rate>,
<min_rx_rate>,<max_rx_rate> where <carrier> is the Carrier code for modulation type (V34 = V.34, V90 = V.90, and K56 = K56): <automode> 0 = Automode Disabled, 1 = Automode Enabled: <min_tx_rate><min_rx_rate><max_tx_rate><max_rx_rate>      are the Minimum And Maximum Data Rate for Transfer and Recieve Respectively

I had a look at the Banksia Modem Manual (receiving modem)and it only supports V34 carrier. I was able to connect using:

AT+MS=V34,1,75,28800,75,336000

I'm not entirely happy with crippling the modem to access this modem because I also connect to other ISPs. My understanding is that the modem tries to connect with the fastest modulation first then tries other modulations until it finds one that works. Maybe I need to change a parameter to allow the USB modem more time to connect to the Banksia modem at different modulations.

I'll post more information if I find an additional parameter I can change.

Thanks for you help on this. I was floundering until you pointed me in the right direction.

0
 
TheBadManCommented:
A trick I used with Win 98 (don't know if it will work with XP) to get 2 PC's connected modem-modem, was to append three comma's  after the phone number in the dial-up adapter eg. "xxxx,,," This forced the modems to wait a little before connecting, at least that is my understanding.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now