Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Question about serial ports

Posted on 2002-05-09
10
Medium Priority
?
242 Views
Last Modified: 2010-04-26
I bought a Royal postal scale that downloads the current postal rates from the internet.  The scale is connected to the pc with a RS232 Serial Cable.  When I attempt to download the current postal rate from my pc to the scale; I get a message that the download failed.

My OS is Windows NT 4.0. Serial Port 1 is set to Com 1 & Serial Port 2 is set to Com 2.  My modem is set to Com 3.  In the setup software for the download; I am supposed to choose the com port that the serial cable is connected to.  I've tried Com 1 & 2 and I get the same message.

I went into the bios to see if the serial ports were enabled.

They were set to Auto.  Tried to download on these settings first.  Would not work.  I then changed serial port 1 to Com 1, etc.

Can anyone tell me what I am doing wrong?
0
Comment
Question by:Miked062998
  • 3
  • 3
  • 2
  • +2
10 Comments
 
LVL 13

Expert Comment

by:magarity
ID: 6999543
First, does the program's specifications say it works with WinNT?
0
 
LVL 31

Expert Comment

by:rid
ID: 6999578
A modem on com3 suggests an internal modem. Are you certain that the com1 and com2 are enabled in the BIOS? Sometimes internal modems throw tantrums if they cannot get whatever I/O and IRQ they want - and these may be occupied by something else, like onboard com ports. It may be worth checking out.

Regards
/RID
0
 
LVL 31

Expert Comment

by:rid
ID: 6999585
Sorry for being blind or something, ugh.

:-\
/RID
0
Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

 
LVL 31

Expert Comment

by:rid
ID: 6999590
A serial cable... did it come with the scale?
/RID
0
 
LVL 13

Expert Comment

by:magarity
ID: 6999644
"a Royal postal scale"

I wonder if Royal is the brand name or are you in England?
0
 

Author Comment

by:Miked062998
ID: 6999779
The software does work with Windows NT. It is an internal modem on Com 3 and it is working fine.  The serial cable did come with the scale and "Royal" is the brand name.
0
 
LVL 17

Expert Comment

by:xema
ID: 6999797
I will only try com2 as com 1 and 3 will share the same IRQ, Have you check the settings on the ports, baud rate, pariety, stop bits?
0
 
LVL 13

Accepted Solution

by:
magarity earned 300 total points
ID: 6999802
OK, the most likely culprit is probably flow control.  Without the manual to the device/program I can just give pointers:  Look to see if the flow control is specified.  You can set the flow control for the serial ports in the Windows hardware manager (I forget what exactly WinNT call it).  The device may need flow control turned off or the speed limited somehow.  For example, the device might have a 19200 max baud UART in it but the computer is expecting 128000 baud.  In this kind of case, WinNT would be told to limit the computer to 19200.  Etc, etc.

See?  Sorry I can't give exact instructions but I don't have the manuals.  Please write back with additional questions and be sure to supply as much detail as possible into what you are able to figure out.
0
 

Author Comment

by:Miked062998
ID: 7002255
Thanks for your help.  Could not get it to work on that pc.
Tried another pc and it worked fine.

Thanks again

Mike
0
 

Expert Comment

by:twoodall84
ID: 7002280

Software Issues -
I'm assuming the download from the web to your pc worked without any problems and you saved some file to a local drive. If so, what software are you using to tranfer the downloaded file to the scale? Does it have settings which specify COM port (or IRQ and port), baud, parity, stop bits, flow conrtol?

Hardware Issues -
Do you have to do something special to the scale to let it know it will be receiving data?

Stay away from COM 1 as it normally defaults to the same IRQ as COM3. If possible, verify on bootup that COM2 is using IRQ 3 and port 2F8. If it doesn't or your unsure, try forcing it to these settings in BIOS. Do you have an external modem to test COM2 with? If you haven't used the port before, this would be helpful.

Also is there any other hardware (such as a network card) in your PC that might interfere with the port resources?
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
This is about my first experience with programming Arduino.
Integration Management Part 2
Screencast - Getting to Know the Pipeline

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question