Solved

too many httpd processes

Posted on 2002-05-11
3
554 Views
Last Modified: 2010-05-18
There are too many httpd processes in my RH linux server running Apache. It makes the loading average very high, and the websites very slow to connect, and finally server "down"!

How can I do so as to reduce to httpd processes, is a connection uses a httpd process, can a httpd process handles many connections?

Thanks.

Stanley
0
Comment
Question by:stanleyhuen
  • 2
3 Comments
 
LVL 15

Expert Comment

by:samri
ID: 7004035
I looks like maybe your apache is having some problem, or you are under some denial-of-service attacck.

In either case, try to monitor your apache activity using http://your-server/server-status

You need to enable the feature.  Look in httpd.conf for the following directive, and uncomment the lines.  And make sure you add your IP address in "Allow from.." line.

-----------
ExtendedStatus On
#
# Allow server status reports, with the URL of http://servername/server-status
# Change the ".your_domain.com" to match your domain to enable.
#
<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 192.168.0 127.0.0
</Location>
-----------

What is your OS, and Apache version?
0
 
LVL 15

Expert Comment

by:samri
ID: 7004037
I looks like maybe your apache is having some problem, or you are under some denial-of-service attacck.

In either case, try to monitor your apache activity using http://your-server/server-status

You need to enable the feature.  Look in httpd.conf for the following directive, and uncomment the lines.  And make sure you add your IP address in "Allow from.." line.

-----------
ExtendedStatus On
#
# Allow server status reports, with the URL of http://servername/server-status
# Change the ".your_domain.com" to match your domain to enable.
#
<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 192.168.0 127.0.0
</Location>
-----------

Anothe thing to watch is, try using "netstat" from UNIX cmdline, and watch the remote-address field.  If there is too many connection from one specific IP address, it might be suspicious.

CHeck the server log (tail -f error.log), and see if there is any weird entries.

What is your RH, and Apache version?
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 50 total points
ID: 7004679
is this a duplicate question?
Anyway ...

# see following variables in httpd.conf
MinSpareServers
MaxSpareServers
StartServers
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
Introduction As you’re probably aware the HTTP protocol offers basic / weak authentication, which in combination with the relevant configuration on your web server, provides the ability to password protect all or part of your host.  If you were not…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question