• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 269
  • Last Modified:

Windows 2000 reboots instead of shutting down

When I attempt to shut down Windows 2000 SP2, instead of shutting down it reboots.  When I try to reboot, it will reboot successfully.

I have had problems with shutting down and rebooting before, and these were related to Adaptec DirectCD being installed.  That program is now at the latest version.

Any ideas?
0
thechatking
Asked:
thechatking
  • 4
  • 3
  • 3
  • +3
1 Solution
 
MFKCommented:
0 Logoff

1 Shutdown

2 Shutdown and Restart

3 Shutdown and Power Off*

Root Key: HKEY_CURRENT_USER
Key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Shutdown
Entry: LogoffSetting
Entry: ShutdownSetting
Data Type: REG_DWORD

Check the above key...may be somehow W2k is using it if set to 2.

0
 
thechatkingAuthor Commented:
The 'Shutdown' key does not appear in my registry.  Should I add it?
0
 
CrazyOneCommented:
See if this helps

Go to Control Panlel > Power Options > APM and make sure there is a check mark in the "Enabled Advanced Power..." box.


The Crazy One
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
stevenlewisCommented:
HOW TO: Troubleshoot Shutdown Problems in Windows 2000 (Q315409)
http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q315409
0
 
thechatkingAuthor Commented:
CrazyOne... "Enable Advanced Power" was checked, so I unchecked the box and it didn't solve it.

Steven, I read the articles but I'm not sure they're relevant as they all refer to errors during shutdown.  There's no error message during my problem.

Could it be that the problem is again related to DirectCD being installed?  I have heard this causes problems on Windows 2000 computers.
0
 
CrazyOneCommented:
>>>Could it be that the problem is again related to DirectCD being installed

I suppose it is possible but I have it installed and don't have this problem. Test by removing it and then see what happens.
0
 
thechatkingAuthor Commented:
Before shutting down, I killed the DirectCD process from Task Manager and the computer shut down correctly.

Now, how do I get DirectCD to close automatically before I shut down?
0
 
stevenlewisCommented:
try msconfig for w2k
MSCONFIG for Win 2000

http://www.insideproject.com/guides/showguide.cfm?guideid=31

http://www.insideproject.com/downloads/msconfig2k/msconfig.zip




and then uncheck it to keep it from starting automatically
it will still run when you want it to, just won't run on startup
0
 
Mark_RCommented:
I'm presuming there are no DirectCD files in your 'Startup' folder, so you could try taking a look under the following Registry key (using Regedit.exe):

HKLM\Software\Microsoft\Windows\CurrentVersion\Run

There'll probably be an entry for a DirectCD file there.  

If you highlight the entry in the right hand pane of the Regedit window, then click on the 'Registry' menu and choose 'Export Registry File...', you can then save the key (for safety!!) before deleting it from the Registry.

This will stop the memory-resident portion from being loaded at startup.  Be sure to save the key just in case the removal affects the operation of DirectCD when you try to run it manually (although that would be unusual).
0
 
jmiller47Commented:
Use the appliaction WINMSD and go to the startup tab. Disable it there.
0
 
CrazyOneCommented:
Umm unless I misread something thechatking is not concerned about the program running but being able to close it before invoking the Shut Down. I suppose a shutdown script would be the way to go by killing DirectCD before the ShutDown starts.

>>>>Now, how do I get DirectCD to close automatically before I shut down?  
0
 
jmiller47Commented:
CrazyOne,

Thank you! You are absolutely correct. I sort of skimmed over this question and did not read it in it's entirety.

TheChatKing,

With Windows 2000, the easiest way I know to accomplish this is to use a logoff script on the computer's Group Policy. You do NOT need Active Directory for this.

Go to Start>Run> and type GPEDIT.MSC and press OK. This will start the MMC for Group Policy. Expand Computer Configuration > Windows Settings > Scripts > and choose Shutdown. You can place a script to shutdown you application at logoff (Also shutdown/Restart...) here.

If you need a script for this, I could do it, but it will not be easy. Please see what you can do and if you cannot find a script to do what you need, let me know. I will see what I can do for you.

Otherwise, placing your script at that location will ensure that it is run before shutdown, logoff, or restart.

I hope this helped. Let me know if you need a kill process script created. I will try my best to help out.
0
 
thechatkingAuthor Commented:
Problem solved!

It's turns out that all I had to do was disable APM.  I tried this earlier and it didn't work, but now it seems to have solved the problem for good.

Bad diagnosis on my part, I'm afraid.  Thanks for all your contributions to the problem anyway!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 4
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now