Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium


"error 0007 Stage Control Blocks were destroyed".

Posted on 2002-05-13
Medium Priority
Last Modified: 2007-12-19
I am attempting to install Oracle (Personal Edition 8.1.7) on a NT stand_alone At the point where oracle attempts to start up the OracleOraHome 81 service; this comes up "error 0007 Stage Control Blocks were destroyed". Is this something to do with entries nut being able to have been made into the Registry???

Can anyone hulp??

Even if you manually try to start up the service like error.
Question by:spd800c2
1 Comment

Accepted Solution

MFK earned 150 total points
ID: 7005803
This is from metalink:

Subject: error 0007: Storage control blocks were destroyed

RDBMS Version:: 8.1.7
Operating System and Version:: NT 4.0 SP5
Error Number (if applicable):: error: 0007
Product (i.e. Instance, Security Manager, etc.):: Intelligent Agent
Product Version:: 8.1.7
OEM Console Operating System and Version:: NT 4.0

error 0007: Storage control blocks were destroyed

error 0007: Storage control blocks were destroyed

I am receiving the error 0007: Storage control blocks were destroyed every time I try to start the Intelligent Agent service on my NT4 server. I have gone through all the following suggested steps to correct the error but it still will not work. Can you suggest something else that might work?

1) I have checked the NMICONF.LOG file for errors but it contains none.
2) I have verified that the Listener service is started and TCP/IP configured properly on my NT server.
3) I have verified that the LISTENER.ORA & TNSNAMES.ORA files are correctly configured.
4) I have verified that I can make SQL*Net connections to my database from my server.
5) I have de-installed the IA software on my server.
6) I have tried to reinstall the IA software on my server, but am unsuccessful. I get the error: Error starting OracleAgent81 Service.

Does any one have any other ideas?


From: Oracle, Nahed Majzoub 15-Mar-02 22:49
Subject: Re : error 0007: Storage control blocks were destroyed

On Windows NT, the Intelligent Agent error messages are not interpreted correctly. In Oracle terms, a System error 7 should actually read:

Oracle Agent failed to run auto-discovery script nmiconf.tcl. Look in the nmiconf.log file for more information.

The Intelligent Agent has a strong dependency on the systems TCPIP and SQL*Net configuration. If the TCPIP is not installed or the SQL*Net
configuration files are missing or list incorrect information, the agent will not start.


Steps to troubleshoot this problem:

1. Go to the ORACLEHOME\NETWORK\LOG directory.

2. Open the NMICONF.LOG file using NOTEPAD or some other Windows editor.

Look for errors in the file.

3. If the TCP/IP protocol is the problem, the following error may appear in the log:
"unable to open registry key:
system cannot find the file specified"

a. Verify that TCP/IP is installed and functioning.
Test this by using the PING command from the DOS Shell.
If PING does not return a valid reply, please correct the problem
with the underlying TCP/IP protocol before attempting to start the
Intelligent Agent on NT.

4. If the problem is with the SQL*Net configuration files, the log will contain errors like:

"can't read "ListenerName" no such variable"

a. Verify the Listener Service is starting and TCP/IP is configured
in the LISTENER.ORA and TNSNAMES.ORA on the server.

b. Verify the TNSNAMES.ORA has valid TCP/IP service descriptors for the sids defined for that system. If the TNSNAMES.ORA contains
TNS aliases for non-existing sids on that system, the control blocks error can occur. Also, all sids in the LISTENER.ORA should have
TCP/IP service descriptors in the TNSNAMES.ORA.

c. For pre-8.1.7 Agents, if you have two aliases that go to different IP addresses for the same machine, remove one of the aliases. Do this
even if the machine has multiple Network Interface Cards (NICs).

Thank you for using our forum
Nahed Majzoub


From: Patrice PATRON 10-Apr-02 09:42
Subject: Re : error 0007: Storage control blocks were destroyed

I've got the same problem on two PC. I think the problem become because the system environment variable ORACLE_HOME was still defined before I install Oracle 8.1.7 over an 8.0.5 installation. After suppressing this variable everyting was OK.



Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious side…
This post first appeared at Oracleinaction  (http://oracleinaction.com/undo-and-redo-in-oracle/)by Anju Garg (Myself). I  will demonstrate that undo for DML’s is stored both in undo tablespace and online redo logs. Then, we will analyze the reaso…
This video shows setup options and the basic steps and syntax for duplicating (cloning) a database from one instance to another. Examples are given for duplicating to the same machine and to different machines
This video shows how to copy an entire tablespace from one database to another database using Transportable Tablespace functionality.
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question