Cannot communicate between 2 machines on different subnets & netmask

Hi,

I have Linux 7.1 using IPChaines and IP_FORWARDING=on.

I have an external network with the following setup:
Cisco router = 192.168.160.225
Windows 2000 = 192.168.160.226
(NetMask = 192.168.160.240)

The above machines are connected to a switch.
I then connected a network cable from the switch into my linux box via (eth3) I configured eth2 as follows:
eth2 IP=192.168.160.227
Netmask = 192.168.160.240

I am able to ping the Windows 2000 machine from the linux box.

However on my Internal network I cannot ping the Windows 2000 machine but of course I can ping eth2.
My internal network is:
eth0: 192.168.66.1
Netmask: 255.255.255.0

My IP address on that network (192.168.66.91), this is the machine I am using to try and ping the Windows 2000 machine.

I also have a direct internet connection and the router for that internet connection is listed as my default gateway.
Default gateway = 192.168.99.201
eth2: 192.168.99.202
Netmask: 255.255.255.248

Please ask if you need any clarification on the above network.

I know it may make my life easier if I use IP Filtering however I do not have the expertise to get that up and going quickly because I am looking for a solution by today.
MCI_ConsultantsAsked:
Who is Participating?
 
Computer101Connect With a Mentor Commented:
PAQed - no points refunded (of 300)

Computer101
E-E Admin
0
 
jlevieCommented:
You've got a routing problem. Right now the machines in the 192.168.160.0/24 network believe that any destinations other than that network should go to the Cisco, which is the default gateway for that network. There are two possible solutions for that. One is to include a static route on the Cisco telling it that the 192.168.66.0/24 network is reachable by the gateway at 192.168.160.227 (Linux's eth2 interface). The other solution is to add a static route to the w2k machine and tell it the same thing. With either of those routes in place you should be able to w2k machine as it'll know (either from it's static route or by a redirect from the Cisco) how to get packets back to the Linux box and thus to a client on the inside of the Linux box.

A possible complication is that you've also got a direct Internet connection via the Linux (presumably via eth1). I can't tell how you've set that up, so I don't know if additional routing is needed on Linux. Fix the routing on the 192.168.160 network and see if you can connect to w2k.
0
 
ahoffmannCommented:
echo 1 >/proc/sys/net/ipv4/ip_forward
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
The--CaptainCommented:
Please post output of:

ifconfig -a
netstat -nr
ipchains-save
cat /proc/sys/net/ipv4/ip_forward

Cheers,
-Jon

0
 
CleanupPingCommented:
MCI_Consultants:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
paullamhkgCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

PAQ - no points refunded

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

paullamhkg
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.