Solved

Yet another network problem!

Posted on 2002-05-14
22
179 Views
Last Modified: 2010-04-11
I finally decided to get rid of that phoneline network and have installed ethernet cabling with a hub and a router. The problem is that each computer can only see itself, not the other computer.  Computer1 is working fine as far as internet access (but cannot see Computer2). Computer2 can't see Computer1 and has no internet access.  On Computer1, I have "Obtain IP address automatically" set, and the router sets it to 192.168.1.100.  When I try to set Computer2 to obtain IP automatically, it doesn't work.  I have all the settings the same on both computers (gateway as 192.168.1.1, mask as 255.255.255.0, etc.)  The hub shows both computers online.  I tried to assign IP on Computer2 to 192.168.1.101, but then the DHCP radio button is not functional.  I'm sure it's a simple setting I'm missing, but I can't think of what else to check.  Some of you have helped me before and I'm sorry to be so repetitious, but every time I change something on the network, I can't get it to work again.  I just don't know enough about how networks work so I can't troubleshoot them.  

The router is set to "Obtain IP address automatically" as well, and it works fine with Computer1 but not Computer2.  DHCP is enabled, beginning with IP address 192.168.1.100 (Computer1).  

Also, Computer1 is set with DNS disabled.  I tried that with Computer2, as well as trying to enter the DNS manually, and it doesn't work.  

Workgroup is the same name on both computers. Both run Win98 (Computer1 is SE).  

WHAT am I missing???  THANK YOU so much!
0
Comment
Question by:blondy
  • 11
  • 7
  • 2
  • +2
22 Comments
 

Author Comment

by:blondy
ID: 7009995
P.S.  Also, NetBEUI, IPX/SPX, and TCP/IP are all installed.
0
 
LVL 4

Expert Comment

by:Bit_Twiddler
ID: 7010029
Have you specified which resources on each PC get shared?

If you have not then:

Select My Computer and for each resource (HD, CDR, CDRW etc.)right click on the icon representing the device and select the sharing tab. In the dialog box that appears set the device as shared and what kind of access etc. and click OK.  Do this on both machines for ech device you want to share on the network.

Note that some printers do not support network printing and may not be able to be shared without the use of a print server.
0
 

Author Comment

by:blondy
ID: 7010055
The resources are already selected to be shared on each machine.  
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 7010062
tried to assign IP on Computer2 to 192.168.1.101, but
then the DHCP radio button is not functional.
this is by design. You use one or the other, not both
Now when troubleshooting a network, start with the physical layer first
swap out the cables (switch them) and see if you get an ip address from the router (use dhcp on both)
also try a different port on the router/hub
also check in device manager and make sure there are no problems with the NIC, correct drivers assigned, etc
next delve into the protocols
from a prompt type
ipconfig /all |more
and see if it is getting assigned the correct ip info
then ping in the following order
ping 127.0.0.1
ping its own ip address
ping the router
ping the other machine
ping www.experts-exchange.com
ping 206.169.61.246 (experts-exchange's ip address)
when all else fails, remove all networking components form network neighborhood, properties
go to device manager remove the NIC (in safe mode, in case there are duplicates)
uninstall dialup networking (control panel, add/remove programs, windows setup)
reboot and re-install everything, reconfigure
0
 

Author Comment

by:blondy
ID: 7010065
The resources are already selected to be shared on each machine.  
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 7010066
also disable any firewalls (like zonealarm, blackice if present)
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 7010068
I noticed you said you have a router and a hub
why both? if the router has multiple LAN ports, connect the machines directly to those, and discard the hub
also reset the router
0
 

Author Comment

by:blondy
ID: 7010069
The resources are already selected to be shared on each machine.  
0
 
LVL 15

Expert Comment

by:samri
ID: 7010762
blondy,

> The router is set to "Obtain IP address automatically" as well, and it works fine with Computer1 but not Computer2.  DHCP is enabled, beginning with IP address 192.168.1.100 (Computer1).

Have you tried to fix a static IP to the router (maybe 192.168.1.254), and for the rest of the PC, just get it to grab from DHCP, and make sure the DHCP is also having a static IP.  Make sure your set the DHCP Option 015-Default Router to have the router IP address (192.168.1.254).

Follow the test as recommended by stevenlewis.  

If it does not work, try using static IP, and make sure each PC is pointing to the same router as the default gateway.  Anything on the router configuration?

If it still failed, I think your Win98 networking component must have been corrupted.  Try to reinstall.  In some cases, you might need to manuall delete the DLL's (not sure which one).

cheers.
0
 
LVL 31

Expert Comment

by:rid
ID: 7011515
One way to go could be first to concentrate on the hub and the computers connected to it.
1) Enable NETBEUI protocol and remove TCP/IP.
2) Verify that file and printer sharing is enabled, and share something on each box.
3) Check that computers have individual names, and belong to a common workgroup.
4) Restart all computers and try to browse network neighbourhood.
If this doesn't work, take a closer look at hardware (cables, hub ports, uplink/normal switch on hub etc as well as NIC drivers and settings on each machine).

If it works, your hardware should be fine. Then reinstall TCP/IP. Try using static IP addresses on all nodes, setting the router IP as gateway on the other ones. Enable DNS and enter suitable addresses for servers. You've got a nice ping tryout sceme above from stevenlewis.

Regards
/RID
0
 

Author Comment

by:blondy
ID: 7012337
>>>Have you tried to fix a static IP to the router (maybe 192.168.1.254), and for the rest of the PC, just
get it to grab from DHCP, and make sure the DHCP is also having a static IP.  Make sure your set the
DHCP Option 015-Default Router to have the router IP address (192.168.1.254).<<<

Samri, I don't know how to fix a static IP to the router (doesn't the router have to take the IP that is given by the cable ISP?)  How do I "grab" it (and what is "it?")  What is DHCP Option 015-Default Router?  Sorry but I don't know much about networks (OBVIOUSLY!)

The router configuration is set up with DHCP enabled and with 2 computers, using 192.168.1.100 and 192.168.1.101. I have tried setting static and dynamic IPs on Computer2 and neither works.  



0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 41

Expert Comment

by:stevenlewis
ID: 7012507
who makes the router?
0
 

Author Comment

by:blondy
ID: 7012584
Stevenlewis:  I only have a one port router; that's why I have a hub.  

ZoneAlarm is disabled on both machines.  

Device manager shows all to be fine.  

Tried different port on hub...no luck.  

Pinging:  It will ping itself and 127.0.0.1 but it times out when pinging the router or the other machine or any web site.

What do you mean when you say I should remove the NIC in safe mode in case there are duplicates?  Duplicate what?  There is only one Linksys adapter listed. Could there be one that is "hidden?"

I'm still working on other options from everyone...thanks!




0
 

Author Comment

by:blondy
ID: 7012589
The router, hub, and both NICs are Linksys.
0
 
LVL 41

Accepted Solution

by:
stevenlewis earned 250 total points
ID: 7012651
There is only one Linksys adapter listed. Could there be one that is "hidden
yes

Did you try switching the cable (to eliminate it)
lets simplify here, remove the hub from the router
you should have connectivity between the two machines just using the hub
static assign the ip addresses
machine 1
192.168.1.101
mask 255.255.255.0
gateway 192.168.1.1
don't worry about the dns entries for now
machine 2
192.168.1.102
mask 255.255.255.0
gateway 192.168.1.1
don't worry about the dns entries for now
you should be able to ping
each of the other machines
if not, try removing all the networking components from the machine that is not working now
network neighborhood, right click choose properties, and remove ALL
then go to control panel, add/remove programs, windows setup and uncheck dialup networking
then go to device manager and remove the NIC (do this in safe mode)
reboot and reinstall everything and try again
If it still doesn't work, and you have eliminated the cable as the problem, the next thisng to suspect is a faulty NIC
0
 

Author Comment

by:blondy
ID: 7012688
The router, hub, and both NICs are Linksys.
0
 

Author Comment

by:blondy
ID: 7012794
The cable is fine.  Removed router.  Uninstalled, reinstalled everything.  Still cannot ping each other.  I think you may be right about the NIC being bad.  Will pick one up tomorrow and let you know.  

BTW, the NIC was not visible in safe mode.  Sometimes it shows up in Network Neighborhood, sometimes not.  Another indication of a bad NIC.  

I'll keep you posted.

Thanks...
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 7012800
Well if nothing else you are learning a lot about troubleshooting a network LOL
0
 
LVL 31

Expert Comment

by:rid
ID: 7013028
"... I don't know how to fix a static IP to the router (doesn't the router have to take the IP that
is given by the cable ISP?)  "

The router has "two faces". One outwards, which is a DHCP client, probably, and gets the IP from your ISP, and the other inwards, which can have a static IP, in some of the "private" IP ranges. The inward side can act as DHCP server for your computers, but many times it is easier to assign static IP:s to the machines on your LAN. This, of course, means that you need to know the inside IP of your router, as this should be used as gateway address on your computers. The router also would need to be configured to work in either of these modes, if possible. Some routers can only work with DCHP on the "inside".

Whatever, hardware first in this case, I think.

Cheers
/RID
0
 

Author Comment

by:blondy
ID: 7014505
OK, it's working!!  It was a bad NIC.  (And would you believe, in the middle of all this, my power supply went bad on me so I had to run out and get one before I could even test the new NIC!  I think it was a bad power cord.)  Anyway, now the computers can see each other.  The only problem now is that the net access on Computer2 is EXTREMELY slow.  I have broadband access (cable) and it works like lightning on Computer1. I will ask this in another question so I can award points for this one.  THANKS EVERYONE!  (Steven, thanks for all the help...I upped the question by 50 points for all your expertise.  I appreciate it.  Now I'm going to go ask about the internet speed in another question.)
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 7015163
blondy glad it's working for you now. I'm usre you learned a bit here LOL
0
 

Author Comment

by:blondy
ID: 7015303
I learned A LOT!  Thanks to all who commented.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now