chmod not working on cygwin

I'm running cygwin and I change the protections with chmod but nothing happens? What do I need to do?


$ ls -l
total 2
-rw-r--r--    1 Administ None         1675 May 17 14:48 fsmake13

$ chmod -v u+x fsmake13
mode of `fsmake13' changed to 0744 (rwxr--r--)

$ ls -l
total 2
-rw-r--r--    1 Administ None         1675 May 17 14:48 fsmake13

$ whoami
Administrator
JamesHartnettAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
yorenConnect With a Mentor Commented:
You have to set your CYGWIN environment variable to "ntsec" or "ntea", depending on whether you use NTFS or FAT32. See the Cygwin FAQ entry on this for more info:

http://cygwin.com/faq/faq_4.html#SEC45
0
 
JamesHartnettAuthor Commented:
I guess this is the correct way to go but I can't understand why the rest of the people at work don't have this option set.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.