Solved

Shift Click to open new link opens a blank page

Posted on 2002-05-20
8
175 Views
Last Modified: 2013-11-18
When I shift click on a web-link to open the page in a new window, it just gives me a blank page. It should open the link in the new browser window but doesn't even put the address in the address bar. I don't know how this started to happen. The only thing that I did was to to a windows update and somehow that must have caused this to happen. I am using IE 6. Can someone tell me how to solve this? Thanx in advance.
0
Comment
Question by:skynergy
  • 7
8 Comments
 
LVL 27

Expert Comment

by:Asta Cu
ID: 7024245
Does the same thing result when you try opening a new window using the File menu and then the New Window option?

Have you applied the patches and fixes as well as running WindowsUpdate to make sure your OS and browser have the fixes installed?

Here's a recent critical patch for IE 6:

http://www.microsoft.com/windows/ie/downloads/critical/Q321232/default.asp

Asta
0
 
LVL 27

Accepted Solution

by:
Asta Cu earned 50 total points
ID: 7024263
It also helps to know if this problem is a new one and what you may have done to change your settings, environment recently, or if this problem has always existed.

Here are some other "possibilities"
A New Internet Explorer Window Does Not Always Open When You Click Hyperlinks
http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q272415&LN=EN-US&rnk=1&SD=msdn&FR=0&qry=open%20new%20window%20blank&src=DHCS_MSPSS_msdn_SRCH&SPR=IE600&

You may have a registry error, but it would help to know more about your environment and Operating system/version.

Any error messages or other problems noted?

Unable to Open a Link in New Window in Internet Explorer
http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q281679&LN=EN-US&rnk=2&SD=msdn&FR=0&qry=open%20new%20window%20blank&src=DHCS_MSPSS_msdn_SRCH&SPR=IE600&

Have you scanned your system with an updated Virus definition file to make sure you don't have an infection (worm/trojan/virus)?

Other possibilities come to mind, but will await more from you before filling this question with "maybe" types of thoughts.

":0) Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 7024268
Be sure to apply this CRITICAL update/patch, and if the problem still persists after this, try the IE Repair option.  Needless to say, it is always important to close the browser for any changes to take place.  Sometimes multiple reboots also help address the problem as well as
1) clearing browser's history, temporary internet files and 2) running maintenance (cleanup/scandisk/defrag - depending on your operating system).

http://www.microsoft.com/windows/ie/downloads/critical/Q321232/default.asp

Good luck, off to work.
Asta
0
Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

 
LVL 27

Expert Comment

by:Asta Cu
ID: 7024275
If the problem continues, give some sample links; perhaps you're trying to open a PDF file?  Perhaps the Web link has frames, etc.  Many possibilities, perhaps there are browser plugins required that you don't have installed, since IE 6 does not support the old Netscape type of plugins and any you may need will also need to be reinstalled.

Internet Explorer Opens a Blank Page with a Placeholder Icon Instead of a .pdf File in Adobe Acrobat Reader (Q305153)
http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q305153

Netscape-Style Plug-ins Do Not Work After Upgrading Internet Explorer (Q303401)
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q303401

If the problem links include Flash or Shockwave objects, you'll want to go to Macromedia and download their new/updated Players (free).

Now off to work, finally.
":0) Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 7030368
Any luck here, skynergy?
Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 7030370
0
 

Author Comment

by:skynergy
ID: 7035055
Hi Asta

Sorry that I took so long ;-)

The "Unable to Open a Link in New Window in Internet Explorer" link was the one that sorted out the problem. The solution was "Click Start , click Run , and then type regsvr32 urlmon.dll"

Thanx for your help!
Skynergy
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 7035512
Fantastic!  Thanks for the great news, Skynergy.
":0) Asta
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
In this article you will learn how to create a free basic website on Bitbucket, a git service provider. Polymer creates dynamic HTML components, which allow more flexibility than static HTML. This tutorial uses Ubuntu Linux but can also be done on W…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question