• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 186
  • Last Modified:

.htaccess file blocks virtual website

Hi,

I have an odd problem with my apache.
When I put an empty .htaccess in mu virtual web site the site isn't accesible at all.

Even if I use a working htaccess file still the same problem occurs.

What can be the problem here?

greetz

Raymond
0
rdno
Asked:
rdno
1 Solution
 
andreifCommented:
What do you get when trying open site in browser?
Does apache log say anything about this? Check both general apache log and virtual host's one.
Is there right permissions set for .htaccess? It must be readable for webserver
0
 
samriCommented:
Check the error_log as recommended by andreif.

If you copied over the working htaccess file, make sure the AuthUserFile is pointing the a valid file.  And try to use "Sarisfy any" first.  If it works, then remove the Satisft directive.

Again, the error log should be helpful.
0
 
rdnoAuthor Commented:
I posted a reply yesterday, but an error occured :o(

I don't use authentication in the .htaccess file, but only rewrite rules. That was the major problem. in the site the option FollowSymLinks was not enabled which is needed by mod_rewrite.
The error log showed this. I though I looked at it already, but I must have skipped this error.

greets,

Raymond

p.s. the apache text message "access denied" appeared.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now