• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 922
  • Last Modified:

re: Not Enough Extended Memory To Run Windows

    Yes, I have recently fixed a problem with the computer hanging up at Checking NVRAM...  by replacing the 168 pen SDRAM in it.  Now, the computer goes ahead and performs the POST, but, after the Windows 98 logo screen, I get an error message indicating Not Enough Extended Memory to Run Windows.. Press any key to continue.  When any key is pressed, I get a shut down screen.  

     Any help on resolving this issue will greatly be appreciated.

     George
0
GMartin
Asked:
GMartin
  • 3
  • 3
  • 2
  • +2
1 Solution
 
WakeupCommented:
Gmartin,

How much ram do you have?  And what version of Windows are you running again?  also how much Hard drive space do you have?  And how much of that is free?
0
 
magarityCommented:
This is a typical message from an older version of Windows when too much RAM is installed.  Please let us know what version you are using.
0
 
GMartinAuthor Commented:
I am using Windows 98
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
kiranghagCommented:
i am using 192 mb sdram in a 440lx based celeron 266.
so some problem with the 98 files should be there in ur case.
add device=c:\windows\himem.sys and device=c:\windows\emm386.exe in your configs.sys

0
 
Kyle SchroederEndpoint EngineerCommented:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q311367

This article describes your problem exactly.  Check the [TTFontDimenCache] settings in the system.ini for duplicates.

-dog*
0
 
GMartinAuthor Commented:
    What is the TTFontDimenCache settings within the system.ini file all about?  Any follow up on that will be greatly appreciated.

     George
0
 
Kyle SchroederEndpoint EngineerCommented:
Read the article, it explains it.  From what I gather, those settings control how Windows "caches" (stores in memory) the fonts on your computer.  Somehow, a program or Windows made a duplication of those settings, and then when Windows tries to process them, it generates the error you're experiencing.  The exact steps to resolve this, after booting to Safe Mode (Command Prompt Only), which you do by holding CTRL before the Win98 logo screen, then choose the option for Safe Mode command prompt only, which is generally 7.

Type cd\Windows , and then press ENTER.

Type copy system.ini system.old , and then press ENTER.

This creates a backup copy of the System.ini file with the name System.old.

Type edit system.ini , and then press ENTER.

Scroll to the [TTFontDimenCache] section of the System.ini file.

Delete all duplicate entries under [TTFontDimenCache] .

NOTE : This includes duplicate [TTFontDimenCache] headings.

The [TTFontDimenCache] section should appear as follows:

[TTFontDimenCache]
0 4=2 4
0 5=3 5
0 6=4 6
0 7=4 7
0 8=5 8
0 9=5 9
0 10=6 10
0 11=7 11
0 12=7 12
0 13=8 13
0 14=8 14
0 15=9 15
0 16=10 16
0 18=11 18
0 20=12 20
0 22=13 22

On the File menu, click Save .

To do this by using keyboard commands, press ALT+F to open the File menu, and then press S to save the file.

On the File menu, click Exit .

NOTE : To do this by using keyboard commands, press ALT+F, and then press X.

------------------
That should do it.

-dog*
0
 
GMartinAuthor Commented:
Hi Everyone:

     As always, I enjoyed reading everyones insights and thoughts regarding my question.  After care review of the comments, I must award the points to dogztar.
This decision is based upon the merit of his answer.  
The comment provided by dogztar was very methodical, well thought out, and easy to understand.  Additionally, dogztar backed up his comment with an article to further give support.  Great job!!

     The fix for the error message of Not Enough Memory to Run Windows was made possible by simply adding more memory. There was one piece of RAM which was bad, so, BIOS was only detecting and counting the one with the least amount on it, 8MB.  So, when I removed the bad RAM and replaced it with 16MB, the computer booted fine.  I did, however, have to reload some drivers because somehow many of them got corrupted.  

     In closing, I want to thank everyone for their feedback.  All comments were considered in resolving this problem.  I simply chose Dogztar's comment because of the time and effort that was put into it.

      Thanks again.  

      George
0
 
Kyle SchroederEndpoint EngineerCommented:
Well, OK....but I didn't really put that much time into it, other than searching Google with your error message.  Wakeup was probably closer on track since he asked "How much ram do you have?"  The article I found didn't really address your issue. If you had specified that you were trying to run Win98 with 8MB of RAM, then I probably would have said "Add more RAM".

In any case, the question is closed now.  Wakeup, I'll post a points Q for you since you were really closest.

-dog*
0
 
WakeupCommented:
Thanks Dog...

Didn't need em...but I will gladly accept them anyway! :)
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now