Solved

Help me to like Linux

Posted on 2002-05-23
20
706 Views
Last Modified: 2013-11-15
I've been working with MS products since 1984 - so you could call me Microsoft adept. I know a lot about all MS based operating systems that have come on the market since then.
Since a few years I hear all the buzz about this great alternative called Linux. And instead of ignoring or burying it - or even worse convict it without trying - I decided to give it a chance and I purchased Suse Linux 8.0 Professional.  I installed it on a machine with windows ME on it. This machine is on a small private network. Server of this network is a PIV also with WinME installed and that has a faxmodem (for the internet, mail and faxes - soon to be replaced by a cable modem) and has a HP G55 (all in one) print/scan solution. This network and the said devices work fine in the Win environment. Connecting the machines is through a SMC Hub.

I installed Suse 8.0 without any problem (congrats to the Suse team for this marvelous achievement) and KDE 3.0 looks very good. Think I could become used to it.
However wouldn't be on this forum if I didn't have an issue. Please take note in your answers that I'm a newbie...
Questions
1. I configured the network card with a permanent Ip no (192.168.0.18) and pointed the route towards the server (which acts as a gateway - ip 192.168.0.12) and defined the workgroup to be 'MShome' - which is the same workgroup as the server)
Problems here are
- Win Server does not see the Linux Machine
- Linux client doesn't see win machine via Konqueror (cannot connect to host localhost). I've installed 'lin...' Can't remember the exact name but when I browse the network with this tool it 'sees' the server and all shared folders.
2. I installed the printer (using the basic drivers) but nothing prints. For this printer there was a 'special driver' on one of the disks, but when I 'install' it, it doesn't install anything as far as I could see (doesn't show up in the available drivers). When going thru the files on the disk I found several html pages giving instructions on how to manually extract, compile and install the driver for this device. I was stunned. If you want to convince the public to start using linux don't include instructions like that for something that should be as simple as installing a printer. Or do you really thing 'if it is a gdi use command tar xyzg etc - if it is a non-gdi use command...' means anything to a starter ?
When I click install driver in YAST2 I expect the thing to be installed.
Anyway it should work with the basic drivers too. I looked it up thru hardware and noticed - despite my indications - it was listed as a local printer. I tried to change the connection thru this tool - pushed the scanning button (which scans the network) and guess what : it even sees the HP printer on the server !!!). Only when I try to save this setting I get an error message. Did I miss something here ? Pls help
3. My Win server is installed as a gateway and has a proxy server running, however internet nor email can be initiated. Please help
4. Wine should allow me to run Windows programs. I installed it and followed the wizard’s instructions. Without success. Even tried to edit winecnf (again something you don't ask a newbie to do) without success.

I started to like Linux but the text based manual installations remind me too much about the old dos age to be appealing to me. Understand this is a great tool for specialists, but if you want Linux to beat Windows this is an area that should be improved. I hope I'm wrong here and that someone can point me to the button I need to push... Also the network/internet/printer thing is starting to bother me.

Any help welcome    
0
Comment
Question by:Eddyd
20 Comments
 
LVL 4

Expert Comment

by:MFCRich
Comment Utility
1. When you say the Win server can't see the linux machine, are you talking network neighborhood, ping, ...?

2. MS drivers don't work with a Linux kernel.

3. This may have to wait until issue 1 is resolved.

4. I can't help here, I never Wine :)

Most Linux distro's now have graphical installs but I don't use them. Windows point-and-click stuff may be easy but it also means that you have less control over the machine.(Think of all the people who install FrontPage with IE and are now spreading CodeRed and Nimbda because they don't know they are running IIS)

0
 

Author Comment

by:Eddyd
Comment Utility
1. indeed talking about Network Neighbourhood. Ping works.
2. on the win machine indeed there is a win driver, but on the linux machine I installed the drivers that came with linux (HPIJS). I indicated I wanted a SAMBA/WINDOWS printer on printserver 192.168.0.18. Send a print instruction like that should work should it.
3.agree
4. I like wine - prefer french Bordeaux :-)
0
 
LVL 1

Expert Comment

by:nkathman
Comment Utility
You can use Samba to have the windows pc's see the linux box.  With it, you can do file and print sharing, create a wins server, etc.  On the proxy, if using netscape, go to edit, preferences, advanced, proxy configuration and set up the proxy.  Haven't had much experience with Wine, but if your looking to run IE or Office, look into crossoveroffice.org
0
 
LVL 2

Expert Comment

by:barrero
Comment Utility
1. I agree with both who preceded me. You should be able to see windows machines with Samba enabled. Normally, almost all the distros I saw there, installed samba by default, when asking for MS or windows connectivity. I presume that the group you mentioned ('MShome'), was indicated to linux when configurins the samba package when being installed.
Presumptions: TCP/IP is installed and configured, so it´s going well. SAmba is installed and you have problems there.
Suggestions: (I know it´s nos something to say to a newbie, but there is a toolt called SWAT who allows you to configure samba by point and clicking via a web interface) Once upon a time, there were some problems with encripted password when accessing systems other than Windows 95. Please take a look to the samba doc about your MS-OS, I don´t know exaclty the issues with Windows-Me. Another one, take alook where you are verifying the password (again, take a look in the samba.conf file), you have more than one way to authenticate users, you can even use a NT domain controller.
FInally, I would ask you to see the log files from the system (to verify if the server is up and running) and the log files specifically to samba, to see which error we're getting, and try to figure what is going wrong.

2. What kind of printer do you have there? Without any kind of "driver" you can see if its working by issueing this command in a prompt:
  $ echo /etc/passwd > /dev/lp0

the /dev/lp0 is the LPT1 port we know under MS-OSs. I'm printing there the file that contains the list of users, if you think it´s not to safe to do that, just print any other file.

If you can see anithing printed, the port, the cable and the printer are working fine, but if you can´t have anything printed out, at least one of those elements have a problem. If not, maybe the print out is not very "nice", so there you need a "driver".
Why am I usinog those """? because under linux the sens of driver for printers is not the same to the mean we had for MS. In fact under Unixes, we use filters instead of drivers, and now there are many utilities who try to hide those filters to the user. Especifically with SuSe I don´t know whic utility is... but there is another problem. Plesase, before going forware, verify what I asked you before...  Thanks..

3. If TCP/IP is working, I agree with nkathman, who says you how to configure thw client side of the proxy in the navigator. If TCP/IP is not working...  I also agree with the others, solve first problem 1.

4. Wine doesn't work with all windows programs, I had some problems with somw of them, but I runned in MS-Word 2000, but had problems with a little application built with Borland Delphi.


In general, please, can you send to this forum the error mesagges you got? Again, it´s maybe somthing no to ask to a newbie.. but personally I found it easier to trooblesdhot Linux than MS.

I don´t want to start a war to see which OS is better... I work with linux, NT and 2K in my servers.....  soon I´ll have solaris too :-)


(Please excuse my english... it´s not my mother tongue)
0
 

Author Comment

by:Eddyd
Comment Utility
to mr Barrero
just to clarify
1. from the Win machine I can PING the linux machine on its
ip address. Through LinNeighbourhood I can see the Win machine with all it's shared folders - incl the printer.
I can not see linux machine in Win (network neighbourhood)and vica versa (in Konquerer browse the lan gives error 'cannot connect to host localhost')

2. Printer is not on lpt1 - it's attached to the lpt port of the win machine and shared over the network

3. can soemone tell me where the internet setting are stored - tried Kinternet but that doesn't seem to work.
Tried 'netstat -r' and this shows me gateway is correctly pointing to the win ip no.

4. when starting wine only get message ' need windows executable '

 
0
 
LVL 3

Accepted Solution

by:
tibori earned 500 total points
Comment Utility
You need to have a program called SAMBA running on the Linux box for it to show up in Network Neighborhood. Let's first check if it's installed. Issue the command:
whereis samba
This should give you back output similar to the following:
samba: /usr/sbin/samba /etc/samba /usr/share/man/man7/samba.7.gz
If it gives you just "samba:" then you most likely don't have it installed(or it's not in your path). You may want to try the command: find / -name samba and see what it gives you. Anyways, if it's installed, then lets' check if it is started.Issue the command:
ps -ef | grep smb
This should give you back somethign similar to:
root      1433     1  0 10:36 ?        00:00:00 smbd -D
If the output of the command is blank, then most likely it's not running. Try one of the following:
service smb start
OR
/etc/rc.d/init.d/smb start
I'm not sure if Suse has these scripts, but if it does it'll make things easier. If you get an [OK] back from either of the above commands, it means that SAMBA started. Now you just need to configure it to set up the Workgroup name, shares, printers, etc. To do this, you need to either edit /etc/smb.conf(or /etc/samba/smb.conf), or use a web based administration tool called SWAT(makes it somewhat easier). The smb.conf file is pretty self explanatory, and you should be able to just follow the examples in there. If you need help, try "man samba" to read the manual, or of course post your question here.
0
 

Author Comment

by:Eddyd
Comment Utility
Thanks Tibori for your clear explanation.

Tried whereis samab and got same path as described so Samba is installed

tried ps -ef|grep smb and got a response, so asume it's running.

Can but only asume then smb.conf is not setup correctly.
Can you assist there ? Will look for SWAT in the meantime .

Thanks again/Eddy


0
 

Author Comment

by:Eddyd
Comment Utility
Meanwhile located SWAT

read manual and checked /etc/services and inetd.conf.
Both files already contained the required instructions (assume in suse 8 this is set per default)
Checked if Inetd was running (which wasn't) and started it (to be sure even rebooted) - however still unable to start swat by entering http://localhost:901 (901 is portnumber set in config files)

Check smb.conf to update manually. If only contains 1 parameter under (Global) which is
workgroup = Mshome
(which is the correct ms workgroup name)
The man smb did not shed any light

Any help welcome/eddy
0
 

Author Comment

by:Eddyd
Comment Utility
meanwhile able to start swat, but no luck with the rest
0
 

Author Comment

by:Eddyd
Comment Utility
Toyed around a bit with swat and managed to get the Win machine see the linux machine. Installed shares and also shares where recognised

However still have following problems :
a) can only login in shares where I allowed guest login. Have setup users in smppasswd using SWAT with id and password same as normal linux user id. Win machine keeps asking for a password, but whatever pwd I fill in is rejected
b) Linux (Konquerer) still cannot see win machine. Gives error 'cannot connect to local localhost' Bit confused here. The 'localhost' isn't that the linux machine on 127.0.0.1 ?
c) printer still doesn't work. It see the 'samba printer' on the network (in YAST), but am unable to print testpages
d) Internet still doesn't work. How do I tell the browser to use the proxy server on the win machine ?


Thanks to Tibori I came this far. When I assign points  you will be rewarded.
Will increase points to 500 if all remaining questions get solved.

rgds/eddy
 
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 3

Expert Comment

by:tibori
Comment Utility
Sounds like you're moving along nicely. Let me see if I can help some more:
>a) can only login in shares where I allowed guest login. >Have setup users in smppasswd using SWAT with
>id and password same as normal linux user id. Win >machine keeps asking for a password, but whatever
>pwd I fill in is rejected
You need the line: encrypted passwords = yes in your smb.conf
This is because Windows(by default) uses encrypted passwords. You can change this by applying a registry key, but it's best to keep it and have samba use encrypted passwords too.
>b) Linux (Konquerer) still cannot see win machine. Gives >error 'cannot connect to local localhost' Bit
>confused here. The 'localhost' isn't that the linux >machine on 127.0.0.1 ?
There are two ways to access the windows box from the linux box. One would be smbclient. This is an FTP like client that you can launch from a terminal window:
smbclient //windowsmachinename/sharename -U username
If you want to see the share in Konqueror, you'll have to mount it. Mounting will make the windows share seem as if it's a local drive. For this you'll need to do:
1. Create a directory on the local file system that you have access to: mkdir /home/yourname/<directoryname> (or /mnt/<directoryname> if you have root access)
2. Then mount the smb share: smbmount //winmachinename/sharename /your/directory/created/above -o username=<username> password=<password>
3. Go to the directory you created, and you'll see the contents of your windows share.
Optional: If you want this share to be available after booting, add the above smbmount line to the file /etc/rc.d/rc.local.

>c) printer still doesn't work. It see the 'samba >printer' on the network (in YAST), but am unable to
>print testpages
This depends on the spooling system you're using, and if it's started or not. First let's see which system(lpr, lprng, or cups) you're using:
do a "whereis cups". If this doesn't give you any output, you're most likely using lprng. Do a "whereis lpr" just to make sure it's installed. Now let's see if it's started:
ps -ef | grep lp
If this gives you back processes, then it's a config issue. If not, you can start it via:
/etc/rc.d/init.d/lpd start (or /sbin/service lpd start)
Then do a /etc/rc.d/init.d/lpd status. If it says it's running, then let's check what's in the queue:
lpq
If there's no jobs in the queue, let's try printing one:
lpr /etc/samba/smb.conf
If this works, then your printer is configured correctly for unix printing. It should then work automatically via samba, but you may need some extra configuration.I'm guessing you already have the "load printers = yes" option enabled in smb.conf?
Anyways, let's see if it works through linux directly first, then we'll try samba.
Also, which printer is it?

>d) Internet still doesn't work. How do I tell the >browser to use the proxy server on the win machine
Don't know much about this, but I'll take a look.
0
 

Author Comment

by:Eddyd
Comment Utility
Thanks Tibori,
thanks to you finally getting somewhere. really appreciate your help !

To come back on the issues :
1. swithed password encryption on and set it to 'user'. No luck. Now if the 'guest login' on 'share' level isn't restrictive I could live with this situation. Only thing I really need is to share documents on a limited number of files (public ones stored in 'my documents'). Is this the case ?
..just notices something strange. In swat there is a section 'active shares'. One of the fiels there is 'user' and 'group'. I have set up global 'share' but on share level made 2 shares : 1 folder allow guest - here the respective entries are 'nobody/nobody' (which is guest I suppose) on the other one I did not allow guest to log in and set 'username' to 'root' (one of the ids I setup in SWAT). Here the entries are 'root/root'.
Does this mean I have accidently set them up correctly and I'm actuallty entering on user level on the second share ?

2. Tried your suggestion and it works. Lan browsing still gives same error, but when I go to the 'mounted folder' I indeed can see and manipulate the files.
However
2.1 can only execute the smbmnt command from ROOT. If I try to do this on user level get error 'smbmnt must be installed SUID root for direct user mounts (500.500)'
How do I 'allow' this for a user without first having to log in as root ?
2.2 it gives error on -o invalid command. Still runs but asks for entry of a password. Bit hard to do this on bootup isn't it ?
2.3 I would like to load on startup but rc.local does not exist on my machine (Suse 8.0) + what in combination with items 2.1 and 2.2 ?

3. printer = HP Officejet G series. installed it using YAST2 - which autodetected the samba/win and suggested driver. Testpage doesn't run irrespective wether samba is running or not  
- command ps -ef |grep lp gives line ending with 'lpd waiting'
- whereis cups : /etc/cups
- whereis lpr : gives math to man/...gz (so imagine not installed)
- lpq returns : lp@linux 'lpdfilter drv=app method = auto color = yes
- lpr /etc/... gives no reaction (no error or anything)

4. internet : noted

5. ps : have to start smbd and nmbd thru swat every time I do a cold reboot. How can I startup this process on boot ?



Ps : already increased points to 500. They're yours whatever happens. Any new tech advising will get an award depending on their input.

rgds/Eddy
0
 
LVL 3

Expert Comment

by:tibori
Comment Utility
Hi Eddyd. Sorry for not responding earlier, but I've been pretty busy today :)
Alright, let's take it step by step:
1. First a question: Have you added samba users to your system already? If not use:
smbpasswd -a <username>
This user will first need to have a regular user account. Once you add a user, then you'll need to specify them in the valid user directive. If you just want guest access set "guest = yes", and "read only = yes"(or no, depending on your preference) under the share definition
;[myshare]
;   comment = Mary's and Fred's stuff
;   path = /usr/somewhere/shared
;   valid users = mary fred
;   public = no
;   writable = yes
;   printable = no
;   create mask = 0765


2.1: To change the smbmount executable to be SUID root, execute the following:
chmod u+s /path/to/smbmount
Note: This has some security implications, but IMHO not too serious if you're behind a firewall...
2.2 You should be able to give a "password=<yourpassword" flag to smbmount. At least on my system you can. This will leave you with a cleartext password in a text file...Now that I think about there's a more secure way to do this...let me check.
2.3 Sorry, it looks like in Suse, it's called boot.local(under /etc/rc.d)

3. Looks like you have CUPS, that's GREAT. So first make sure the service is started:
ps -ef | grep cups
This should return something similar to:
root       996     1  0 13:01 ?        00:00:00 /usr/sbin/cupsd
If it's not, simply start it manually:
/usr/sbin/cupsd
Then go to http://localhost:631 and check to see if you can see your printers there. You'll need to log in as root.
4.
5. To make it simple you could just add this to boot.local:
/path/to/smbd -D
/path/to/nmbd -D
OR to go about it the right way:

you just need to add a symlink to your init dir. In Redhat(what I use) this can be made simple with the command:
chkconfig --add smbd
Suse may not(or it just may) have this utility...The following should work on any system with SysV init scripts:
ln -s /etc/rc.d/init.d/smbd /etc/rc.d/rc3.d/S90smbd
ln -s /etc/rc.d/initd/smbd /etc/rc.d/rc1.d/K90smbd

What this does is create two symlinks(like shortcuts) in the rc3.d and rc1.d directories. The significance of the S90 and K90 are that the S scripts start a process, the K's kill it. The number specifies the order that it starts in(lower numbered services start first). If you take a look in /etc/rc.d/rc3.d,(do an ls -l in this dir) you'll see many symlinks to the init.d dir with various numbers. These all start services on system boot.


....sorry gotta go. I'll try to come back and finish my response tonight(or early tomorrow. Post your share definition so I can go throuhg it
0
 

Author Comment

by:Eddyd
Comment Utility
Hi Tibori,

1. yes added users (via SWAT) to the smbpasswd file so that should be ok. Myshare only has a command and path line (and a 'guest ok = yes' on one share)
Since I seem to be able to exchange files and that's all I want sofar suggest to give this one a rest. Unless you're convinced this this is required to solve printer or internet problems ?

2.1 Did that but still got error. So tried same chmod on smbmnt and now it works when logged in as a user. - SOLVED

2.2 confirm always asks password manually. Can this be one of the reason 2.3 doesn't work ?

2.3 ok found and edited boot.local. However on boot get error '246 failed to connect to <winpc> '

3. confirm cups started. However localhost:631 (port 631)cannot be reached. Can this be another number ? Where is this defined ?

4.

5. entered both commands to boot.local (before the smbmount command). SMBD runs after boot. NMBD doesn't.
Any idea ? Asume not starting of NMBD could be part of the  reason 2.3 doesn't work ?
(Tried other suggestions to but without any result)


rgds/eddy  
0
 

Author Comment

by:Eddyd
Comment Utility
2.2 solved. username and password string should be seperated by a comma.
0
 
LVL 3

Expert Comment

by:tibori
Comment Utility
ALRIGHT, glad to hear we're solving some of them. As far as a guest share, it's fine if it meets your needs. I believe it's read-only by default, so if you need write capability, you may want to add "writeable = yes" under the share definition. Definitions on this share won't affect your Internet or printing(although your settings under the [global] section may affect the latter..)
2.2/2.3 Yes you definitely need the comma :) Sorry I forgot to mention that. Could this be the problem for 2.3?

BTW, if you havent' already take a look at this excellent HOWTO for SAMBA:
http://www.tldp.org/HOWTO/SMB-HOWTO.html
3. Cups stores its config info in cupsd.conf(usually under /etc/cups). Since I'm short on time again(sorry), let me just refer you to:
http://www.tldp.org/HOWTO/Printing-HOWTO/index.html
5. nmbd controls netbios resolution if you're running a WINS server. You don't necessarily need it, since it can all go trhough broadcasts.
Let me know how far you get. I'll try to provide some more info tomorrow.
tibori
0
 

Author Comment

by:Eddyd
Comment Utility
sofar remaining issues
1. nmbd -d looks like being activated on boot, but once startup completed it isn't running. Somewhere the process is killed. Smbd runs fine. As a consequence of that the smbmount instruction is activated either as it needs nmbd.
2. printing to a samba printer. Going thru the material you pointed out. Sofar no luck
3. internet not working (via the win machine)

Any help welcome.

Ps : if you feel you can not help me any further feel free to say so. I'll then close this call and give you your reward.
0
 

Author Comment

by:Eddyd
Comment Utility
meanwhile solve item 1 myself. For your info boot.local starts before the network adapter is initiated. Put the command at the end of S05network script and now this works fine.
0
 

Author Comment

by:Eddyd
Comment Utility
also solved point 3 internet by manually setting up all proxies.

Leaves me with the printing stuff...
0
 

Author Comment

by:Eddyd
Comment Utility
almost all issued resolved thanks to Tibori. Only remaining issue is the printing issue but granting points anyway.
If Tibory is reading this, you can mail me at
ederybel at tijd dot com if you have any further help to offer or remarks to make.

Anyway - thanks a lot !!!!

rgds/Eddy
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now