Solved

Packet loss via router

Posted on 2002-05-28
20
289 Views
Last Modified: 2010-03-18
Hi,
I have a network of about 40 computers. They are connected to the Inet via router,which is a Linux (Mandrake 8.3/iptables 1.2.5)box, connected to ADSL line with Alcatel SpeedTouch Home ADSL modem. When i try to connect something from the network, I get about 70% packet loss. From the router the line works decently (~2% packet loss).
 Please, help!!!
            L.
0
Comment
Question by:Leonid99
  • 9
  • 4
  • 3
  • +2
20 Comments
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
either the driver, or the NIC, or the cable, or the hub/switch has a problem.
I'd start with exchanging the cable, then NIC ..
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
Checked it, no data loss between router and computers inside the network. It's some weird mtu problem
0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
did your router forget about window size settings?
Did you try to force set the mtu < 1500 on the NIC (not a good idea 'cause it affects LAN traffic too, but worth a try)
0
 
LVL 3

Expert Comment

by:cincin77
Comment Utility
Does the ping command also have packet loss?
As it uses 64 byte packets by default which has nothing to do with MTU? (also as it is an ICMP message nothing to do with MTU:)) )
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
I check the data loss with 'ping -s 1400 x.x.x.x'
from router it does 0% packet loss, from the internal host it does 70%
0
 
LVL 3

Expert Comment

by:cincin77
Comment Utility
what about without the -s option?
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
I check the data loss with 'ping -s 1400 x.x.x.x'
from router it does 0% packet loss, from the internal host it does 70%
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
I check the data loss with 'ping -s 1400 x.x.x.x'
from router it does 0% packet loss, from the internal host it does 70%
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
I check the data loss with 'ping -s 1400 x.x.x.x'
from router it does 0% packet loss, from the internal host it does 70%
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
I check the data loss with 'ping -s 1400 x.x.x.x'
from router it does 0% packet loss, from the internal host it does 70%
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Author Comment

by:Leonid99
Comment Utility
That's what bad connection, and computer left on overnight do :)
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
Have you tried playing with your MTU values?

Cheers,
-Jon
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
Probably not the problem, but just a thought...
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
Yes, I did. It's not mtu -- the pings get lost even on small packet sizes
0
 
LVL 3

Accepted Solution

by:
cincin77 earned 300 total points
Comment Utility
if you have w2k client try to use pathping command instead of ping, it will give you valuable information on the source of the loss(that is the links or the active devices?)
0
 
LVL 1

Author Comment

by:Leonid99
Comment Utility
it was routing problem with my ISP.
sorry for your time.
cinciny77, nice try, u get your points :))
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
Please tell us how you ISP explained 70% packet loss as "a routing problem" - this I gotta hear.

Thanks,
-Jon
0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
.. I'm interested too ..
0
 
LVL 15

Expert Comment

by:samri
Comment Utility
or maybe it's the carrier is the culprit.
0
 
LVL 16

Expert Comment

by:The--Captain
Comment Utility
Or maybe it's rabid backhoes - In any case, I wanna know.  leonid has some explaining to do, IMO...

Cheers,
-Jon
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now