Solved

Cannot login as root in Red Hat 7.3 (network connection error...)

Posted on 2002-05-28
5
553 Views
Last Modified: 2013-12-06
I have a T1 line that works fine on Windows 98.

For now I'm not even trying to get it to work on my Linux partition, just to login as root, but even that I can't.

When trying to login as root, I get the following message:

There was an error settingp up inter process communication for KDE.

Message: Could notread network connection
list //.DCOPserver_localhost.localdomain_0

Check that the dcopserver program is running.

Kind Regards
Stephane


0
Comment
Question by:stephaneeybert
  • 3
5 Comments
 
LVL 2

Expert Comment

by:olidel
ID: 7040323
Hi,

    You said that you have a T1 line. Does that mean that you want to connect to a linux box which is behind a T1 line ? It looks like that you have a problem with kdm and that you are using a graphical interface. So Could you tell us how this is working when you use a simple command line.

Thanks.

Bye.
0
 

Author Comment

by:stephaneeybert
ID: 7040394
In fact when I said a T1 line, I meant a network connection, with an Ethernet card, to the Internet.
My computer is a laptop, it has this network card that connects it to the Net.
The graphical interface is KDE. I don't know which commands to type in. I'm a novice...
0
 
LVL 3

Accepted Solution

by:
tibori earned 100 total points
ID: 7045015
If you're logging in locally(on the console), it sounds like you have your system set for runlevel 5(X-Windows), and there's a problem with your X configuration. I would try hitting Ctrl-Alt-F1 or Ctrl-Alt-F2 at the login prompt. This should get you back to a shell prompt. Log in here, and rerun XConfigurator to reset your X settings. If that goes through fine, try creating a file called .xinitrc and placing it in your home directory, with the following content:
/usr/bin/gnome-session. This will switch your desktop from KDE(which may be configured incorrectly, or missing key files), to GNOME.
If console login works, but remote login(over the T1) doesn't, check your bash(or other shell's) init(rc) file, to make sure you're not trying to start x on remote logins.
0
 

Author Comment

by:stephaneeybert
ID: 7046517
Okay I will try all of that. Cheers!
Just for info, I did not install Gnome, but just KDE.
And when logging as a normal user (non root), I can open a console anddo a su.

Now I'll be off for a few days or more.
Flying to France...

Thanks!
0
 

Author Comment

by:stephaneeybert
ID: 7237914
Sorry. I was away for quite a while.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question