Solved

Native VLAN Mismatch

Posted on 2002-05-29
13
2,242 Views
Last Modified: 2011-09-29
We have a Catalyst 2924XL with 4 port fiber module, each goes to another 2924 switch, usually port 24.  I am getting this error message on the switches that are connected to the backbone switch via fiber:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/24 (0), with SWI01_RPCHM01.rpc.net FastEthernet1/1 (1)

Of course the interface is different with all the errors, 1/1, 1/2, 1/3, 1/4.

Whats strange about this is every port on all of the switches are assigned to VLAN 1, the default VLAN.  I did a show vlan and everything looks fine.

Any Ideas?
0
Comment
Question by:tduplantis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 4
13 Comments
 
LVL 11

Expert Comment

by:geoffryn
ID: 7042828
What does a "sho cdp nei" say?
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7042967
This is the core router.

RTR03_RPCHM01  Fas 0/24   150    R   2620      Fas 0/0
RTR01_RPCHM01  Fas 0/24   153    R   3620      Eth 0/0
SWI07_RPCHM01  Fas 1/2    172    S   WS-C2924C-Fas 0/24
SWI06_RPCHM01  Fas 1/1    155    S   WS-C2924C-Fas 0/24
SWI04_RPCHM01  Fas 1/4    177    S   WS-C2924C-Fas 0/24
SWI03_RPCHM01  Fas 1/3    158    S   WS-C2924C-Fas 0/24

This is SWI07_RPCHM01

SWI01_RPCHM01.rpc  Fas 0/24 149  T S   WS-C2924M-Fas 1/2
SWI08_RPCHM01      Fas 0/23 152  T S   WS-C2924C-Fas 0/24



I'm not sure why it is saying SWI01_RPCHM01.rpc(.net), you think this can cause a problem?
0
 
LVL 11

Expert Comment

by:geoffryn
ID: 7044691
Can you post the VLAN config from both switches?
0
Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

 
LVL 4

Author Comment

by:tduplantis
ID: 7044721
CORE SWITCH:

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                Fa1/1, Fa1/2, Fa1/3, Fa1/4
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0


ONE THAT IS GETTING ERRORS:


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
SWI06_RPCHM01#
0
 
LVL 11

Expert Comment

by:geoffryn
ID: 7044824
Do you have any ports configured as trunks?
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7044892
Yes, I have 7 of them setup on the core switch. Here is config:

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SWI01_RPCHM01
!
no logging console
enable secret 5 $1$JE5M$SJwn.lTMBNQkRMevTzD0d0
!
!
!
!
!
!
spanning-tree vlan 1 priority 100
ip subnet-zero
!
!
!
interface FastEthernet0/1
 description XXXXX
 duplex full
 speed 100
 port group 1
 spanning-tree portfast
!
interface FastEthernet0/2
 description XXXXX
 duplex full
 speed 100
 port group 1
 spanning-tree portfast
!
interface FastEthernet0/3
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/4
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/5
 description XXXXX
 duplex full
 speed 100
 port group 3
 spanning-tree portfast
!
interface FastEthernet0/6
 description XXXXX
 duplex full
 speed 100
 port group 3
 spanning-tree portfast
!
interface FastEthernet0/7
 description XXXXX
 duplex full
 speed 100
 port group 4
 spanning-tree portfast
!
interface FastEthernet0/8
 description XXXXX
 duplex full
 speed 100
 port group 4
 spanning-tree portfast
!
interface FastEthernet0/9
 description XXXXX
 duplex full
 speed 100
 port group 5
 spanning-tree portfast
!
interface FastEthernet0/10
 description XXXXX
 duplex full
 speed 100
 port group 5
 spanning-tree portfast
!
interface FastEthernet0/11
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/12
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/13
 description XXXXX
 duplex full
 speed 100
 port group 7
 spanning-tree portfast
!
interface FastEthernet0/14
 description XXXXX
 duplex full
 speed 100
 port group 7
 spanning-tree portfast
!
interface FastEthernet0/15
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/16
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/17
 spanning-tree portfast
!
interface FastEthernet0/18
 description XXXXX
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/19
 spanning-tree portfast
!
interface FastEthernet0/20
 spanning-tree portfast
!
interface FastEthernet0/21
!
interface FastEthernet0/22
 spanning-tree portfast
!
interface FastEthernet0/23
 spanning-tree portfast
!
interface FastEthernet0/24
 description 12 Port 3COM Switch (Connected to PORT 1)
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface VLAN1
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.1.1
snmp-server engineID local 00000009020000502AE4B0C0
snmp-server community private RW
snmp-server community public RO
snmp-server location 2nd Floor - RPC-Houma, LA
snmp-server contact David Landry
snmp-server chassis-id Sun
banner motd ^C
WARNING: The unauthorized use of devices or the tampering with access
         to this network and its resources are CRIMINAL offenses!

             ***** ALL VIOLATORS ARE SUBJECT TO PROSECUTION *****^C
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password 7 050A081B2D495C5B4A
 login
line vty 5 15
 password 7 050A081B2D495C5B4A
 login
!
end

SWI01_RPCHM01#
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7044901
Strange, I just noticed that default gateway statement in there, that shouldn't be in there at all.
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7044907
Well it should be, but its wrong. I corrected it, wonder if that was causing the problem? Especially considering all the other switches are pointed to the proper default gateway.
0
 
LVL 11

Accepted Solution

by:
geoffryn earned 100 total points
ID: 7044927
I doubt that is your issue.  You appear to be using port groups for link aggregation but I don't see any trunk ports for carrying VLANs.  Are you using VLANs for anything?

If you were using VTP, I should see a command like this:

set trunk 2/49 on dot1q 1-1005
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7044934
Well it should be, but its wrong. I corrected it, wonder if that was causing the problem? Especially considering all the other switches are pointed to the proper default gateway.
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7044938
We are not using vlans for anything.
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7047041
This has been resolved and was a cosmetic error only.  One of our switches was running Version 12.0(5.4)WC(1) which has a bug associated with CDP version 2.  We set all switches to CDP version 1 and the error went away.  Thanks everyone for your responses.
0
 
LVL 4

Author Comment

by:tduplantis
ID: 7047045
Thanks Geoffryn for your help on this, I called Cisco to get is resolved, but I learned a lot from our discussion.  Have a great one!
0

Featured Post

Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question