Solved

Folder Permissions

Posted on 2002-06-02
7
257 Views
Last Modified: 2012-05-04
I need a folder that I can save files in but not be able
to delete anything in.  This sounds pretty easy to do. But
when I set the permissions to not allow deleting
subfolders and files I cannot save files to the folder.  
It creates the file in the folder but the file is empty.  
It tells me that the folder has read-only permissions.  
For the permission settings I allowed everything except
the two delete options.  

I can copy files to the folder.  Once the file is in the
folder I can open it but I cannot save the file.

Is there anything I can do?

Mike

0
Comment
Question by:mfair
7 Comments
 
LVL 2

Expert Comment

by:gikam
ID: 7050439
U cannot save the file already there because it has the same name. A save of an open file first does a DELETE of the old file than a write. So u must save the file under a different name!
luck
0
 
LVL 1

Expert Comment

by:igore
ID: 7050702
Go into Advanced view on file permissions for the folder and make sure the groups (or Users) you want to grant access have all boxes EXCEPT Delete, Delete Subfolders and Files, Change Permissions & Take Ownership.  This will allow you to save to the file but will prevent you from deleting it.
0
 

Author Comment

by:mfair
ID: 7064953
This did not work.  It says that folder is marked as read-only.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 2

Expert Comment

by:gikam
ID: 7069250
U said u can copy files to the folder!!!!
how does it say  'readonly'?????
0
 

Author Comment

by:mfair
ID: 7073027
Ahh so you now see the problem.  

It actually creates a file in the folder but it is empty.  But, yes, it does say folder is marked as read-only, when in reality it is not.  I think the easiest way for you to see this is to try it yourself, if you haven't already.

Thanks
0
 
LVL 2

Accepted Solution

by:
gikam earned 200 total points
ID: 7077390
I try it and it's working
u have to have the following permissions settings: on that folder:
in the sharing tab > Do not share
in  the security tab > grooup everyone only
all 6 allow boxes greyed
all 6 deny boxes empty
(allow inheritable... checked, but i think is not important)
clic Advanced
clic view/edit
just check the 2 boxes in the deny column, add thats all
hope i did'n forget something
luck



0
 
LVL 1

Expert Comment

by:netwiz562
ID: 8961191
---- CLEAN UP ----

mfair,
No comment has been added lately (402 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: [ Award points to gikam ]

Please leave any comments here within the next seven days.

¡PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

------------------------------
Rajiv Makhijani
EE Cleanup Volunteer
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Do you use a spreadsheet like Microsoft's Excel?  Have you ever wanted to link out to a non excel file on your computer or network drive?  This is the way I found to do it!
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question