Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 219
  • Last Modified:

VB session freeze

Notes client & server v5.0.8 running on W2000.
Im using notes-api thru Domino COM object.
I have 2 programs running, first is a NT service running as other NT user, all ok.
Second - with problem - is run in foreground as me (remote login), ran thru VB's IDE environment.
Then all notes-services (even server) freeze on this line:
Set sess = New NotesSession

- Any idea ?
0
Gunsen
Asked:
Gunsen
  • 4
  • 3
  • 2
  • +2
1 Solution
 
snocrossCommented:
I'm not a VB expert but should it not be 'DIM sess as New NotesSession' instead of SET?
0
 
GunsenAuthor Commented:
Dim sess = New NotesSession
...is same as the one i use....
Dim sess As NotesSession
Set sess = New NotesSession
0
 
snocrossCommented:
Hmmm... never done it that way.  Can you try without the extra step and see if the same thing happens or is that something you do regularly with no problems?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
GunsenAuthor Commented:
Actually its the same code as i did with the NT service program.  And i tried late binding as from lotus KB:
Dim session
Set session = CreateObject("Lotus.NotesSession")
0
 
HemanthaKumarCommented:
Hi Gunsen,

The way you access the Domino object via com is mentioned in Lotus help. It should be the one you just commented.

New NotesSession means nothing in vb, it will check for its library for a class called NotesSession. Since it doesn't have it fails. So proper use would be

Dim session
Set session = CreateObject("Lotus.NotesSession")

~Hemanth
0
 
HemanthaKumarCommented:
More info on Domino com objects can be found in this document
ftp://ftp.lotus.com/pub/lotusweb/devtools/comdoc.chm

0
 
GunsenAuthor Commented:
Still doesnt work.  Is there any limitations on instanciation and use of this COM object, with several differt NT/AD accounts ?
0
 
GunsenAuthor Commented:
Ok, found the problem.
The user profile for this W2000-user was corrupted...
0
 
HemanthaKumarCommented:
Good !
0
 
zvonkoCommented:
Hello Gunsen,

be so kind and delete this question or ask here to refund your points and let the question be viewed for reference:
http://www.experts-exchange.com/commspt

Otherwise it blows our abandoned questions count :-)

Thanks,
zvonko

0
 
MoondancerCommented:
300 points refunded and item moved to our PAQ at zero points rather than deleting it so that others may benefit from the help given here.
Thanks to all,
Moondancer - EE Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now